Subject: Re: [DNSOP] Interim Meeting on Special Names and RFC 6761

From: str4d <[email-masked]>
Date: Thu, 9 Apr 2015 02:48:29 +0000 (UTC)

Tim Wicinski wrote:
> All,
> 
> As we announced in Dallas, we’ve decided to have a separate
> meeting on Special Names and RFC 6761 topics.   We're planning on 
> scheduling this the week of April 13th; with Thursday, April 16th 
> as an initial choice.

Thanks for planning this :)

As someone who has an interest in this particular meeting but has
never watched or participated in IETF or DNSOP meetings before, how
will this meeting be conducted? How do people choose to watch or
participate? The only information I can find that might be related is
about IEFT interim meetings [0], but there is no scheduled interim
meeting for this topic [1]. Is there another mailing list or website I
should be following for more information?

[0] https://www.ietf.org/meeting/interim-meetings.html
[1] https://www.ietf.org/meeting/interim.html

> 
> If folks have any preference for a date, or conflicts with this 
> one, please let us know. We plan on having the meeting at 2pm UTC, 
> which would translate to 4pm CEST, 10am EST, 7am PST, and 11pm
> JST. Other suggestions are also welcome-- no time is perfect for 
> everyone but we’re trying to accommodate the widest range of 
> participants that we can.

I haven't seen any further communication (on this ML) about the
meeting, so I assume the specified date and time is still the case?
Friday would work better for me than Thursday (which I can't do at 2pm
UTC), but I'm just one person.

> 
> We’re working on a detailed agenda but the initial plan is to 
> attempt to address both specific drafts and some of the 
> larger-scale issues we’re seeing around the administration of the 
> special-use domain names registry.

Sounds good. I look forward to seeing these issues nailed down.

str4d

> 
> thanks Tim/Suzanne
> 
> _______________________________________________ DNSOP mailing list
>  [email-masked] https://www.ietf.org/mailman/listinfo/dnsop

---

From: joel jaeggli <[email-masked]>
Date: Wed, 8 Apr 2015 20:57:41 -0700

> Thanks for planning this :)

Dates are actively being looked at, the development of the topic is
taking longer than was anticipated prior to the meeting.

I'm not the chair, but I think we can be assured that there will be an
update soonish and proposed dates will be outside the notification window.

> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 9 Apr 2015 01:15:01 -0400

On 4/8/15 10:48 PM, str4d wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA512
>
> Tim Wicinski wrote:
>> All,
>>

Hi

Suzanne and I met earlier today, in an effort to start setting the 
agenda. We both realized between travel and the larger problem space, we 
needed more time to get this right.

We're now proposing the week of May 11th, 2015.  The chairs don't wish 
to inflict meetings on the working group for Monday or Friday.  We are 
considering Thursday, May 14th 1400 UTC, but will welcome any and all 
opinions on this matter.

Suzanne is drafting an initial agenda and should be forthcoming by 
week's end.  Any suggestions for items are welcome.

thanks

> -----BEGIN PGP SIGNATURE-----
>
> iQIcBAEBCgAGBQJVJehTAAoJEBO17ljAn7PgHiUP+wUdnGPa4R8mn/h1q5Uea28O
> xJChFJBvgvcKv63MAgx9DzuAgSIFokSV+RPtOrJU7j7n3+nidLEnR81Fn44Nu7H4
> wZeXht2ig/DmtIhBYEw5yy3G7vmQF1b+t8c4ev53JzkeOmYefaRVgDQN97MLy49u
> aRBiEOSRY83ax5B9C/10o7MIcB5K5JIRKhy5tHUirc28RimruuiHYh/j8fURtk8a
> qsyGxGLIRT9j64E6PXXLw4o8f90KoX4DWnmdweVnQRaEVxnRoz5btt8PR/9YHLpK
> S+A0aMM0YvphECataGb+xOT6lhE7ObScyPA7UY0Wgra8/Y4JqSja3wBQBfjivnAm
> vd/7qtkFMtRJwd6IJjyL2hzsBd+iIrbrUi8GG5vJXMZzpdg0umte8z0Siq4AeGkw
> 2I9X6a4+Dg/Xbwx5Ar/hC81IxPRNSVwHZ3SFjnEvL2WHofsUF1HchnblvwLVOW/e
> rV/ypgfx/Ii8we0FtgBrqJm25f8JKJVdcfW8K790pE+RI+wUAFjmhYyY2ken6GC3
> 1nwfEJyxoqJZOtHQRP2yXaOosGTFa4nndH5NvlmyVgL3iX/xCFKNnfDD/QhkUPr4
> jAN+j3WlLElRTKLGUGxrrf8hXrFHMw7sARTXgTniant3/pMbrr6LRzYyqaTM8uwL
> 7jEpFZ7Hc6w4O4vILK2b
> =qwv/
> -----END PGP SIGNATURE-----
>

---

From: Edward Lewis <[email-masked]>
Date: Fri, 10 Apr 2015 15:00:54 +0000

May 14 0700-0830 UTC (If I did the math right) is the RIPE 70 DNS-WG
meeting.[5]

[5] - https://ripe70.ripe.net/programme/meeting-plan/dns-wg/

That may be "good" or "bad" - UTC 10 (MET/CET=noon) overlaps some portion
of the rest of the RIPE meeting.  ("Open source" runs to 1030UTC.) [6]

[6] - https://ripe70.ripe.net/programme/meeting-plan/

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 14 Apr 2015 11:54:46 -0700

On Apr 8, 2015, at 10:15 PM, Tim Wicinski <[email-masked]> wrote:
> We're now proposing the week of May 11th, 2015.  The chairs don't wish to inflict meetings on the working group for Monday or Friday.  We are considering Thursday, May 14th 1400 UTC, but will welcome any and all opinions on this matter.
> 
> Suzanne is drafting an initial agenda and should be forthcoming by week's end.  Any suggestions for items are welcome.

Anything further on this, such as a specific date/time?

--Paul Hoffman

---

From: Warren Kumari <[email-masked]>
Date: Tue, 14 Apr 2015 16:02:32 -0400

> Anything further on this, such as a specific date/time?

Hopefully one that will for for those folk who a: live in Europe and /
or b: will be at DNS-OARC and the DNS track at RIPE...

Seeing as Interims are supposed to be announced >=30 days in the
future I'm guessing not the 14th of May...

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Alec Muffett <[email-masked]>
Date: Tue, 14 Apr 2015 20:28:50 +0000

On Apr 14, 2015, at 1:02 PM, Warren Kumari <[email-masked]> wrote:
> future I'm guessing not the 14th of May…

Hi All,

Per this topic, I have uploaded v-01 of draft-appelbaum-dnsop-onion-tld; differences are viewable at:

http://www.ietf.org/rfcdiff?url1=draft-appelbaum-dnsop-onion-tld-00&url2=draft-appelbaum-dnsop-onion-tld-01 <http://www.ietf.org/rfcdiff?url1=draft-appelbaum-dnsop-onion-tld-00&url2=draft-appelbaum-dnsop-onion-tld-01>

…and the diff largely consists of some technical simplification, thanks & acknowledgements, and typos.

I would also like to take this opportunity to correct a timeline for the potential death of existing “.onion” TLD certificates in the instance that the “.onion" special use domain is not registered in the near-to-medium term; this correction arises from a misunderstanding on my part of the results of CA/B Forum Ballot 144, and is not a substantial error (off by one month) but I would like it to be clear for all interested parties.

  -a

== Summary ==

All “.onion” SSL certificates will be revoked if “.onion” is not approved as a special use TLD on/by November 1st 2015; if “.onion" is approved then the certificates will persist without action being required.

= Timeline =

== March 2014 ==

CA/B Forum approve Ballot 144, paving a route to “proper” SSL Certificates for Onion Sites

== Current Day Goes Here ==

Hello world.

== 1 May 2015 ==

All existing ".onion” SSL Certificates which were issued under the “local names” exception “must” be revoked by their issuer, the expectation being that the certificate holder will receive a new Ballot-144-compliant “EV” Onion certificate.  This is what i was not formerly clear regarding, and see below because...

== 1 October 2015 ==

The "Local Names” exception, under which SSL Onion certificates were originally issued, dies; this will doubly-kill all the Onion certificates, however the Ballot-144-compliant “EV” Onion certificates have until…

== 1 November 2015 ==

…which is the CA/B Forum “deadline” for IETF to approve “.onion” as a TLD; if “.onion” is not approved by this time then the certs will be “turned off” / killed by the certificate authorities.

—
Alec Muffett
Security Infrastructure
Facebook Engineering
London

---

From: Ted Lemon <[email-masked]>
Date: Tue, 14 Apr 2015 21:52:32 -0400

> future I'm guessing not the 14th of May...

If this is a virtual interim two weeks is sufficient.   I thought this _was_ a virtual interim.   Not so?

---

From: joel jaeggli <[email-masked]>
Date: Tue, 14 Apr 2015 19:05:14 -0700

> If this is a virtual interim two weeks is sufficient.   I thought this _was_ a virtual interim.   Not so?

It is.

---

From: Warren Kumari <[email-masked]>
Date: Tue, 14 Apr 2015 23:04:09 -0400

On Tuesday, April 14, 2015, Ted Lemon <[email-masked]> wrote:

> On Apr 14, 2015, at 4:02 PM, Warren Kumari <[email-masked]
> <javascript:;>> wrote:
Nah, I got it wrong -- I'd thought it was 30 days for any interim, not only
in person...

My bad.
W

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 16 Apr 2015 15:34:53 -0400

> Anything further on this, such as a specific date/time?

We know this is the week of RIPE, which complicates things, but this 
week was the best of a bad lot.

Looking at the RIPE calendar, we have a few suggestions:

1) Tuesday May 12, 1600 UTC (1400 RIPE Local time), 12 Noon EDT, 9am PDT

2) Wednesday May 13, 1600 UTC(1400 RIPE Local time), 12 Noon EDT, 9am PDT

Thursday is out for several reasons.

We are leaning towards 1) Tuesday Slot, unless we hear an overwhelming 
outpouring either way.

Thanks
tim

---

From: Edward Lewis <[email-masked]>
Date: Thu, 16 Apr 2015 19:47:33 +0000

This time, Tim, the time zone math is wrong. ;)  (Referring to a previous
off-list reply.)

1600UTC is 1800 CET (RIPE is in +0200 this time).

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 16 Apr 2015 16:04:12 -0400

I was even referring to http://www.worldtimebuddy.com/ for all my time 
zone calculations.  Sigh.

tim

---

From: Tim Wicinski <[email-masked]>
Date: Wed, 22 Apr 2015 15:07:07 -0400

All

We've finalized the Interim Meeting to discuss the questions around RFC 
6761 and the "Special Names" Registry.

Details:

Date: Tuesday, 12 May 2015
Time: 1600-1800 UTC (1200-1400 EDT)

An agenda is coming together, but all drafts that address this issue are 
currently up for discussion

JOIN WEBEX MEETING:
https://ietf.webex.com/ietf/j.php?MTID=me1390ebc21ee8ab1b9dfe4a4363cff17
Meeting number: 649 835 476
Meeting password: 1234

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada)
1-650-479-3208 Call-in toll number (US/Canada)
Access code: 649 835 476

Drafts:

http://datatracker.ietf.org/doc/draft-lewis-user-assigned-tlds/

http://datatracker.ietf.org/doc/draft-chapin-additional-reserved-tlds/

http://datatracker.ietf.org/doc/draft-appelbaum-dnsop-onion-tld/

http://datatracker.ietf.org/doc/draft-wkumari-dnsop-alt-tld/

http://datatracker.ietf.org/doc/draft-grothoff-iesg-special-use-p2p-names/

http://datatracker.ietf.org/doc/draft-cheshire-homenet-dot-home/