Subject: [DNSOP] Next steps for draft-ietf-dnsop-dns-terminology

From: Paul Hoffman <[email-masked]>
Date: Tue, 12 May 2015 12:52:29 -0700

Thank you for all your input. We are processing it now, particularly Tony Finch's long list. The chairs have told us that they're willing to extend the WG Last Call, and it will take us more time to integrate this into a new Internet Draft and respond, so please wait until we have. We definitely want more comments after we have issued the new draft and our follow-up comments.

--Paul Hoffman

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 14 May 2015 05:31:31 -0400

Paul is correct.  I wanted to extend the WGLC 2 weeks till May 22, 2015.

I believe our goal is to leverage expediency over completeness - to move 
the document into official publication. If anything is missing, it can 
be addresses in a -bis document within the next year.

thanks
tim

On 5/12/15 3:52 PM, Paul Hoffman wrote:
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Tony Finch <[email-masked]>
Date: Fri, 15 May 2015 09:40:59 +0100

Another item for section 7:

DNS operator -- an entity responsible for running DNS servers. For a zone's authoritative servers, the registrant may act as their own DNS operator, or their registrar may do it on their behalf, or they may use a third-party operator.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 15 May 2015 07:20:44 -0700

> DNS operator -- an entity responsible for running DNS servers. For a zone's authoritative servers, the registrant may act as their own DNS operator, or their registrar may do it on their behalf, or…

I'm OK with the first sentence, but not the second, given that many authoritative servers at various levels don't have registrants or registrars. There are DNS operators well outside the registration model.

If the WG wants this term, I propose adding it to section 5 instead, with the definition being :

DNS operator -- A person or organization responsible for running a DNS service. This can apply to both recursive servers and authoritative servers (where the operator is, or has been chosen by, whomever is responsible for the zone).

--Paul Hoffman

---

From: Tony Finch <[email-masked]>
Date: Fri, 15 May 2015 15:30:39 +0100

Paul Hoffman <[email-masked]> wrote:
>
> I'm OK with the first sentence, but not the second, given that many
> authoritative servers at various levels don't have registrants or
> registrars. There are DNS operators well outside the registration model.

Indeed, but I wanted to make the point that the RRR model is actually an
RRRO model, and leaving out the O is a common mistake.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Thames, Dover: North becoming variable, then southwest 3 or 4, increasing 5 or
6 later. Slight or moderate. Rain later. Good, occasionally poor later.

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 17 May 2015 16:59:42 -0700

> DNS operator -- an entity responsible for running DNS servers. For a zone's authoritative servers, the registrant may act as their own DNS operator, or their registrar may do it on their behalf, or…

It was pointed out to me offline that I was taking the term "DNS operator" too far, and that this is really part of the registration model. (I found it in RFC 2181 in the general sense, but that seems to be a one-short use of the term).

So, I'm OK with the above definition if other folks here are.

--Paul Hoffman

---

From: manning <[email-masked]>
Date: Sun, 24 May 2015 14:46:41 -0700

actually, the ICANN bylaws agree with your more liberal (RFC 2181-style) understanding…

"In particular, all sub domains shall be allowed to operate their own domain name servers, providing in them whatever information the sub domain manager sees fit (as long as it is true and correct).”

manning
[email-masked]
PO Box 12317
Marina del Rey, CA 90295
310.322.8102