Subject: [DNSOP] root name server experiment (Yeti-DNS), project announcement

From: Paul Vixie <[email-masked]>
Date: Thu, 07 May 2015 23:16:40 -0700

Announcing an experimental root name service (Yeti-DNS) intended to allow wide scale network science using the IANA name space but without perturbing the IANA root name server system. This three-year project will begin with the following inquiries:

1. Can root name service succeed if it is only connected via IPv6 (and never via IPv4)?
2. Can we change the DNSSEC "ZSK" more frequently, perhaps every two weeks?
3. Can we change the DNSSEC "KSK" more frequently, perhaps every six weeks?
4. How many root name servers is enough? How many is too many?
5. Can we add and delete root name server operators frequently, such as every month
6. Can the IANA name space be served by more than one set of root name server?

Other experiments can also be proposed and we expect a "big tent" response to same. At all times during this project, the DNS name space served by our experimental servers will precisely mirror the IANA name space, including all TLD data and TLD meta-data. The only change we will make will be in the apex NS RRset (which denotes the root name server names) and to the DNSSEC data (keys) and meta-data (signatures). This project will have its own DNSSEC validation key and its own "hints file".

How to participate:

We welcome interested parties in three tranches:

1. Authority server operators, able to contribute and operate IPv6-connected name servers which will respond to queries from all over the Internet. Unicast or anycast, load balanced clusters or single servers -- it's up to you how you wish to organize your name server. We ask only that you collect your query traffic (scripts will be provided) and upload your collected traffic to a central server for use by interested researchers.
 
2. Recursive server operators, able to tolerate experimental infrastructure which is reachable only by IPv6. You would simply download the project "hints" file and DNSSEC validation key, and continue as before. It is your traffic that will drive the measurements that are the real goal of this project. You would be wise to use this in non-production environments in case one of the experiments running upstream of you has side effects.

3. Interested researchers, whether academic or commercial, are invited to download our collected data including packet traces and log files, for independent or collaborative network science inquiry. Such research is the ultimate goal of this project, and we will publish a bibliography of technical reports shared with us.

This is an independent project, unattached to and unauthorized by any existing Internet governance or "I-star" body. Our goal is to discover the real limits of DNS root name service at scale. All project activities will be as transparent as possible, and all participation will be both voluntary and informal. There will be no corporate entity in charge, no contracts, no budget or fees -- just hard operational research in the best traditions of the Internet.

Please feel free to reach out to any or all of the project's self-organized coordinators with your comments, questions, and especially, your indication of willingness to operate an authority name server as part of this experiment.

[email-masked] (Davey Song)
[email-masked] (Akira Kato)
[email-masked] (Paul Vixie)

You can also visit the project's web site, at

http://yeti-dns.org/

---

From: Shane Kerr <[email-masked]>
Date: Fri, 8 May 2015 08:44:21 +0000

All,

On Thu, 07 May 2015 23:16:40 -0700
Paul Vixie <[email-masked]> wrote:

> Announcing an experimental root name service (Yeti-DNS) intended to
> allow wide scale network science using the IANA name space but
> without perturbing the IANA root name server system.

...

> Please feel free to reach out to any or all of the project's
> self-organized coordinators with your comments, questions, and
> especially, your indication of willingness to operate an authority
> name server as part of this experiment.
> 

FYI, I'll be working on this project as well, on behalf of BII (my new
employer).

If you want to discuss this project in person and are going to be in
Amsterdam at either the DNS-OARC workshop (starting tomorrow,
2015-05-09) or the RIPE meeting (starting Monday, 2015-05-11) then
please come and talk to me.

I hope to see you there!

Cheers,

--
Shane