Subject: Re: [DNSOP] Working Group Last Call draft-ietf-dnsop-isp-ip6rdns

From: "Howard, Lee" <[email-masked]>
Date: Mon, 2 May 2016 21:03:20 +0000

>So, ISPs not doing reverse DNS for IPv6, like my current ISP, are making it
>impossible to use your own mail server to deliver mail over IPv6. I think
>they are doing a serious disservice to the open internet.

That's a separate conversation. If your ISP allows you to run a mail server on the service you buy, they have several options for how to populate rDNS records, as listed in the document. If they do not, then they still have options for how (or whether) to populate PTR records.

For what it's worth, MAAWG and BITAG (among others) recommend blocking port 25 unless you know there's a mail server there. https://www.m3aawg.org/sites/default/files/document/MAAWG_Port25rec0511.pdf  http://www.bitag.org/documents/Port-Blocking.pdf

Lee

________________________________

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 3 May 2016 17:14:00 +0200

On Mon, May 02, 2016 at 09:03:20PM +0000,
 Howard, Lee <[email-masked]> wrote 
 a message of 159 lines which said:

> If your ISP allows you to run a mail server on the service you buy,

I think this nicely summarizes the disagreement. My ISP does not have
to "allow" me to do this or that. I pay for an Internet access, I
want an Internet access and the ISP is not a nanny regulating me! 

> For what it's worth, MAAWG and BITAG (among others) recommend
> blocking port 25 unless you know there's a mail server there.

MAAWG also recommended to block port 53. I do not feel in agreement
with this cartel of big telcos.

---

From: "Howard, Lee" <[email-masked]>
Date: Tue, 3 May 2016 16:05:35 +0000

>want an Internet access and the ISP is not a nanny regulating me!

I would not presume to know what service you have contracted with your ISP to provide you. It sounds like you object to your ISP's terms, not this draft telling ISPs how they might populate or delegate reverse DNS.

>with this cartel of big telcos.

Regardless of what we might wish, there are two possibilities:
1. Your ISP permits mail servers to be run by customers. The document acknowledges that rDNS is usually required for mail servers, and describes several options for how to populate the rDNS.
2. Your ISP does not permit mail servers to be run by customers. The document describes several options for how to populate the rDNS, and what to consider in deciding whether to do so and which method to use.

Does your objection to the tyranny of your ISP mean that this document is not worth publishing?
I don't think port blocking is within the charter of DNSOP.

Lee