Subject: [DNSOP] [Technical Errata Reported] RFC7871 (4735)

From: RFC Errata System <[email-masked]>
Date: Thu, 7 Jul 2016 20:55:47 -0700 (PDT)

The following errata report has been submitted for RFC7871,
"Client Subnet in DNS Queries".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7871&eid=4735

--------------------------------------
Type: Technical
Reported by: Robert Edmonds <[email-masked]>

Section: 13

Original Text
-------------
   7.   Due its internal implementation, ANS finds a response that is
        tailored for the whole /16 of the client that performed the
        query.

   8.   ANS adds an ECS option in the response, containing:
[...]
        *  SCOPE PREFIX-LENGTH set to 0x30, indicating a /48 network.

Corrected Text
--------------
   7.   Due its internal implementation, ANS finds a response that is
        tailored for the whole /48 of the client that performed the
        query.

   8.   ANS adds an ECS option in the response, containing:
[...]
        *  SCOPE PREFIX-LENGTH set to 0x30, indicating a /48 network.

Notes
-----
The prose description in step 7 does not match the ECS option described in step 8. Either both should say "/16" or both should say "/48". Probably /48 was meant, since a /16 would be a huge amount of IPv6 address space.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7871 (draft-ietf-dnsop-edns-client-subnet-08)
--------------------------------------
Title               : Client Subnet in DNS Queries
Publication Date    : May 2016
Author(s)           : C. Contavalli, W. van der Gaast, D. Lawrence, W. Kumari
Category            : INFORMATIONAL
Source              : Domain Name System Operations
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Wilmer van der Gaast <[email-masked]>
Date: Fri, 8 Jul 2016 16:21:41 +0100

On 8 July 2016 at 04:55, RFC Errata System <[email-masked]>
wrote:

> The prose description in step 7 does not match the ECS option described in
> step 8. Either both should say "/16" or both should say "/48". Probably /48
> was meant, since a /16 would be a huge amount of IPv6 address space.
>
> Seems correct to me. Probably a copy-paste oversight from IPv4 to IPv6.

---

From: Wilmer van der Gaast <[email-masked]>
Date: Fri, 8 Jul 2016 16:22:21 +0100

On 8 July 2016 at 16:21, Wilmer van der Gaast <[email-masked]> wrote:

>> The prose description in step 7 does not match the ECS option described
>> in step 8. Either both should say "/16" or both should say "/48". Probably
>> /48 was meant, since a /16 would be a huge amount of IPv6 address space.
>>

(And when I say correct, I mean I agree with the correction, not with the
original text.)