Subject: Re: [DNSOP] My assessment of .homenet as described during the WG session yesterday.

From: Terry Manderson <[email-masked]>
Date: Thu, 30 Mar 2017 20:46:39 +0000

Dear WGs (HOMENET and DNSOP)

Based on the reviews from many folk, the discussions in DNSOP and HOMENET, the clarifying questions and responses during the HOMENET session at IETF98, a number of other DNS expert level discussions I have had, and the IAB statement [1] my final assessment on the HOMENET domain is as follows.

A TLD request is not the ideal architectural direction that would encompass the goals of the greater Internet along with the ethos and scope of the IETF.

I shall be returning the document (draft-ietf-homenet-dot) to the WG to consider and find consensus on a domain under .ARPA

The already stated technical assessment is a .ARPA subdomain can satisfy the requirement for a special use domain, in addition to being resolvable in the DNS with the requested characteristics. The WG should consider the situations where the name of the device is escalated to the user, not that I believe the WG should engage in UI/UX design, but to ensure that if it is desired by the WG that the name be suitably obfuscated, HOMENET features should exist to ensure that.

Thanks
Terry

[1] https://www.iab.org/documents/correspondence-reports-documents/2017-2/iab-statement-on-the-registration-of-special-use-names-in-the-arpa-domain/

On 29/03/2017, 3:32 AM, "DNSOP on behalf of Terry Manderson" <[email-masked] on behalf of [email-masked]> wrote:

    Dear HOMENET and DNSOP WG(s),
    
    Wearing the INT AD hat.
    
    Firstly, thank you to the DNSOP WG for the deep review, thoughts, and considered responses to my request for review.
    
    Secondly, my apologies for not sharing my throughs before the HOMENET session. It would have been impractical to do so as this is a very (VERY) fluid situation with IETF leadership also engaged in discussions.
    
    This is simply an iteration of my description of the current situation as delivered yesterday. Do be aware that conversations are continuing and you should NOT take this as a declarative statement. During the HOMENET WG session I specified that for this topic I am comfortable answering _ clarifying _ questions. The same applies here. My answers may or may not change due to the fluid nature of the concern and I hope you appreciate that.
    
    My summary of the situation is this.
    
    1) .homenet _COULD_ be added to the special use domain registry based on RFC6761 
    
    2) The expected future operation of HOMENET resolution for DNSSEC validating stub resolvers requires a break in the DNSSEC chain of trust.
    
    3) To achieve "2", the document _additionally_ asks IANA to insert an insecure delegation into the root zone
    
    4) The ask for "3" is not covered in IETF policy terms, in fact it tries to put an entry into someone else's registry (the root zone), and will require a set of collaborative discussions with the ICANN community and a new process that handles this situation. There are no expectations that this process will be defined in a reasonable time for the uses of HOMENET.

    Options, possibly not an exhaustive list
    
    A) seek a .homenet special use domain with the request for an insecure delegation in the root zone. (This is what the document asks for NOW, and here we are)
    
    B) seek a .homenet special use domain WITHOUT the delegation request AND ask the IETF/IESG/IAB to commence the discussion with the ICANN community to achieve an insecure delegation
    
    c) seek a <SOMETHING>.arpa insecure special use delegation
    
    d) go for "B" and if that doesn't work shift to "C"

    Each of these have different positive and negatives in a raw technical sense, UI design desires, and policy and political frames.
    
    Again, this situation is fluid and as discussions evolve I will provide more information when it is appropriate. In the mean-time I would very much like everyone to take a calming breath and understand that I am taking a very pragmatic view of this concern.
    
    Cheers,
    Terry
    INT AD

---

From: Ted Lemon <[email-masked]>
Date: Thu, 30 Mar 2017 15:54:21 -0500

Thanks, Terry!  I know this wasn't a fun discussion, but it is good to get
a clear answer that sets or expectations, so thanks for that!

---

From: George Michaelson <[email-masked]>
Date: Thu, 30 Mar 2017 18:50:41 -0500

Thank you for a quick, informed and above all open decision Terry.

-George

On Thu, Mar 30, 2017 at 3:54 PM, Ted Lemon <[email-masked]> wrote:
> Thanks, Terry!  I know this wasn't a fun discussion, but it is good to get a
> clear answer that sets or expectations, so thanks for that!
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>