Subject: [DNSOP] Fwd: New Version Notification for draft-arends-dnsop-dnssec-algorithm-update-00.txt

From: "Jakob Schlyter" <[email-masked]>
Date: Tue, 14 Mar 2017 09:04:53 +0100

This draft should be of interest to this WG, providing an alternative to 
draft-wouters-sury-dnsop-algorithm-update.

	jakob

Forwarded message:

> From: [email-masked]
> To: Roy Arends <[email-masked]>, Jakob Schlyter 
> <[email-masked]>, Matt Larson <[email-masked]>
> Subject: New Version Notification for 
> draft-arends-dnsop-dnssec-algorithm-update-00.txt
> Date: Mon, 13 Mar 2017 10:47:24 -0700
>
> A new version of I-D, 
> draft-arends-dnsop-dnssec-algorithm-update-00.txt
> has been successfully submitted by Roy Arends and posted to the
> IETF repository.
>
> Name:		draft-arends-dnsop-dnssec-algorithm-update
> Revision:	00
> Title:		DNS Security (DNSSEC) DNSKEY Algorithm IANA Registry Updates
> Document date:	2017-03-12
> Group:		Individual Submission
> Pages:		6
> URL:            
> https://www.ietf.org/internet-drafts/draft-arends-dnsop-dnssec-algorithm-update-00.txt
> Status:         
> https://datatracker.ietf.org/doc/draft-arends-dnsop-dnssec-algorithm-update/
> Htmlized:       
> https://tools.ietf.org/html/draft-arends-dnsop-dnssec-algorithm-update-00
>
>
> Abstract:
>    The DNS Security Extensions (DNSSEC) require the use of 
> cryptographic
>    algorithm suites for generating digital signatures and 
> cryptographic
>    hashes over DNS data.  The algorithms specified for use with DNSSEC
>    are reflected in IANA registries.  This document updates some 
> entries
>    in these registries.  The main reason for these updates is to 
> retire
>    the use of SHA1.
>
>
>
>
> Please note that it may take a couple of minutes from the time of 
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat

---

From: Frederico A C Neves <[email-masked]>
Date: Tue, 14 Mar 2017 05:36:00 -0300

Jakob,

> > https://tools.ietf.org/html/draft-arends-dnsop-dnssec-algorithm-update-00

This is a cleaner guidance to implementers but I would like to see the
new curves, ED25519 ED448, included at least as recommended to
implement.

Fred

---

From: Petr Špaček <[email-masked]>
Date: Wed, 15 Mar 2017 12:20:56 +0100

Thank you for the draft.

I have to say that from my perspective the
draft-wouters-sury-dnsop-algorithm-update selected a better approach to
the problem. IMHO it is important to distinguish consumers and producers
of signatures as discussed in the original thread.

While I agree that draft-wouters-sury-dnsop-algorithm-update requires
substantial editorial changes the spirit seems to be correct to me so I
would rather advance draft-wouters-sury-dnsop-algorithm-update instead
of this new draft.

Sorry for being mean!

Petr Špaček  @  CZ.NIC

On 14.3.2017 09:04, Jakob Schlyter wrote:
>> A new version of I-D, draft-arends-dnsop-dnssec-algorithm-update-00.txt
>>    The DNS Security Extensions (DNSSEC) require the use of cryptographic
>>    algorithm suites for generating digital signatures and cryptographic
>>    are reflected in IANA registries.  This document updates some entries
>>    in these registries.  The main reason for these updates is to retire
>>    the use of SHA1.
>>
>>
>>
>>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: John Dickinson <[email-masked]>
Date: Wed, 15 Mar 2017 15:39:58 +0000

> draft-wouters-sury-dnsop-algorithm-update.

I like this simple short draft. I prefer its terminology. The only tiny
issue I have is with the wording "Must Not Implement". Since there is
no capability exchange you can not avoid talking with a peer that
happens to support RSAMD5. However, I do of course agree with the
sentiment.

John

---

From: Roy Arends <[email-masked]>
Date: Wed, 15 Mar 2017 17:58:15 +0100

> On 15 Mar 2017, at 16:39, John Dickinson <[email-masked]> wrote:
> 

Thanks John!

The RSAMD5 status is copied verbatim from RFC6944 and this draft does not alter it.

Hope this helps,

Roy