Subject: Re: [DNSOP] Kindly review draft-woodworth-bulk-rr-05.txt

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 28 Mar 2017 11:12:17 -0500

On Wed, Feb 15, 2017 at 10:33:50AM +0000,
 Woodworth, John R <[email-masked]> wrote 
 a message of 121 lines which said:

> We welcome _any_ feedback on the draft as we are hoping to have it (or some incarnation) adopted by the WG soon and look to rally more interest around it.

> Q) Does BULK cover all RR types?
> A) No. The draft only covers A, AAAA, PTR and CNAME RR types.

Unless I'm wrong, draft-woodworth-bulk-rr-05.txt does not explain what
to do if the QTYPE=ANY. (Section 3.2 seems to indicate that it will
*not* match even if there are A or AAAA records.)

Also, as I said at the mike, the part about NPN is really difficult to
understand. The pseudo-code is much better. A high-level presentation
of NPN would be a good idea (and a separate draft for NPN).

Anyone willing to do a hackathon project in Prague on implementing
BULK on NSD?

---

From: "Woodworth, John R" <[email-masked]>
Date: Tue, 28 Mar 2017 16:44:42 +0000

> -----Original Message-----
> From: Stephane Bortzmeyer [mailto:[email-masked]]
>
> On Wed, Feb 15, 2017 at 10:33:50AM +0000,  Woodworth, John R <[email-masked]> wrote  a message of 121 lines which said:
>
> > We welcome _any_ feedback on the draft as we are hoping to have
> > it (or some incarnation) adopted by the WG soon and look to rally
> > more interest around it.
>
> Unless I'm wrong, draft-woodworth-bulk-rr-05.txt does not explain
> what to do if the QTYPE=ANY. (Section 3.2 seems to indicate that it will

Stephane,

First, thanks for your feedback it is very appreciated.

We attempted to handle this implicitly in section 3 --

    "The nameserver MUST query its local RR database for any "BULK"
    RRs with a matching owner, class and compatible Match Type."

However, I see now it may be better to make logic for the "ANY"
QTYPE more explicit.

BTW: We are working to remove the current QTYPE restrictions in the
next draft.

>
> Also, as I said at the mike, the part about NPN is really difficult
> to understand. The pseudo-code is much better. A high-level presentation

Thanks again, we will revisit this section to provide better clarity
and potentially break it into its own draft.

Thanks,
John

>
> Anyone willing to do a hackathon project in Prague on implementing BULK
> on NSD?
>
>
-- THESE ARE THE DROIDS TO WHOM I REFER:
This communication is the property of CenturyLink and may contain confidential or privileged information. Unauthorized use of this communication is strictly prohibited and may be unlawful. If you have received this communication in error, please immediately notify the sender by reply e-mail and destroy all copies of the communication and any attachments.