Subject: Re: [DNSOP] WGLC for draft-ietf-dnsop-sutld-ps

From: Edward Lewis <[email-masked]>
Date: Thu, 16 Mar 2017 16:08:35 +0000

On 3/15/17, 20:22, "DNSOP on behalf of Russ Housley" <[email-masked] on behalf of [email-masked]> wrote:

>I see that draft-ietf-dnsop-sutld-ps-03 still references I-D.lewis-domain-names, but I have not seen ant WG Last Call for that document.  What is the plan?

Just accidently saw this...I haven't been reading DNSOP much recently.

FWIW, the document ("-domain-names-") was informally attached to the IAB's Names and Identifier's Program, that program was recently scuttled by the IAB like, maybe, 2-3 weeks ago.  I had been wondering (but more tied up with this week's ICANN meeting) what happens next, and haven't gotten around to dealing with that.  In that sense "Good Question."

The domain-names draft was never considered for a DNSOP WG document as it is mostly about how this is not a DNS problem.  In 2015, I did get comments from folks on this list and then for most of 2016 the discussion was under the IAB program.  There wasn't much discussion which is the prime reason the document was in a suspended, waiting state.

The document currently has two pieces.  One is the historical narrative and written to justify clarifying domain names, with "clarifying" being an action not to be undertake without much consideration.  (Having written two clarifications, I've learned.)  The other piece is where I wanted discussion, defining domain names.

I could edit the document to include just the first piece and submit it to the Independent Stream whatever, Editor.  There's not much reason not to do that - it just hadn't happened while the IAB program was in place (potentially adopting the document).  On the other hand, I was still "discovering" some of the elements of the relevant history as late as December based on the only set of comments I'd received in months (got it in private email in September).

What are the chances that the Independent Stream Editor will bounce this document towards DNSOP?  So - as a question to the chairs - is it worth DNSOP adopting this document (covering the history) at the risk of it being out of scope for the charter, or is it better to, if the Independent Stream Editor bounces this to DNSOP, reply with a "it's not our bailiwick?"

I suppose in any case there will be an IETF-wide last call before the document stands a chance of being a vetted, published document.  I've just never thought of any other vetting (WG) to be done.

Ed

---

From: Ralph Droms <[email-masked]>
Date: Thu, 16 Mar 2017 15:59:22 -0400

> On Mar 16, 2017, at 12:08 PM, Edward Lewis <[email-masked]> wrote:
> 

Ed - I think your document is a valuable reference and worth publishing.  The first question to ask is whether you want to continue with the publication process.  If you do, I'm sure we can find some way to publish it.

I need to re-read the document to refresh myself on the two aspects of the document that you mention.  If you really are looking for IETF discussion and consensus on the defining domain names, a third path would be an AD-sponsored submission, independent of any WG.

- Ralph

> 
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: "Paul Hoffman" <[email-masked]>
Date: Thu, 16 Mar 2017 13:26:01 -0700

On 16 Mar 2017, at 12:59, Ralph Droms wrote:

> If you really are looking for IETF discussion and consensus on the 
> defining domain names, a third path would be an AD-sponsored 
> submission, independent of any WG.

Please do note that we already have such a discussion (that will go for 
IETF consensus) active in draft-ietf-dnsop-terminology-bis. We've been 
asking for feedback on this topic already, and even you gave us some. 
:-)

--Paul Hoffman

---

From: Edward Lewis <[email-masked]>
Date: Thu, 16 Mar 2017 21:18:08 +0000

>Ed - I think your document is a valuable reference and worth publishing.  The first question to ask is whether you want to continue with the publication process.  If you do, I'm sure we can find som…

In the sense of first things first, its time I "cut" the document to get the history and an argument for a clarification.

But...the last comment I received was about the history which led me to a bit more research.  Thinking this over, I think it's time for a IETF wide last call to see if there are more comments out there like that.

---

From: Edward Lewis <[email-masked]>
Date: Mon, 27 Mar 2017 15:43:51 +0000

On 3/16/17, 15:59, "Ralph Droms" <[email-masked]> wrote:
   
>Ed - I think your document is ...

With Homenet's session ending early, I removed the "definition" section (and retitled it to reflect that it is a case for clarifying, not to be confused with containing an architectural definition).

The draft is in manual submission now, will be a -06.  Apparently I never got the memo about the modern ID submission process ;) - I keep getting some part of the meta-data wrong.