Subject: [DNSOP] I-D Action: draft-bellis-dnsext-multi-qtypes-06.txt

From: [email-masked]
Date: Mon, 02 Jul 2018 05:51:23 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Domain Name System Operations WG of the IETF.

        Title           : DNS Multiple QTYPEs
        Author          : Ray Bellis
	Filename        : draft-bellis-dnsext-multi-qtypes-06.txt
	Pages           : 7
	Date            : 2018-07-02

Abstract:
   This document specifies a method for a DNS client to request
   additional DNS record types to be delivered alongside the primary
   record type specified in the question section of a DNS query.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-bellis-dnsext-multi-qtypes/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-bellis-dnsext-multi-qtypes-06
https://datatracker.ietf.org/doc/html/draft-bellis-dnsext-multi-qtypes-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-bellis-dnsext-multi-qtypes-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Richard Gibson <[email-masked]>
Date: Mon, 2 Jul 2018 10:19:04 -0400

This is conceptually similar to [accompanying-questions], but limits all 
questions to share a QNAME. The result is a more concise payload and 
simpler processing logic at the expense of an ability to request e.g. 
(www.example.com, A) and (_443._tcp.www.example.com, TLSA) in one query. 
I can imagine many scenarios where such queries would be valuable, 
though, and am suspicious about the tradeoff (which essentially supports 
only A+AAAA queries) being worthwhile. [accompanying-questions] had some 
[issues] of its own to work out, but seemed to fall at approximately the 
right level of flexibility for allowing clients to query for more than 
one tuple.

[accompanying-questions]: 
https://datatracker.ietf.org/doc/draft-yao-dnsop-accompanying-questions/
[issues]: https://www.ietf.org/mail-archive/web/dnsop/current/msg21085.html

On 07/02/2018 08:51 AM, [email-masked] wrote:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dbellis-2Ddnsext-2Dmulti-2Dqtypes_&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=-o8MJF7i0TzXAJRB0ncfTVfWKSyTG7nl_iTLU_A2B7c&m=qoeMRqSzFwqsFQC8jC1yu3vx8EparFX7LesUv2k9jCM&s=nAF1psaBl4BrcSH12DDD8-h4jVVriftlNvhtAmFlY5Q&e=
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dbellis-2Ddnsext-2Dmulti-2Dqtypes-2D06&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=-o8MJF7i0TzXAJRB0ncfTVfWKSyTG7nl_iTLU_A2B7c&m=qoeMRqSzFwqsFQC8jC1yu3vx8EparFX7LesUv2k9jCM&s=D1oTk_bgVu4lj3OjjuiXoxOIuBBbIL0KO6kbHZ9_hRM&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dbellis-2Ddnsext-2Dmulti-2Dqtypes-2D06&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=-o8MJF7i0TzXAJRB0ncfTVfWKSyTG7nl_iTLU_A2B7c&m=qoeMRqSzFwqsFQC8jC1yu3vx8EparFX7LesUv2k9jCM&s=8WzllvYxQajep8eqJqq3yV2J_tRoOKYnow5bwzceXx8&e=
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dbellis-2Ddnsext-2Dmulti-2Dqtypes-2D06&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=-o8MJF7i0TzXAJRB0ncfTVfWKSyTG7nl_iTLU_A2B7c&m=qoeMRqSzFwqsFQC8jC1yu3vx8EparFX7LesUv2k9jCM&s=J471bGTuh5C7VV8996erxtZkgU-KZ5fbUOgkqqEtR-I&e=
>
>
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=-o8MJF7i0TzXAJRB0ncfTVfWKSyTG7nl_iTLU_A2B7c&m=qoeMRqSzFwqsFQC8jC1yu3vx8EparFX7LesUv2k9jCM&s=kfPI_hiW8R7kJUNYC9wrFWmPV07xPNgiZcm7jtOdhjA&e=
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dnsop&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=-o8MJF7i0TzXAJRB0ncfTVfWKSyTG7nl_iTLU_A2B7c&m=qoeMRqSzFwqsFQC8jC1yu3vx8EparFX7LesUv2k9jCM&s=aFTa0u2T8MtsiQHha6UQaRdLL3FoifHiU9sY-XorioQ&e=