Subject: [DNSOP] Genart last call review of draft-ietf-dnsop-terminology-bis-11

From: Roni Even <[email-masked]>
Date: Wed, 08 Aug 2018 05:40:51 -0700

Reviewer: Roni Even
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-dnsop-terminology-bis-??
Reviewer: Roni Even
Review Date: 2018-08-08
IETF LC End Date: 2018-08-13
IESG Telechat date: Not scheduled for a telechat

Summary: The document is ready for publication as a BCP with nits

Major issues:

Minor issues:

Nits/editorial comments:

1.  In section 2 the term DNAME is mentioned and while CNAME is specified DNAME
is not (maybe reference RFC6672?)

2. In section 5 "Most resorece record " typo.

3. This is more a comment and since I did not follow the progress of the
document I am not sure the motivation here. Reading the text I noticed that in
the definition of referrals in section 4 the text include also what looks to me
like logic starting from the third paragraph. I was wondering why is it here
and not in one of the standard track documents and referenced here. I saw that
this is a big change from RFC7719.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 8 Aug 2018 14:57:09 +0000

> is not (maybe reference RFC6672?)

We have been trying to use this document to define terms. In the case of DNAME, it doesn't appear to actually mean anything (at least, I couldn't find an RFC that said what the D was for). I suspect it was the early DNS folks being cute, something along the lines of "D is bigger than C". Having said that, we will add a reference without adding an explanation.

> 2. In section 5 "Most resorece record " typo.

Thanks!

> this is a big change from RFC7719.

Yes, that all came from the extensive WG discussion. You are correct that there is not an RFC that says "here are the kinds of referrals and what they mean", but there was a strong desire that we define "referrals" because that term is used in many other documents in many contexts. Someone could (maybe SHOULD) write a "DNS referrals" RFC, and the terminology-ter document (if such a thing comes into existence) could rip out this section and refer to it.

The main thing here is that this document doesn't change an existing definition of "referrals". We just kinda realized that we had to get it written down the first time.

--Paul Hoffman

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 9 Aug 2018 05:04:09 +0000

Hi Paul,
I am OK with your response
Thanks
Roni

-----Original Message-----
From: Gen-art [mailto:[email-masked]] On Behalf Of Paul Hoffman
Sent: Wednesday, August 08, 2018 5:57 PM
To: Roni Even
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Gen-art] [Ext] Genart last call review of draft-ietf-dnsop-terminology-bis-11

On Aug 8, 2018, at 5:40 AM, Roni Even <[email-masked]> wrote:
> 1.  In section 2 the term DNAME is mentioned and while CNAME is 
> specified DNAME is not (maybe reference RFC6672?)

Thanks!

> 3. This is more a comment and since I did not follow the progress of 
> the document I am not sure the motivation here. Reading the text I 
> noticed that in the definition of referrals in section 4 the text 
> include also what looks to me like logic starting from the third 
> paragraph. I was wondering why is it here and not in one of the 
> standard track documents and referenced here. I saw that this is a big change from RFC7719.

--Paul Hoffman
_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Giovane C. M. Moura" <[email-masked]>
Date: Fri, 10 Aug 2018 14:53:48 +0200

Maybe I am missing something,  but it seems to be that the term
'answers' and 'response' are currently being used interchangeably in the
draft.

I opened a issue on Github for that, with an example.

https://github.com/DNSOP/draft-ietf-dnsop-terminology-bis/issues/70

/giovane

---

From: "Paul Hoffman" <[email-masked]>
Date: Fri, 10 Aug 2018 07:31:50 -0700

> https://github.com/DNSOP/draft-ietf-dnsop-terminology-bis/issues/70

It would be good to have the conversation here on the list instead.

First: we were probably sloppy in the use of the word "answer". In many 
cases, that should be "response".

The response is the entire DNS message that is sent in reply to a 
question.

However, in your GitHub comment, you suggest that an "answer" is both 
the contents  of the Answer section *and* the contents of the Authority 
section. Why would the contents of the Authority section be considered 
an answer?

--Paul Hoffman

---

From: "Paul Hoffman" <[email-masked]>
Date: Fri, 10 Aug 2018 07:55:00 -0700

Also, in searching for "answer" in the document, I find that most of the 
uses are as a verb, which is unambiguous. It's only ambiguous when the 
word "answer" is used as a noun. Unfortunately, there are some places 
where "answer" as a noun is used in material we quote from other RFCs, 
and we cannot change those.

--Paul Hoffman

---

From: "Giovane C. M. Moura" <[email-masked]>
Date: Fri, 10 Aug 2018 17:51:14 +0200

Thanks Paul,

> First: we were probably sloppy in the use of the word "answer". In
> many cases, that should be "response".

Thanks for clarifying it, and don't get me wrong,  it's not only this
draft that had this --  many academic papers do the same (including
mine) -- but since this is a terminology doc, it's better to get it
right here.  So the next docs follow it.

> The response is the entire DNS message that is sent in reply to a
Great. Do you plan to define it in the document as well?

> However, in your GitHub comment, you suggest that an "answer" is
> both the contents  of the Answer section *and* the contents of the
> Authority section. Why would the contents of the Authority section be
> considered an answer?

That was just a clarifying question; I was in doubt myself.
So in that case the _response_ then does not contain an answer -- just
the authority.

Maybe this is clear for DNSOP fellows, but for  many researchers this
may not be.

> Also, in searching for "answer" in the document, I find that most of > the
> uses are as a verb, which is unambiguous. >It's only ambiguous when > the
> word "answer" is used as a noun.

Yes, you are right.

 >Unfortunately, there are some places

True. Which supports the need for a terminology rfc :)

thanks,

giovane

---

From: Richard Gibson <[email-masked]>
Date: Fri, 10 Aug 2018 12:36:22 -0400

> Great. Do you plan to define it in the document as well?
Analogous to a "response" DNS message containing an "answer" (presumably 
consisting of zero or more records), I'd be equally precise about a 
"query" DNS message containing a "question" (consisting of zero or more 
entries, but with any count other than 1 being essentially meaningless) 
and avoid conflating those terms.

https://tools.ietf.org/html/rfc1035#section-4.1.2 :
 > The question section is used to carry the "question" in most queries, 
i.e., the parameters that define what is being asked.

---

From: Joe Abley <[email-masked]>
Date: Fri, 10 Aug 2018 12:49:58 -0400

Hi Richard,

I'd suggest that the unqualified nouns "question" and "answer" are sufficiently ambiguous as to be dead to us at this point.

I agree with the idea that a "response" is a DNS message generated in response to a query. Both "query" and "response" can be defined as DNS messages with particular values of QR observed in their respective headers.

I think "question" and "answer" can only usefully be used in other definitions as "question section" and "answer section". The document can certainly provide suggestions as to the set of meanings that other documents have previously ascribed to the bare nouns, but I think there ought to be a recommendation that they not be used in that way.

Joe

> On Aug 10, 2018, at 12:36, Richard Gibson <[email-masked]> wrote:
> 
> Analogous to a "response" DNS message containing an "answer" (presumably consisting of zero or more records), I'd be equally precise about a "query" DNS message containing a "question" (consisting of zero or more entries, but with any count other than 1 being essentially meaningless) and avoid conflating those terms.
> 
> > The question section is used to carry the "question" in most queries, i.e., the parameters that define what is being asked.
> 
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Dick Franks <[email-masked]>
Date: Fri, 10 Aug 2018 18:22:58 +0100

Some of this lack of precision is spread about by much-loved DNS tools.

 ; <<>> DiG 9.11.4-RedHat-9.11.4-4.fc28 <<>> @b.root-servers.net . -t NS
 ; (2 servers found)
 ;; global options: +cmd
 ;; Got
answer:
<--------------------<<
 ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37483
 ;; flags: qr aa rd; QUERY: 1, ANSWER: 13, AUTHORITY: 0, ADDITIONAL: 27
 ;; WARNING: recursion requested but not available

 ;; OPT PSEUDOSECTION:
 ; EDNS: version: 0, flags:; udp: 4096
 ;; QUESTION SECTION:
 ;.                IN    NS

 ;; ANSWER SECTION:
 .            518400    IN    NS    j.root-servers.net.
 .            518400    IN    NS    h.root-servers.net.
 ...

And before anyone complains, similar infractions in perl Net::DNS
documentation will be fixed in next release.

Dick
________________________