Subject: Re: [DNSOP] Call for Adoption: draft-bortzmeyer-rfc7816bis

From: 神明達哉 <[email-masked]>
Date: Wed, 1 Aug 2018 11:25:04 -0700

On Tue, Jul 24, 2018 at 9:33 AM Tim Wicinski <[email-masked]> wrote:

>    This starts a Call for Adoption for draft-bortzmeyer-rfc7816bis

>    The draft is available here:
https://datatracker.ietf.org/doc/draft-bortzmeyer-rfc7816bis/

>    Please review this draft to see if you think it is suitable for
adoption
>    by DNSOP, and comments to the list, clearly stating your view.
>    Please also indicate if you are willing to contribute text, review,
etc.

I support the adoption.  I'm willing to review future versions.

I have a couple of minor comments on 00:

- Regarding the first paragraph of Section 6, I've noticed RFC8198
  would have the same improvement effect.  You may or may not to
  mention it, but I'm noting it here as the draft also has a TODO
  about mentioning RFC8020 in this context.

- Also in Section 6:

   QNAME minimisation may also improve lookup performance for TLD
   operators.  For a typical TLD, delegation-only, and with delegations
   just under the TLD, a two-label QNAME query is optimal for finding
   the delegation owner name.

  It's not super obvious why it's "optimal".  Is this because it would
  be an exact match for minimized queries and the assumption is that
  an exact match is much more efficient than longest match in TLD
  server implementations?

--
JINMEI, Tatuya

---

From: Sara Dickinson <[email-masked]>
Date: Fri, 3 Aug 2018 10:27:18 +0100

+1 for adoption and willing to review

Sara. 

> On 25 Jul 2018, at 04:31, Davey Song(宋林健) <[email-masked]> wrote:
> 
> +1
>  
> DNS privacy is an important issue. I support this adoption. And I’m willing to review it. 
>   <>
> Davey
> 发件人: DNSOP [mailto:[email-masked] <mailto:[email-masked]>] 代表 Tim Wicinski
> 发送时间: 2018年7月25日 0:33
> 收件人: dnsop
> 主题: [DNSOP] Call for Adoption: draft-bortzmeyer-rfc7816bis
>  
>  
> We discussed this and there appears to be support to adopt this, with
> the caveat of adding more content to the section on Operational Considerations.
>  
>  
> The draft is available here: https://datatracker.ietf.org/doc/draft-bortzmeyer-rfc7816bis/ <https://datatracker.ietf.org/doc/draft-bortzmeyer-rfc7816bis/>
>  
> Please review this draft to see if you think it is suitable for adoption
> Please also indicate if you are willing to contribute text, review, etc.
>  
> This call for adoption ends: 9 August 2018
>  
> Thanks,
> tim wicinski
> DNSOP co-chair
>  
> _______________________________________________
> DNSOP mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/dnsop <https://www.ietf.org/mailman/listinfo/dnsop>

---

From: "A. Schulze" <[email-masked]>
Date: Sat, 4 Aug 2018 22:24:29 +0200

> This starts a Call for Adoption for draft-bortzmeyer-rfc7816bis

Hello WG,

I do support QNAME minimisation.

As some may know, we operate a medium size enterprise and ISP network.
There we use UNBOUND as recursive resolver. QNAME minimisation is enabled in relaxed mode.
We do this since more then two years (unbound 1.5.7 or so)
It's working as expected without major problems or issues.

Prior activation of that feature we designed a backup strategy for domains that will trigger failures.
We could "reroute" queries for problematic domains to an other resolver configured more relax.
This happen by manual interaction if QNAME minimisation is identified as root cause for a specific resolving issue.

For some months that list of "broken domain" is empty.
I see optimizations in unbound as reason for not having any trouble with QNAME minimisation,

Hope, that helps...
Andreas

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 9 Aug 2018 04:49:18 -0400

All

Thanks for all the comments on this draft.  The Call for Adoption is 
ending today but it seems that there is consensus to adopt this work in 
DNSOP and support this work.   The chairs thank everyone for the feedback.

Authors should upload a new version with the 
draft-ietf-dnsop-rfc7816bis  name.

Thanks!
Tim
for all the chairs