Subject: Re: [DNSOP] I-D Action: draft-hoffman-dns-terminology-ter-01.txt

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 24 Jul 2019 17:07:26 -0400

On Mon, Apr 29, 2019 at 05:00:38PM -0700,
 [email-masked] <[email-masked]> wrote 
 a message of 41 lines which said:

>         Title           : Terminology for DNS Transports and Location
>         Author          : Paul Hoffman
> 	Filename        : draft-hoffman-dns-terminology-ter-01.txt

Seen on a slide at IETF 105 :

DoTH (to talk about DoH and DoT together, as in "DoTH use TLS to
protect DNS queries against snoopers").

A nice addition? :-)

---

From: Tony Finch <[email-masked]>
Date: Thu, 25 Jul 2019 11:54:26 +0100

> protect DNS queries against snoopers").

DoTH is the abbreviation I use for my documentation about encrypted DNS
since August last year, https://www.dns.cam.ac.uk/servers/doth.html

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Wight: Variable 2 to 4, becoming cyclonic 5 to 7 for a time. Smooth or slight
becoming slight or moderate. Squally thundery showers. Good, occasionally
poor.

---

From: Normen Kowalewski <[email-masked]>
Date: Thu, 25 Jul 2019 13:22:24 +0200

Hi Tony,

what do you use then for  "traditional DNS over UDP/TCP” aka Do53 

I had thought about one approach is to express distinction into the abbreviation by transport protocol, a suggestion by Puneet Sood  was to use DoUT instead of Do53
This would still be consistent with grouping DoT and DoH into in DoTH.

BR, Normen

> On 25. Jul 2019, at 12:54, Tony Finch <[email-masked]> wrote:
> 
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Tony Finch <[email-masked]>
Date: Thu, 25 Jul 2019 12:26:49 +0100

> what do you use then for  "traditional DNS over UDP/TCP” aka Do53

I like Do53. I also like DONUTS (DNS over normal unencrypted TCP streams)
but that joke is a bit over-ripe.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Fitzroy, Sole: Southerly veering westerly 5 to 7, occasionally gale 8 at first
in west Sole, decreasing 3 or 4 later. Rough or very rough. Thundery showers.
Good, occasionally poor.

---

From: Paul Wouters <[email-masked]>
Date: Thu, 25 Jul 2019 10:25:28 -0400 (EDT)

On Thu, 25 Jul 2019, Tony Finch wrote:

> I like Do53.

I dislike Do53, because then we should really have Do53-over-TCP as DoT
and Do53-over-https as DoH. If we call it "DNS-over-TCP" than really
what we are doing is running (classic) DNS over TCP, and we shouldn't
midway the discussion rename "DNS" to "Do53".

Paul

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 25 Jul 2019 14:35:40 +0000

Do53 was invented as a way of saying "DNS format and transport as described in RFC 1034 and RFC 1035, with updates". If anyone has a better shorthand for that than "Do53", that's great. I believe a shorthand is needed, particularly for publications that are discussiong multiple transports.

--Paul Hoffman

---

From: Tony Finch <[email-masked]>
Date: Thu, 25 Jul 2019 15:36:39 +0100

> midway the discussion rename "DNS" to "Do53".

These abbreviations are about identifying the transport that is being used
for the DNS messages. One problem with Do53 is that it isn't specific
about the transport, because it covers both UDP and TCP. But it's a handy
abbreviation for DNS over traditional transports. It doesn't identify DNS
as a whole, just the framing of DNS messages in UDP and TCP.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
a just distribution of the rewards of success

---

From: George Michaelson <[email-masked]>
Date: Thu, 25 Jul 2019 10:39:39 -0400

I dislike the rate of change in terminology, and what feels like
intrusion of somebodys favourite term, which is not actually
reflective of widespread use in DNS discussion.

I have never said DO53 and I don't know anyone who has. Every other
term of art, has sound basis. This feels like a bad backronym and we
are now moving from a terminology to an emerging AI aware ontology of
phoneme-building.

Can we stick to acronyms which really exist? Is this in a document of
substance and I missed something? (very possible)

A dictionary model I like (btw) is to show the earliest published use
of the form, to set its context and definitions as they emerge.

-G

---

From: Paul Wouters <[email-masked]>
Date: Thu, 25 Jul 2019 10:51:11 -0400 (EDT)

> Do53 was invented as a way of saying "DNS format and transport as described in RFC 1034 and RFC 1035, with updates". If anyone has a better shorthand for that than "Do53", that's great. I believe a…

Classic DNS or Native DNS ?

Or just "DNS over UDP/TCP" ? It's not that long to use.

Paul

---

From: Martin Hoffmann <[email-masked]>
Date: Thu, 25 Jul 2019 16:52:55 +0200

Paul Hoffman wrote:
> Do53 was invented as a way of saying "DNS format and transport as
> described in RFC 1034 and RFC 1035, with updates". If anyone has a
> better shorthand for that than "Do53", that's great. I believe a
> shorthand is needed, particularly for publications that are
> discussiong multiple transports.

I still maintain that having descriptive terms should be preferable
over an abundance of abbreviations, particular in documents. In this
case, why not "classic DNS" or "traditional DNS"? Likewise, "encrypted
DNS" instead of DoTH.

Kind regards,
Martin

---

From: Evan Hunt <[email-masked]>
Date: Thu, 25 Jul 2019 17:02:42 +0000

> as a whole, just the framing of DNS messages in UDP and TCP.

The other day at ANRW, a paper was presented that compared performance of
DoH, DoT, and Do53. It was unclear to me what transport the authors had
used for their Do53 measaurements - and it makes a significant difference.
I don't know, even now, whether the comparison was apples-to-apples or not.

"Do53" is a handy abbreviation, but I'm concerned that using it as a
coequal peer of DoT and DoH will lead to fuzzy thinking.

-- 
Evan Hunt -- [email-masked]
Internet Systems Consortium, Inc.

---

From: Tommy Jensen <[email-masked]>
Date: Thu, 25 Jul 2019 17:14:53 +0000

I agree with "encrypted DNS" because that makes the meaning (DoH or DoT or X : X is some new way to encrypt DNS) clear when it is intended, and saying DoH/DoT when that is really intended (just those two and not any other encrypted version of DNS) isn't that burdensome. DoTH can be confused with some new specific protocol "DNS over T____ H____" since that's what the other Do* patterns indicate.

However, I think Do53 makes sense as it includes any use of DNS over port 53 and fits the Do* pattern used by other DNS protocols. This would only become confusing in the event we end up introducing an encrypted DNS protocol that also operates over port 53 which seems incredibly unlikely.

Thanks,
Tommy
________________________________
From: DNSOP <[email-masked]> on behalf of Martin Hoffmann <[email-masked]>
Sent: Thursday, July 25, 2019 7:52 AM
To: Paul Hoffman <[email-masked]>
Cc: dnsop <[email-masked]>
Subject: Re: [DNSOP] [Ext] I-D Action: draft-hoffman-dns-terminology-ter-01.txt

Kind regards,
Martin

_______________________________________________
DNSOP mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdnsop&amp;data=02%7C01%7CJensen.Thomas%40microsoft.com%7C6e63764eb3524be5ccc108d7110fd3cf%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636996631991661796&amp;sdata=8bdbQf45P7S53XE4DLJ9H9m0di%2FgbykgOrCPXktNdtM%3D&amp;reserved=0

---

From: Joe Abley <[email-masked]>
Date: Thu, 25 Jul 2019 10:24:06 -0700

I agree with "encrypted DNS" because that makes the meaning (DoH or DoT or
X : X is some new way to encrypt DNS) clear when it is intended

Like DNSCrypt with UDP transport?

Or like an apex TXT record that contains a one-time token to authenticate a
zone to a service?

I spent some time this week at the Africa DNS Forum in Botswana promoting
the idea that the concept of "DNS Security" is usefully more broad than
just DNSSEC. Perhaps we need a corresponding effort to broaden "DNS
Encryption" beyond DoH and DoT?

Joe

---

From: Paul Wouters <[email-masked]>
Date: Thu, 25 Jul 2019 13:29:25 -0400 (EDT)

> coequal peer of DoT and DoH will lead to fuzzy thinking.

Indeed. U53, T53 and UT53 (or 53U, 53T, 53UT) would be far more informative.

Paul

---

From: Tommy Jensen <[email-masked]>
Date: Thu, 25 Jul 2019 17:30:05 +0000

Good point ("s/new/other" in my definition of "encrypted DNS"). And I agree, "encrypted DNS" is a superset of "DoH and DoT" but not the other way around.

Thanks,
Tommy
________________________________
From: Joe Abley <[email-masked]>
Sent: Thursday, July 25, 2019 10:24 AM
To: Tommy Jensen <[email-masked]>
Cc: Martin Hoffmann <[email-masked]>; Paul Hoffman <[email-masked]>; dnsop <[email-masked]>
Subject: Re: [DNSOP] [Ext] I-D Action: draft-hoffman-dns-terminology-ter-01.txt

I agree with "encrypted DNS" because that makes the meaning (DoH or DoT or X : X is some new way to encrypt DNS) clear when it is intended

Or like an apex TXT record that contains a one-time token to authenticate a zone to a service?

I spent some time this week at the Africa DNS Forum in Botswana promoting the idea that the concept of "DNS Security" is usefully more broad than just DNSSEC. Perhaps we need a corresponding effort to broaden "DNS Encryption" beyond DoH and DoT?

Joe

---

From: Tommy Jensen <[email-masked]>
Date: Thu, 25 Jul 2019 17:33:51 +0000

The 53U, 53T, 53UT ordering makes more sense to me, since it aligns with the DoH/DoT alignment of protocol indicator followed by transport indicator ordering.
________________________________
From: DNSOP <[email-masked]> on behalf of Paul Wouters <[email-masked]>
Sent: Thursday, July 25, 2019 10:29 AM
To: Evan Hunt <[email-masked]>
Cc: dnsop <[email-masked]>
Subject: Re: [DNSOP] I-D Action: draft-hoffman-dns-terminology-ter-01.txt

Paul

_______________________________________________
DNSOP mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdnsop&amp;data=02%7C01%7CJensen.Thomas%40microsoft.com%7Ca83a347f25ef461c263708d71125b5a6%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636996725966251868&amp;sdata=l29PLDfowCk0761lJXtpG4%2FZEvgf8nSkmKWLZ8HxcFE%3D&amp;reserved=0

---

From: Brian Dickson <[email-masked]>
Date: Thu, 25 Jul 2019 15:20:31 -0400

<humor>
As long as we avoid 53Cr.
(One of the isotopes of chromium happens to have atomic mass of 53 - funny
coincidence, what with chrome/chromium being google things.)
(Particularly if it is hexavalent.)
</humor>
Brian

On Thu, Jul 25, 2019 at 1:34 PM Tommy Jensen <Jensen.Thomas=
[email-masked]> wrote:

> The 53U, 53T, 53UT ordering makes more sense to me, since it aligns with
> the DoH/DoT alignment of protocol indicator followed by transport indicator
> ordering.
> ------------------------------
> *From:* DNSOP <[email-masked]> on behalf of Paul Wouters <
> [email-masked]>
> *Sent:* Thursday, July 25, 2019 10:29 AM
> *To:* Evan Hunt <[email-masked]>
> *Cc:* dnsop <[email-masked]>
> *Subject:* Re: [DNSOP] I-D Action:
> draft-hoffman-dns-terminology-ter-01.txt
>
> Indeed. U53, T53 and UT53 (or 53U, 53T, 53UT) would be far more
> informative..
>
> Paul
>
> https://nam06..safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdnsop&amp;data=02%7C01%7CJensen.Thomas%40microsoft.com%7Ca83a347f25ef461c263708d71125b5a6%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636996725966251868&amp;sdata=l29PLDfowCk0761lJXtpG4%2FZEvgf8nSkmKWLZ8HxcFE%3D&amp;reserved=0
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdnsop&amp;data=02%7C01%7CJensen.Thomas%40microsoft.com%7Ca83a347f25ef461c263708d71125b5a6%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636996725966251868&amp;sdata=l29PLDfowCk0761lJXtpG4%2FZEvgf8nSkmKWLZ8HxcFE%3D&amp;reserved=0>

---

From: Paul Wouters <[email-masked]>
Date: Thu, 25 Jul 2019 15:58:48 -0400

> On Jul 25, 2019, at 06:54, Tony Finch <[email-masked]> wrote:
> 

It might be useful in writing but when speaking it is too similar to DoT in pronunciation, especially for those whose English isn’t a first language.

Paul