Subject: Re: [DNSOP] I-D Action: draft-ietf-dnsop-glue-is-not-optional-04.txt

From: "Wessels, Duane" <[email-masked]>
Date: Fri, 15 Apr 2022 22:44:32 +0000

> On Mar 22, 2022, at 6:02 AM, Ralf Weber <[email-masked]> wrote:
> 
> Moin!
> 
> So to follow up on my comment in the working group on registries not having anything to do with it. I understand that this drafts is for authoritative name server implementers, however I think that we should make clear that an authoritative name server not answering correct by this draft might do so because it does not have sufficient data.
> 
> So we currently have in the introduction:
> 
> Note that this document only clarifies requirements of name server
> software implementations.  It does not place any requirements on data
> placed in DNS zones or registries.
> 
> how about adding:
> 
> However missing data might make it impossible for a name server to answer with the correct (referral) glue data.
> 
> And maybe add some encouragement or referral ;-) to work that has to be done elsewhere.

Ralf (and others),

how does this look to you?

In other words, this document only makes requirements on "available
glue records" (i.e., those given in a zone), but does not make
requirements regarding thier presence in a zone.
If some glue records are absent from a given zone, an authoritative
name server may be unable to return a useful referral response for
the corresponding domain. The IETF may want to consider a separate
update to the requirements for including glue in zone data, beyond
those given in [@!RFC1034] and [@!RFC1035].

Also here: https://github.com/ietf-wg-dnsop/draft-ietf-dnsop-glue-is-not-optional/pull/35

DW

---

From: Ralf Weber <[email-masked]>
Date: Mon, 18 Apr 2022 10:43:50 +0200

Moin!

> requirements regarding thier presence in a zone.
Typo here “their presence in a zone”

> those given in [@!RFC1034] and [@!RFC1035].
Yeah that looks fine to me. The main point was to make sure that zone
data can also be a cause of failed/false referral. This text addresses
this.

So long
-Ralf
——-
Ralf Weber