Subject: [dnssd] Updates on Service Registration Protocol and Advertising Proxy documents

From: Ted Lemon <[email-masked]>
Date: Wed, 14 Jul 2021 06:47:25 -0700

I’ve posted updates to the SRP and Advertising Proxy documents. There are
only two minor changes to SRP—I think it’s ready for last call at this
point.

Advertising Proxy is still a work in progress. I added a section that talks
about a different way of handling mDNS conflicts. I think this merits
further discussion. My previous ask for the working group was to adopt it
as a work item; I think there was reasonable support for this in the
meeting, but I don’t think a call for adoption has happened yet.

In addition to these two documents, I’ve written two other documents in
anticipation of the upcoming meeting. Unfortunately I finished them later
than I’d intended, and they weren’t able to get through legal review in
time to post. Legal review will probably happen next week, and hopefully
I’ll be cleared to post them, although that’s never guaranteed. The two
documents are:

   - a 20-page specification for a SRP replication protocol, which is
   useful for situations where for example you have one or more stub networks
   to connect to an infrastructure network such as a home network, and you
   need to provide some reliability but don't have a way to set up a reliable
   primary name server
   - A 10-page specification for ad-hoc DNS-SD zone discovery using mDNS,
   so that a piece of ad-hoc infrastructure such as an SRP replication zone
   can be made available for DNS and DNS Push queries, reducing the need for
   multicast service discovery for such a zone

These are both things that we've implemented in the latest seed release of
TVos, which runs on HomePod Mini and the most recent Apple TV hardware. I
don't consider either of these to be done—there are open questions on both,
and I think it would really help to have more people looking at the work
and thinking about those open questions. If we can get consensus on
solutions, and that consensus isn't compatible with the current
implementations, I think that's fine—in the case of TVos, firmware updates
are easy and encouraged, so there shouldn't be issues with needing to
support legacy implementations.

(If you are tempted to update your devices to try out the new
functionality, talk to me privately first!)

For the upcoming meeting, if chairs are willing, I'd like to quickly
discuss a WGLC for SRP, and the call for adoption for the advertising proxy
document. I'd also like to talk about open problems in the advertising
proxy document, and if time permits I'd like to talk about the SRP
Replication work and the ad-hoc zone discovery work. I'd like to see both
of these documents adopted by the working group if possible, but I think a
call for adoption on the 27th would be premature since people likely won't
have  had time to review the documents.

---

From: Esko Dijk <[email-masked]>
Date: Sat, 24 Jul 2021 09:37:21 +0000

Hi all,

I support this work and I’d like to do again a review of SRP and Advertising Proxy. Unfortunately I didn’t have time to do this before my holiday , and also not before the IETF meeting as originally planned, so will have to do this some time next month!

Best regards
Esko

From: dnssd <[email-masked]> On Behalf Of Ted Lemon
Sent: Wednesday, July 14, 2021 15:47
To: dnssd <[email-masked]>
Subject: [dnssd] Updates on Service Registration Protocol and Advertising Proxy documents

I’ve posted updates to the SRP and Advertising Proxy documents. There are only two minor changes to SRP—I think it’s ready for last call at this point.

Advertising Proxy is still a work in progress. I added a section that talks about a different way of handling mDNS conflicts. I think this merits further discussion. My previous ask for the working group was to adopt it as a work item; I think there was reasonable support for this in the meeting, but I don’t think a call for adoption has happened yet.

In addition to these two documents, I’ve written two other documents in anticipation of the upcoming meeting. Unfortunately I finished them later than I’d intended, and they weren’t able to get through legal review in time to post. Legal review will probably happen next week, and hopefully I’ll be cleared to post them, although that’s never guaranteed. The two documents are:

  *   a 20-page specification for a SRP replication protocol, which is useful for situations where for example you have one or more stub networks to connect to an infrastructure network such as a home network, and you need to provide some reliability but don't have a way to set up a reliable primary name server
  *   A 10-page specification for ad-hoc DNS-SD zone discovery using mDNS, so that a piece of ad-hoc infrastructure such as an SRP replication zone can be made available for DNS and DNS Push queries, reducing the need for multicast service discovery for such a zone
These are both things that we've implemented in the latest seed release of TVos, which runs on HomePod Mini and the most recent Apple TV hardware. I don't consider either of these to be done—there are open questions on both, and I think it would really help to have more people looking at the work and thinking about those open questions. If we can get consensus on solutions, and that consensus isn't compatible with the current implementations, I think that's fine—in the case of TVos, firmware updates are easy and encouraged, so there shouldn't be issues with needing to support legacy implementations.

(If you are tempted to update your devices to try out the new functionality, talk to me privately first!)

For the upcoming meeting, if chairs are willing, I'd like to quickly discuss a WGLC for SRP, and the call for adoption for the advertising proxy document. I'd also like to talk about open problems in the advertising proxy document, and if time permits I'd like to talk about the SRP Replication work and the ad-hoc zone discovery work. I'd like to see both of these documents adopted by the working group if possible, but I think a call for adoption on the 27th would be premature since people likely won't have  had time to review the documents.

---

From: Jonathan Hui <[email-masked]>
Date: Mon, 26 Jul 2021 16:34:07 -0700

> only two minor changes to SRP—I think it’s ready for last call at this

Thank you for adding text regarding subtypes to draft-10, which is
important for our use cases that involve the integration of Matter
<https://buildwithmatter.com/> and Thread <https://www.threadgroup.org/>.

In addition to the SRP server implementation mentioned in draft-10, there
is now a second independent implementation available as open source within
the OpenThread project -
https://github.com/openthread/openthread/blob/main/src/core/net/srp_server.cpp
.

I support advancing the SRP document to WGLC.

--
Jonathan Hui