Subject: [Doh] terminology: "DNS API"

From: Tony Finch <[email-masked]>
Date: Wed, 6 Jun 2018 15:58:20 +0100

Can we amend the document to replace "DNS API server" with "DNS-over-HTTPS
server" or "DoH server" please?

To me, "DNS API" suggests something like getaddrinfo() or getdns. I
understand that in the web world, "API" suggests something-over-HTTP
that isn't a web page, but even in this context I feel I should expect a
protocol involving more JSON.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Portland, Plymouth: Variable mainly northeast 3 or 4, increasing 5 at times.
Slight or moderate. Showers, becoming thundery. Moderate or good, occasionally
poor later.

---

From: Sara Dickinson <[email-masked]>
Date: Fri, 8 Jun 2018 13:15:12 +0100

> On 6 Jun 2018, at 15:58, Tony Finch <[email-masked]> wrote:
> 

+1 on this (since also in practice ‘DoH server’ seems to be the term everyone is using)

What was the reason that this name was chosen?

Sara. 

> _______________________________________________
> Doh mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/doh

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 14 Jun 2018 19:24:51 +0000

> +1 on this (since also in practice ‘DoH server’ seems to be the term everyone is using)

Late reply: agree. We'll make this change in the next draft.

> What was the reason that this name was chosen?

Um, er, well.... a misunderstanding between the two authors. Patrick though I liked it, I thought that he liked it. We cleared that up that symmetric error today.

--Paul Hoffman