Subject: [Doh] ad-hoc DoH / DoT client

From: Steve Atkins <[email-masked]>
Date: Thu, 11 Jul 2019 15:41:00 +0100

I didn't find a particularly convenient way of doing ad-hoc DNS-over-not-UDP queries, at least not in a way that's user-friendly enough to give to an end user to help them understand what service they're seeing. Local proxies and stub resolvers are fine for using a particular DoX resolver, but not so good as a dig replacement for sending a query to a resolver and seeing what happens.

So https://github.com/wttw/dox is a proof of concept GUI query tool. It'll build on at least macOS, Windows and various Linuxes and gives an easy way for an end user to select a resolver, send a query and see the response.

It also has basic support for measuring web content fetch times using different resolvers, to give some idea of what performance a user might see - from their location, for the websites they're interested in - if they choose to use a particular resolver.

Share and enjoy. Send feedback, suggestions and/or patches to [email-masked] (or via github issues, if you prefer).

Cheers,
  Steve

---

From: Adam Roach <[email-masked]>
Date: Thu, 11 Jul 2019 11:19:31 -0500

Cool work! Thanks for sharing. On a related note, I believe PowerDNS's 
"sdig" tool allows you to perform DoH queries from the commandline: 
https://doc.powerdns.com/authoritative/manpages/sdig.1.html

/a

On 7/11/19 9:41 AM, Steve Atkins wrote:
> _______________________________________________
> Doh mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/doh

---

From: Nico Cartron <[email-masked]>
Date: Thu, 11 Jul 2019 21:46:56 +0200

Hi,

> On 11 Jul 2019, at 18:19, Adam Roach <[email-masked]> wrote:
> 
> Cool work! Thanks for sharing. On a related note, I believe PowerDNS's "sdig" tool allows you to perform DoH queries from the commandline: https://doc.powerdns.com/authoritative/manpages/sdig.1.html

Yes it does. 
And CZ.NIC's kdig supports querying over  DoT. 

-- 
Nico

---

From: Shreyas Zare <[email-masked]>
Date: Sat, 13 Jul 2019 11:21:03 +0530

Here is another open source cross platform locally hostable web app[1] for
anyone who is interested that supports all DNS transport protocols
including DoT & DoH (both wire and json) with IPv6 support and a built in
recursive resolver.

[1] https://github.com/TechnitiumSoftware/net.dnsclient

*Shreyas Zare*
Technitium <https://technitium.com>