Subject: [Doh] Authoritative DNS-over-TLS Operational Considerations

From: "Hewitt, Rory" <[email-masked]>
Date: Thu, 11 Jul 2019 15:19:41 +0000

Does the DoH WG have any input on whether 'we' should be looking into DoH for resolver->authority requests - similar to https://datatracker.ietf.org/doc/draft-hal-adot-operational-considerations/? Or does it not really apply, since we're only interested in client->resolver?

Rory

---

From: Ben Schwartz <[email-masked]>
Date: Thu, 11 Jul 2019 12:24:19 -0400

The DOH charter says:

The primary focus of this working group is to develop a mechanism that
> provides confidentiality and connectivity between DNS clients (e.g.,
> operating
> system stub resolvers) and recursive resolvers.

Thus, while recursive->authoritative connections are not specifically
excluded from our discussion, they are not a "primary focus".

The DPRIVE working group is (re)chartered to improve privacy between
recursive and authoritative servers.  If you're interested in discussing
DoH in that context, I recommend starting in DPRIVE, and only moving to DOH
if there is positive interest and significant required work that is
specific to DoH.

On Thu, Jul 11, 2019 at 11:19 AM Hewitt, Rory <[email-masked]> wrote:

> Does the DoH WG have any input on whether 'we' should be looking into DoH
> for resolver->authority requests - similar to
> https://datatracker.ietf.org/doc/draft-hal-adot-operational-considerations/?
> Or does it not really apply, since we're only interested in
> client->resolver?
>
>
>
> Rory
>
>
> _______________________________________________
> Doh mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/doh
>