Subject: [Dots] Fwd: New Version Notification for draft-francois-ipv6-dots-signal-option-00.txt

From: Jérôme François <[email-masked]>
Date: Mon, 21 Mar 2016 18:59:32 +0100

Dear all,

Please find a new draft proposing an IPv6 Hop-by-Hop option for
delivering DOTS signal.
All comments are welcome.

Thanks,
Jérôme

-------- Message transféré --------
Sujet : 	New Version Notification for
draft-francois-ipv6-dots-signal-option-00.txt
Date : 	Mon, 21 Mar 2016 10:55:51 -0700
De : 	[email-masked]
Pour : 	Jerome Francois <[email-masked]>, Abdelkader Lahmadi
<[email-masked]>

A new version of I-D, draft-francois-ipv6-dots-signal-option-00.txt
has been successfully submitted by Jerome Francois and posted to the
IETF repository.

Name:		draft-francois-ipv6-dots-signal-option
Revision:	00
Title:		IPv6 DOTS Signal Option
Document date:	2016-03-21
Group:		Individual Submission
Pages:		13
URL:            https://www.ietf.org/internet-drafts/draft-francois-ipv6-dots-signal-option-00.txt
Status:         https://datatracker.ietf.org/doc/draft-francois-ipv6-dots-signal-option/
Htmlized:       https://tools.ietf.org/html/draft-francois-ipv6-dots-signal-option-00

Abstract:
   This document describes a delivery mechanism based on the IPv6 Hop-
   by-Hop options extension header type to carry a DOTS client signal
   message over a congested network due to a DDoS attack. The specified
   mechanism allows the DOTS client signal message to be included using
   an opportunistic way in outgoing IPv6 packets traveling then through
   the network to reach a DOTS server or relay.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: 🔓Dan Wing <[email-masked]>
Date: Wed, 23 Mar 2016 17:28:44 -0700

On 21-Mar-2016 10:59 am, Jérôme François <[email-masked]> wrote: 
> Dear all,
> 
> Please find a new draft proposing an IPv6 Hop-by-Hop option for delivering DOTS signal.

IPv6 Extensions Headers, themselves, are often rate-limited or dropped entirely, reference
  https://tools.ietf.org/html/draft-gont-v6ops-ipv6-ehs-packet-drops
  https://tools.ietf.org/html/draft-ietf-v6ops-ipv6-ehs-in-real-world
  http://www.iepg.org/2014-03-02-ietf89/fgont-iepg-ietf89-eh-update.pdf

While there might be agreement to not drop such packets over a link or over an ISP access network, some DOTS deployment models have the DOTS server on the Internet (e.g., cloud-based DDoS mitigation) where such agreements don't (can't) exist.

While using v6 for this sort of piggybacked DOTS message is admirable, it is limited to networks where the DOTS client, DOTS server, intervening network, and user traffic (on which to piggyback) are all using IPv6 during the attack.

Finally, such piggybacked messages seem difficult to authenticate.

-d

> Sujet :	New Version Notification for draft-francois-ipv6-dots-signal-option-00.txt
> De :	[email-masked] <mailto:[email-masked]>
> Pour :	Jerome Francois <[email-masked]> <mailto:[email-masked]>, Abdelkader Lahmadi <[email-masked]> <mailto:[email-masked]>
> 
> URL:            https://www.ietf.org/internet-drafts/draft-francois-ipv6-dots-signal-option-00.txt <https://www.ietf.org/internet-drafts/draft-francois-ipv6-dots-signal-option-00.txt>
> Status:         https://datatracker.ietf.org/doc/draft-francois-ipv6-dots-signal-option/ <https://datatracker.ietf.org/doc/draft-francois-ipv6-dots-signal-option/>
> Htmlized:       https://tools.ietf.org/html/draft-francois-ipv6-dots-signal-option-00 <https://tools.ietf.org/html/draft-francois-ipv6-dots-signal-option-00>
> 
> 
> Abstract:
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: "Roland Dobbins" <[email-masked]>
Date: Thu, 24 Mar 2016 10:48:33 +0700

On 24 Mar 2016, at 7:28, 🔓Dan Wing wrote:

>  some DOTS deployment models have the DOTS server on the Internet 
> (e.g., cloud-based DDoS mitigation) where such agreements don't 
> (can't) exist.

Concur 100%.  This isn't practicable.

-----------------------------------
Roland Dobbins <[email-masked]>