Subject: [Dots] Unique use cases

From: "Roman D. Danyliw" <[email-masked]>
Date: Tue, 29 Mar 2016 22:30:41 +0000

Hello!

There have been three drafts to date describing use cases for DOTS:

** [WG-UC] draft-ietf-dots-use-cases-01
** [ID-UC] draft-nishizuka-dots-inter-domain-usecases-01
** [IDC-UC] draft-nishizuka-dots-inter-domain-mechanism-00

[WG-UC] describes 7 primary use cases (numbered [WG-UC]-1 to [WG-UC]-7); [ID-UC] describes 5 uses cases; and [IDC-UC] describes 2 use cases.  Of these 14 use cases across three drafts, are any: duplicates? more specific instances of another use case? appropriate for a more generalized use case?

(1) What's the difference between [WG-UC]'s [WG-UC]-2, 3, 4, 5 and 6 beyond the kind of device acting as the DOTS client?  The write-ups are nearly identical.

(2) What's the difference between [ID-UC]'s [UD-UC]-1 (Section 4.1.1) and 2 (Section 4.1.2); and [WG-UC]-1, 2, 3, 4, 5 and 6?

(3) What's the difference between [ID-UC]'s [ID-UC]-3 (Section 4.2.1) and [ID-UC]-4 (Section 4.2.2); and [IDC-UC]-1 (Section 3.1)?

(4) [ID-UC]-5 and [IDC-UC]-2 appear to be acknowledged as the same use case in Section 4.2.3 of [ID-UC].  Is that correct?

Roman

---

From: "Roland Dobbins" <[email-masked]>
Date: Wed, 30 Mar 2016 19:04:43 +0700

On 30 Mar 2016, at 5:30, Roman D. Danyliw wrote:

> [WG-UC] describes 7 primary use cases (numbered [WG-UC]-1 to 
> [WG-UC]-7); [ID-UC] describes 5 uses cases; and [IDC-UC] describes 2 
> use cases.

The ancillary use-cases in [WG-UC] are also relevant.  Note that the 
other cited drafts do not appear to acknowledge or evince awareness of 
the existence of significant provisioning challenges with regards to 
DDoS mitigation services, nor do they address the potential benefits of 
information sharing with interested and authorized third parties.

> Of these 14 use cases across three drafts, are any: duplicates? more 
> specific instances of another use case? appropriate for a more 
> generalized use case?

The 9 total use-cases described in [WG-UC] are 
communications/operational model archetypes, which can be generalized 
across any type of network in any topological scenario.

[ID-UC] is overly prescriptive, gets into details of detection, 
classification, traceback, and mitigation mechanisms which are 
themselves beyond the scope of the DOTS WG; makes (yet another) 
ill-advised attempt to re-implement part of IPFIX within DOTS, badly; 
utilizes nonstandard terminology; makes artificial, irrelevant 
distinctions between single-homed and multi-homed topologies; and 
duplicates some elements of [WG-UC].

The above comments apply to [IDC-UC], as well.  It is unclear why both 
[ID-UC] and [IDC-UC] are thought necessary, except to promulgate the 
idea that there is some dichotomy between inter- and intra-domain DOTS 
use-cases.  As discussed previously, there are few if any discernible 
differences between inter- and intra-domain DOTS uses cases, within the 
context of DOTS itself.  The main actual differences consist of 
administrative procedures which are external to DOTS.

By way of contrast, [WG-UC] recognizes that the details of detection, 
classification, traceback, and mitigation mechanisms; telemetry formats; 
topological details; and network operator types are superfluous to 
understanding the common communications models between DOTS nodes and 
the functional roles of DOTS in typical attack/mitigation scenarios.

This is why [WG-UC] doesn't dive into those details - they are a 
distraction which gives the false impression that designing DOTS is a 
complex endeavor which has to take into account all kinds of situational 
specifics, when in reality it is a straightforward matter to which such 
external complexities are largely irrelevant.

>
> (1) What's the difference between [WG-UC]'s [WG-UC]-2, 3, 4, 5 and 6 
> beyond the kind of device acting as the DOTS client?  The write-ups 
> are nearly identical.

That's the point - to illustrate that different types of 
devices/applications can participate in DOTS, and that all the other 
differences are largely irrelevant to the actual requirements of DOTS, 
and that DOTS has universal applicability.

The use-cases in [WG-UC] are generalizable archetypes which demonstrate 
that the utility and applicability of DDoS Open Threat Signaling is 
completely independent of specific detection, classification, traceback, 
mitigation mechanisms, or telemetry formats; and that erroneous, 
unwarranted assumptions and assertions in these areas are 
counterproductive.  DOTS should not and must not be predicated upon 
telemetry formats, mitigation mechanisms, and topological scenarios 
which are completely external and irrelevant to the necessary 
requirements to make DOTS a useful, functional, and 
universally-deployable signaling mechanism.
>
> (2) What's the difference between [ID-UC]'s [UD-UC]-1 (Section 4.1.1) 
> and 2 (Section 4.1.2); and [WG-UC]-1, 2, 3, 4, 5 and 6?

There is no Section 4.1.1 nor Section 4.1.2 in 
draft-ietf-dots-use-cases-01, IIRC?
>
> (3) What's the difference between [ID-UC]'s [ID-UC]-3 (Section 4.2.1) 
> and [ID-UC]-4 (Section 4.2.2); and [IDC-UC]-1 (Section 3.1)?

Are you asking about the delta between the specific use cases in the two 
draft versions?

If so, repetitive language was elided, and a bit of additional 
contextual clarification was added.  No major changes, as these are 
archetypal use cases which are generalizable in nature.

Additional comments about 'cloud' use cases and so forth will be covered 
in the accompanying preso for -01, as these are just more iterations of 
the same basic archetypes.

> (4) [ID-UC]-5 and [IDC-UC]-2 appear to be acknowledged as the same use 
> case in Section 4.2.3 of [ID-UC].  Is that correct?

Unfortunately, I'm very confused by all the new acronyms and reliance on 
numbers which don't actually appear in the documents - there is no 
Section 4.2.3 in draft-ietf-dots-use-cases-01.  Can you provide more 
context?  Apologies for my confusion!

-----------------------------------
Roland Dobbins <[email-masked]>

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Thu, 31 Mar 2016 02:44:02 +0000

Hi Roman,
It's indeed a problem that we need make clear and solve. Please see my response inline:

In summary, we should consolidate all these use cases into several generalized use cases with minimum numbers and clarify their relations clearly, IMHO.

B.R.
Frank

-----邮件原件-----
发件人: Dots [mailto:[email-masked]] 代表 Roman D. Danyliw
发送时间: 2016年3月30日 6:31
收件人: [email-masked]
主题: [Dots] Unique use cases

Hello!

[WG-UC] describes 7 primary use cases (numbered [WG-UC]-1 to [WG-UC]-7); [ID-UC] describes 5 uses cases; and [IDC-UC] describes 2 use cases.  Of these 14 use cases across three drafts, are any: duplicates? more specific instances of another use case? appropriate for a more generalized use case?
[Frank]: draft-nishizuka-dots-inter-domain-usecases-01's last 2 use cases are the same as draft-nishizuka-dots-inter-domain-mechanism-00's 2 use cases. So, we have 12 use cases in this step. And we can further consolidate them, I believe.

(1) What's the difference between [WG-UC]'s [WG-UC]-2, 3, 4, 5 and 6 beyond the kind of device acting as the DOTS client?  The write-ups are nearly identical.
[Frank]: Your understanding is right. My suggestion is to consider how to compress them in next version.

(3) What's the difference between [ID-UC]'s [ID-UC]-3 (Section 4.2.1) and [ID-UC]-4 (Section 4.2.2); and [IDC-UC]-1 (Section 3.1)?
[Frank]: In theory, I think they should be the same use cases, IMHO.

[Frank]: yes.

Roman

_______________________________________________
Dots mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dots

---

From: "Roland Dobbins" <[email-masked]>
Date: Thu, 31 Mar 2016 19:34:18 +0700

On 31 Mar 2016, at 9:44, Xialiang (Frank) wrote:

> In summary, we should consolidate all these use cases into several 
> generalized use cases with minimum numbers and clarify their relations 
> clearly, IMHO.

We did this already with draft-ietf-dots-use-cases-01.  Those are 
archetypal use cases, as they are easily generalizable.

It doesn't matter if an operator is a transit backbone provider, IDC 
hoster, VPS provider, IaaS provider, broadband access provider, 
enterprise organization, ASP, CDN, etc.  The use cases in 
draft-ietf-dots-use-cases-01 cover the relevant communications and 
operational models, which is what really matters.

---

From: "Roman D. Danyliw" <[email-masked]>
Date: Thu, 31 Mar 2016 19:25:24 +0000

Hi Roland!

(chair hat off)
> -----Original Message-----
> From: Dots [mailto:[email-masked]] On Behalf Of Roland Dobbins
> Sent: Wednesday, March 30, 2016 8:05 AM
> To: [email-masked]
> Subject: Re: [Dots] Unique use cases
> 
[snip]

> That's the point - to illustrate that different types of devices/applications can
> participate in DOTS, and that all the other differences are largely irrelevant to
> the actual requirements of DOTS, and that DOTS has universal applicability.

I agree on the intent.  IMHO, by repeating the text so many times, this universal applicability and common behavior regardless of device got lost.

[snip]
> There is no Section 4.1.1 nor Section 4.1.2 in draft-ietf-dots-use-cases-01,
> IIRC?

The cited section numbers were for draft-nishizuka-dots-inter-domain-usecases-01 [aka, ID-UC].  I didn't cite the section numbers for draft-ietf-dots-use-cases-01 [aka, WG-UC].

> Are you asking about the delta between the specific use cases in the two

Ignoring, draft-ietf-dots-use-cases-01, I was trying to understand the difference between use cases #3 and 4 in Section 4.2.1/4.2.2 in draft-nishizuka-dots-inter-domain-usecases-01 [aka, ID-UC]; relative to use case #1 in Section 3.1 of draft-nishizuka-dots-inter-domain-mechanism-00 [aka, IDC-UC].  Are the former two use cases the same as the latter?

> numbers which don't actually appear in the documents - there is no Section
> 4.2.3 in draft-ietf-dots-use-cases-01.  Can you provide more context?
> Apologies for my confusion!

Sorry for the confusion.  Let me expand my notation for clarity ...

Use case #5 in Section 4.2.3 of draft-nishizuka-dots-inter-domain-usecases-01 [aka, ID-UC] appears to state that it is identical to use case #2 in Section 3.2 of draft-nishizuka-dots-inter-domain-mechanism-00 [aka, IDC-UC].  Is that correct?

Roman

---

From: kaname nishizuka <[email-masked]>
Date: Fri, 1 Apr 2016 13:55:57 +0900

Hi Roman,

The questions are related to my draft.
Sorry for my late reply, I added comments inline.

> Ignoring, draft-ietf-dots-use-cases-01, I was trying to understand the difference between use cases #3 and 4 in Section 4.2.1/4.2.2 in draft-nishizuka-dots-inter-domain-usecases-01 [aka, ID-UC]; re…
First, [ID-UC]-4,5 is intended to be identical with [IDC-UC]-1,2. (related to (4)): [ID-UC]-4 == [IDC-UC]-1, [ID-UC]-5 == [IDC-UC]-2.

[ID-UC]-4 (Mutual delegation) is a combination of [ID-UC]-3(delegation model), however, they have a slight difference.
The uniqueness of [ID-UC]-4 is that they utilize the DDoS protection system each other. Hence, it causes a coordination problem like how to determine the range of the protection they cover.

> Use case #5 in Section 4.2.3 of draft-nishizuka-dots-inter-domain-usecases-01 [aka, ID-UC] appears to state that it is identical to use case #2 in Section 3.2 of draft-nishizuka-dots-inter-domain-m…
yes, it's correct.

thank you,
kaname