Subject: [Dots] FW: New Version Notification for draft-teague-dots-protocol-01.txt

From: "Teague, Nik" <[email-masked]>
Date: Thu, 17 Nov 2016 06:38:01 +0000

FYI

This revision offers additional clarity and re-organizes schema within the document.

This does not yet address all the comments we’ve received around the data channel but it’s a step in that direction.

Thanks,

-Nik

On 17/11/2016, 15:36, "[email-masked]" <[email-masked]> wrote:

    A new version of I-D, draft-teague-dots-protocol-01.txt
    has been successfully submitted by Nik Teague and posted to the
    IETF repository.
    
    Name:		draft-teague-dots-protocol
    Revision:	01
    Title:		DDoS Open Threat Signaling Protocol
    Document date:	2016-11-17
    Group:		Individual Submission
    Pages:		40
    URL:            https://www.ietf.org/internet-drafts/draft-teague-dots-protocol-01.txt
    Status:         https://datatracker.ietf.org/doc/draft-teague-dots-protocol/
    Htmlized:       https://tools.ietf.org/html/draft-teague-dots-protocol-01
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-teague-dots-protocol-01
    
    Abstract:
       This document describes Distributed-Denial-of-Service (DDoS) Open
       Threat Signaling (DOTS), a protocol for requesting and managing
       mitigation of DDoS attacks.
    
       DOTS mitigation requests over the signal channel permit domains to
       signal the need for help fending off DDoS attacks, setting the scope
       and duration of the requested mitigation.  Elements called DOTS
       servers field the signals for help, and enable defensive
       countermeasures to defend against the attack reported by the clients,
       reporting the status of the delegated defense to the requesting
       clients.  DOTS clients additionally may use the data channel to
       manage filters and black- and white-lists to restrict or allow
       traffic to the clients' domains arbitrarily.
    
       The DOTS signal channel may operate over UDP [RFC0768] and if
       necessary TCP [RFC0793].  This revision discusses a transport-
       agnostic approach to this channel, focusing on the message exchanges
       and delegating transport specifics to other documents.  The DOTS data
       channel operates over HTTPS or a transport with similar reliability,
       interaction and security characteristics.

    
    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    The IETF Secretariat

---

From: "Teague, Nik" <[email-masked]>
Date: Thu, 17 Nov 2016 06:38:31 +0000

FYI

Thanks,

-Nik

    
    
    Abstract:

    

    The IETF Secretariat