Subject: Re: [Dots] Signal Channel WGLC: Trigger-Mitigation (Initial Jon's Comment)

From: <[email-masked]>
Date: Fri, 3 Aug 2018 08:53:16 +0000

Jon,

I agree with Tiru.

The current text provides a clear answer to your first two questions:

“For a mitigation request to continue beyond the initial negotiated lifetime, the DOTS client has to refresh the current mitigation request by sending a new PUT request. This PUT request MUST use the same 'mid' value, and MUST repeat all the other parameters as sent in the original mitigation request apart from a possible change to the lifetime parameter value.”

For the last one, we can be explicit and add this NEW sentence:

NEW:
  This PUT request is treated as a refresh of the current mitigation.

Please let me know if you think this change is needed. Thanks.

Cheers,
Med

De : Dots [mailto:[email-masked]] De la part de Konda, Tirumaleswar Reddy
Envoyé : jeudi 2 août 2018 16:41
À : Jon Shallow; [email-masked]
Objet : Re: [Dots] Signal Channel WGLC: Trigger-Mitigation

Please see inline [TR]

From: Dots <[email-masked]> On Behalf Of Jon Shallow
Sent: Thursday, August 2, 2018 8:03 PM
To: [email-masked]
Subject: [Dots] Signal Channel WGLC: Trigger-Mitigation

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
Hi there

https://github.com/boucadair/draft-ietf-dots-signal-channel/blob/master/wdiff%20draft-ietf-dots-signal-channel-21.txt%20draft-ietf-dots-signal-channel-22.pdf has the trigger-mitigation moved to mitigation configuration from the channel configuration as discussed on the mailing list.

When doing a PUT mitigation refresh,

4.4.1 Request Mitigation
…
For a mitigation request to continue beyond the initial negotiated lifetime, the DOTS client has to refresh the current mitigation request by sending a new PUT request. This PUT request MUST use the same 'mid' value, and MUST repeat all the other parameters as sent in the original mitigation request apart from a possible change to the lifetime parameter value.
4.4.2 Retrieve Information Related to a Mitigation

Are we allowed to change trigger-mitigation value for the refresh PUT?

[TR] No.

- we allow for a change in lifetime

Also, when doing the efficacy update PUT do the same rules apply for trigger-mitigation?

[TR] Yes.

Is an efficacy update to be treated as a refresh as well – I think it is?

[TR] Yup.

-Tiru

Regards

Jon

---

From: "Jon Shallow" <[email-masked]>
Date: Fri, 3 Aug 2018 10:01:39 +0100

Hi Med,

The additional text brings the clarity I need – thanks.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of [email-masked]
Sent: 03 August 2018 09:53
To: Konda, Tirumaleswar Reddy; Jon Shallow; [email-masked]
Subject: Re: [Dots] Signal Channel WGLC: Trigger-Mitigation (Initial Jon's Comment)

Jon, 

I agree with Tiru. 

NEW:

Cheers,

Med

Please see inline [TR]

  _____  

Hi there

4.4.1 Request Mitigation

…

[TR] No. 

[TR] Yes.

[TR] Yup.

-Tiru

Regards

Jon

---

From: <[email-masked]>
Date: Fri, 3 Aug 2018 09:07:28 +0000

Re-,

OK, done.

This one is fixed.

Thanks.

Cheers,
Med

De : Jon Shallow [mailto:[email-masked]]
Envoyé : vendredi 3 août 2018 11:02
À : BOUCADAIR Mohamed IMT/OLN; Konda, Tirumaleswar Reddy; [email-masked]
Objet : RE: [Dots] Signal Channel WGLC: Trigger-Mitigation (Initial Jon's Comment)

Hi Med,

Regards

Jon

Jon,

I agree with Tiru.

NEW:

Cheers,
Med

Please see inline [TR]

4.4.1 Request Mitigation
…

[TR] No.

[TR] Yes.

[TR] Yup.

-Tiru

Regards

Jon

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Fri, 3 Aug 2018 09:35:59 +0000

Update looks good.

-Tiru

From: [email-masked] <[email-masked]>
Sent: Friday, August 3, 2018 2:37 PM
To: Jon Shallow <[email-masked]>; Konda, Tirumaleswar Reddy <[email-masked]>; [email-masked]
Subject: RE: [Dots] Signal Channel WGLC: Trigger-Mitigation (Initial Jon's Comment)

OK, done.

This one is fixed.

Thanks.

Cheers,
Med

De : Jon Shallow [mailto:[email-masked]]
Envoyé : vendredi 3 août 2018 11:02
À : BOUCADAIR Mohamed IMT/OLN; Konda, Tirumaleswar Reddy; [email-masked]<mailto:[email-masked]>
Objet : RE: [Dots] Signal Channel WGLC: Trigger-Mitigation (Initial Jon's Comment)

Hi Med,

Regards

Jon

From: Dots [mailto: [email-masked]<mailto:[email-masked]>] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: 03 August 2018 09:53
To: Konda, Tirumaleswar Reddy; Jon Shallow; [email-masked]<mailto:[email-masked]>
Subject: Re: [Dots] Signal Channel WGLC: Trigger-Mitigation (Initial Jon's Comment)

Jon,

I agree with Tiru.

NEW:

Cheers,
Med

De : Dots [mailto:[email-masked]] De la part de Konda, Tirumaleswar Reddy
Envoyé : jeudi 2 août 2018 16:41
À : Jon Shallow; [email-masked]<mailto:[email-masked]>
Objet : Re: [Dots] Signal Channel WGLC: Trigger-Mitigation

Please see inline [TR]

From: Dots <[email-masked]<mailto:[email-masked]>> On Behalf Of Jon Shallow
Sent: Thursday, August 2, 2018 8:03 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Dots] Signal Channel WGLC: Trigger-Mitigation

4.4.1 Request Mitigation
…

[TR] No.

[TR] Yes.

[TR] Yup.

-Tiru

Regards

Jon