Subject: [Dots] WGLC Signal: mid=123 then overlapping mid=122

From: "Jon Shallow" <[email-masked]>
Date: Sat, 4 Aug 2018 12:58:04 +0100

Hi there,

What happens when we receive mid=123, followed by mid=122 that overlaps
mid=123?

Do we put mid=122 into an active-but-terminating state?

- state 5 is not really correct here as per the description

Do we return 4.09 conflict with an appropriate (perhaps new)
conflict-status?

- my preference, but this is not said anywhere I can find

- should conflict-scope also include the 'mid' in the list (YANG)?

Do we return 4.00 (bad request)?

- I do not really like this one as there is no indication as to why -
especially of there was an out of sequence packet arrival at the DOTS
server.

Regards

Jon

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 6 Aug 2018 03:08:24 +0000

Hi Jon,

Please see inline [TR]

From: Dots <[email-masked]> On Behalf Of Jon Shallow
Sent: Saturday, August 4, 2018 5:28 PM
To: [email-masked]
Subject: [Dots] WGLC Signal: mid=123 then overlapping mid=122

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
Hi there,

What happens when we receive mid=123, followed by mid=122 that overlaps mid=123?

[TR] In the previous threads we have already discussed to add new conflict-status for conflicting mitigation requests from the same DOTS client (e.g. conflict-status MSB set to 1 means conflict from different DOTS clients, MSB set to 0 means conflict from the same DOTS client).
The mitigation request with mid=122 will be rejected with 4.09 conflict. I don’t get your comment, why put mid=122 into active-but-terminating state ?

Do we return 4.09 conflict with an appropriate (perhaps new) conflict-status ?

[TR] Yes

[TR] we will update the draft.

- should conflict-scope also include the ‘mid’ in the list (YANG)?

[TR] Yes, including mid can help troubleshooting.

[TR] No.

-Tiru

- I do not really like this one as there is no indication as to why – especially of there was an out of sequence packet arrival at the DOTS server.

Regards

Jon

---

From: "Jon Shallow" <[email-masked]>
Date: Mon, 6 Aug 2018 08:56:20 +0100

Hi Tiru,

Please see inline Jon>

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of Konda, Tirumaleswar Reddy
Sent: 06 August 2018 04:08
To: Jon Shallow; [email-masked]
Subject: Re: [Dots] WGLC Signal: mid=123 then overlapping mid=122

Hi Jon,

Please see inline [TR] 

  _____  

Hi there,

Jon> I may have blinked, but do not recall this particular discussion about using MSB and therefor needs to get into the draft.  An alternative is to have a different variable for same/different DOTS client.

Jon> This potential option of what to return was written before we focused in on the single case for active-but-terminating.

[TR] Yes

Jon> Thanks

Jon> Please include it in the draft.

~Jon

[TR] No. 

-Tiru

Regards

Jon

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 6 Aug 2018 08:11:22 +0000

Inline [TR1]

From: Jon Shallow <[email-masked]>
Sent: Monday, August 6, 2018 1:26 PM
To: Konda, Tirumaleswar Reddy <[email-masked]>; [email-masked]
Subject: RE: [Dots] WGLC Signal: mid=123 then overlapping mid=122

Please see inline Jon>

Regards

Jon

From: Dots [mailto: [email-masked]<mailto:[email-masked]>] On Behalf Of Konda, Tirumaleswar Reddy
Sent: 06 August 2018 04:08
To: Jon Shallow; [email-masked]<mailto:[email-masked]>
Subject: Re: [Dots] WGLC Signal: mid=123 then overlapping mid=122

Hi Jon,

Please see inline [TR]

From: Dots <[email-masked]<mailto:[email-masked]>> On Behalf Of Jon Shallow
Sent: Saturday, August 4, 2018 5:28 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Dots] WGLC Signal: mid=123 then overlapping mid=122

[TR1] Both options look okay, I like the MSB approach ☺

-Tiru

[TR] Yes

[TR] No.

-Tiru

Regards

Jon

---

From: <[email-masked]>
Date: Mon, 6 Aug 2018 08:20:28 +0000

Re-,

Trying to conclude on this one:

NEW:

   For example, if the DOTS server receives a mitigation request which

   overlaps with an existing mitigation with a higher numeric 'mid', the

   DOTS server rejects the request by returning 4.09 (Conflict) to the

   DOTS client.  The response includes enough information for a DOTS

   client to recognize the source of the conflict as described below:

   conflict-information:  Indicates that a mitigation request is

      conflicting with another mitigation request.  This optional

      attribute has the following structure:

      conflict-cause:  Indicates the cause of the conflict.  The

         following values are defined:

         1:  Overlapping targets. 'conflict-scope' provides more details

             about the conflicting target clauses.

      conflict-scope:  Indicates the conflict scope.  It may include a

         list of IP addresses, a list of prefixes, a list of port

         numbers, a list of target protocols, a list of FQDNs, a list of

         URIs, a list of alias-names, or a 'mid'.

(the YANG module will be updated accordingly).

Cheers,
Med

De : Dots [mailto:[email-masked]] De la part de Konda, Tirumaleswar Reddy
Envoyé : lundi 6 août 2018 10:11
À : Jon Shallow; [email-masked]
Objet : Re: [Dots] WGLC Signal: mid=123 then overlapping mid=122

Inline [TR1]

Please see inline Jon>

Regards

Jon

Hi Jon,

Please see inline [TR]

-Tiru

[TR] Yes

[TR] No.

-Tiru

Regards

Jon

---

From: "Jon Shallow" <[email-masked]>
Date: Mon, 6 Aug 2018 09:40:10 +0100

Hi Med,

This looks good to me.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of [email-masked]
Sent: 06 August 2018 09:20
To: Konda, Tirumaleswar Reddy; Jon Shallow; [email-masked]
Subject: Re: [Dots] WGLC Signal: mid=123 then overlapping mid=122

Re-,

NEW:

 

Cheers,

Med

Inline [TR1]

  _____  

Hi Tiru,

Please see inline Jon>

Regards

Jon

Hi Jon,

Please see inline [TR] 

  _____  

Hi there,

[TR1] Both options look okay, I like the MSB approach J

-Tiru

[TR] Yes

Jon> Thanks

~Jon

[TR] No. 

-Tiru

Regards

Jon

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 6 Aug 2018 09:23:03 +0000

It is not complete, I don’t see any conflict-status (e.g. active mitigation request withdrawn upon DOTS signal channel session loss and mitigation is triggered for the pre-configured scope) ?

-Tiru

From: [email-masked] <[email-masked]>
Sent: Monday, August 6, 2018 1:50 PM
To: Konda, Tirumaleswar Reddy <[email-masked]>; Jon Shallow <[email-masked]>; [email-masked]
Subject: RE: [Dots] WGLC Signal: mid=123 then overlapping mid=122

NEW:

Cheers,
Med

De : Dots [mailto:[email-masked]] De la part de Konda, Tirumaleswar Reddy
Envoyé : lundi 6 août 2018 10:11
À : Jon Shallow; [email-masked]<mailto:[email-masked]>
Objet : Re: [Dots] WGLC Signal: mid=123 then overlapping mid=122

Inline [TR1]

From: Jon Shallow <[email-masked]<mailto:[email-masked]>>
Sent: Monday, August 6, 2018 1:26 PM
To: Konda, Tirumaleswar Reddy <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Dots] WGLC Signal: mid=123 then overlapping mid=122

Please see inline Jon>

Regards

Jon

Hi Jon,

Please see inline [TR]

-Tiru

[TR] Yes

[TR] No.

-Tiru

Regards

Jon

---

From: <[email-masked]>
Date: Mon, 6 Aug 2018 11:26:58 +0000

Re-,

Conflict-status is not required for the scenario discussed in this thread.

For the scenario where a mitigation is withdrawn because another one is triggered on signal loss, and assuming the session with the client is re-established and notifications about the state change are still scheduled by the server, conflict-scope can include the mid of the pre-configured request. Such information is explicit about the withdrawal cause.

Cheers,
Med

De : Konda, Tirumaleswar Reddy [mailto:[email-masked]]
Envoyé : lundi 6 août 2018 11:23
À : BOUCADAIR Mohamed IMT/OLN; Jon Shallow; [email-masked]
Objet : RE: [Dots] WGLC Signal: mid=123 then overlapping mid=122

-Tiru

NEW:

Cheers,
Med

Inline [TR1]

Please see inline Jon>

Regards

Jon

Hi Jon,

Please see inline [TR]

-Tiru

[TR] Yes

[TR] No.

-Tiru

Regards

Jon

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 6 Aug 2018 12:03:47 +0000

Agreed, Thanks for the clarification.

Cheers,
-Tiru

From: Dots <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, August 6, 2018 4:57 PM
To: Konda, Tirumaleswar Reddy <[email-masked]>; Jon Shallow <[email-masked]>; [email-masked]
Subject: Re: [Dots] WGLC Signal: mid=123 then overlapping mid=122

Cheers,
Med

De : Konda, Tirumaleswar Reddy [mailto:[email-masked]]
Envoyé : lundi 6 août 2018 11:23
À : BOUCADAIR Mohamed IMT/OLN; Jon Shallow; [email-masked]<mailto:[email-masked]>
Objet : RE: [Dots] WGLC Signal: mid=123 then overlapping mid=122

-Tiru

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Monday, August 6, 2018 1:50 PM
To: Konda, Tirumaleswar Reddy <[email-masked]<mailto:[email-masked]>>; Jon Shallow <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Dots] WGLC Signal: mid=123 then overlapping mid=122

NEW:

Cheers,
Med

Inline [TR1]

Please see inline Jon>

Regards

Jon

Hi Jon,

Please see inline [TR]

-Tiru

[TR] Yes

[TR] No.

-Tiru

Regards

Jon

---

From: <[email-masked]>
Date: Mon, 6 Aug 2018 12:14:45 +0000

Thank you, Tiru.

I think we can close this one.

Cheers,
Med

De : Konda, Tirumaleswar Reddy [mailto:[email-masked]]
Envoyé : lundi 6 août 2018 14:04
À : BOUCADAIR Mohamed IMT/OLN; Jon Shallow; [email-masked]
Objet : RE: [Dots] WGLC Signal: mid=123 then overlapping mid=122

Cheers,
-Tiru

Cheers,
Med

-Tiru

NEW:

Cheers,
Med

Inline [TR1]

Please see inline Jon>

Regards

Jon

Hi Jon,

Please see inline [TR]

-Tiru

[TR] Yes

[TR] No.

-Tiru

Regards

Jon