Subject: Re: [Dots] several comments on draft-ietf-dots-architecture-06:

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 3 Sep 2018 09:54:54 +0000

Update looks good to me.

-Tiru

From: Mortensen, Andrew <[email-masked]>
Sent: Friday, July 20, 2018 6:04 PM
To: Konda, Tirumaleswar Reddy <[email-masked]>
Cc: Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: several comments on draft-ietf-dots-architecture-06:

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
I’ve got a pull request to incorporate some minor changes to address issues 2, 3 and 5 below:

<https://github.com/dotswg/dots-architecture/pull/29>

Unless there are objections, I’ll merge and submit a new draft revision. The remaining barrier to initiating WGLC will then be the updated NAT considerations.

andrew

On Jul 16, 2018, at 3:40 AM, Konda, Tirumaleswar Reddy <[email-masked]<mailto:[email-masked]>> wrote:

[EXTERNAL EMAIL]
Hi Frank,

Thanks for the review. Please see inline [TR]

From: Dots [mailto:[email-masked]] On Behalf Of Xialiang (Frank, Network Integration Technology Research Dept)
Sent: Wednesday, July 11, 2018 3:03 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Dots] several comments on draft-ietf-dots-architecture-06:

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
Hi draft authors,
I have several comments of this draft as below for your consideration:
1.       Section 1.2, / “so that only authorized clients can invoke the DOTS service” / “so that only authorized clients/servers can invoke/honor the DOTS service”;

[TR] DOTS client is both authenticated and authorized to invoke the DOTS service but the DOTS server is only authenticated by the DOTS client. I don’t see the need to add “server” and “honor” in the above line.

2.       Section 2.2.2, / If a DOTS server refuses a DOTS client’s request for mitigation, the DOTS server SHOULD include the refusal reason in the server signal sent to the client / If a DOTS server refuses a DOTS client’s request for mitigation, the DOTS server MUST include the refusal reason in the server signal sent to the client;

[TR] Agreed, we will update draft.

3.       Section 3.2.3, / "End-customer with a single upstream transit provider offering DDoS mitigation services" described in [I-D.ietf-dots-use-cases] /  "Upstream DDoS Mitigation by an Upstream Internet Transit Provider" described in [I-D.ietf-dots-use-cases];

[TR] Okay, will fix.

4.       Section 3.2.3, you say “For example, the recursing domain’s mitigator should incorporate into mitigation status messages available metrics such as dropped packet or byte counts from the recursed mitigation.”, but this is not described in current DOTS signal channel draft. What’s your opinion about whether we should add the specified content into the signal channel draft?

[TR] DOTS client is conveyed the mitigation metrics (e.g. bytes-dropped, bps-dropped etc.) by the DOTS server. The DOTS client is opaque to the recursion of the originating mitigation request to the secondary DOTS server, hence the signal channel draft does not discuss recursive signaling but explains conveying the mitigation metrics to the DOTS client in Section 4.4.2.

5.       Section 3.3.3, by reviewing the DOTS signal channel draft, my take is a signal session (sid) can carry multiple mitigation-scope requesting conversations (cuid + mid + cdid (optional)), is it right? If so, by saying “a DOTS operator may configure the DOTS session to trigger mitigation when the DOTS server ceases receiving DOTS client signals (or vice versa) beyond the miss count or period permitted by the protocol.”, which mitigation conversation do you mean to trigger, or all of them over the same signal session?

[TR] If the DOTS server creases receiving DOTS client signal, mitigation will be triggered for all the mitigation requests signaled over the same DOTS signal channel session.

Cheers,
-Tiru

Thanks!

B.R.
Frank

---

From: "Xialiang (Frank, Network Integration Technology Research Dept)" <[email-masked]>
Date: Tue, 4 Sep 2018 01:32:28 +0000

+1

发件人: Konda, Tirumaleswar Reddy [mailto:[email-masked]]
发送时间: 2018年9月3日 17:55
收件人: Mortensen, Andrew <[email-masked]>
抄送: Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]>; [email-masked]; [email-masked]
主题: RE: several comments on draft-ietf-dots-architecture-06:

Update looks good to me.

-Tiru

From: Mortensen, Andrew <[email-masked]<mailto:[email-masked]>>
Sent: Friday, July 20, 2018 6:04 PM
To: Konda, Tirumaleswar Reddy <[email-masked]<mailto:[email-masked]>>
Cc: Xialiang (Frank, Network Integration Technology Research Dept) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: several comments on draft-ietf-dots-architecture-06:

andrew

[EXTERNAL EMAIL]
Hi Frank,

[TR] Okay, will fix.

Cheers,
-Tiru

Thanks!

B.R.
Frank