Subject: [Dots] Are we being too restrictive in the Alias definition requirements?

From: "Jon Shallow" <[email-masked]>
Date: Thu, 20 Sep 2018 08:36:22 +0100

Hi there,

Signal Draft 4.4.1.  Request Mitigation

   In the PUT request at least one of the attributes 'target-prefix',

   'target-fqdn', 'target-uri', or 'alias-name' MUST be present.

Data Draft 6.1.  Create Aliases

   In POST or PUT requests, at least one of the 'target-prefix',

   'target-fqdn', or 'target-uri' attributes MUST be present.  DOTS

   agents can safely ignore Vendor-Specific parameters they don't

   understand.

So, it is not possible to have an Alias template that contains just ports or
protocols that can be used in a mitigation request that does include the
'target-prefix', 'target-fqdn', or 'target-uri' attributes.  Is this too
restrictive?

Possible updates

Signal Draft 4.4.1.  Request Mitigation

NEW:

   In the PUT request at least one of the attributes 'target-prefix',

   'target-fqdn', 'target-uri', or 'alias-name' where the alias contains at
least one of the attributes 'target-prefix', 'target-fqdn', 'target-uri',
MUST be present.

Data Draft 6.1.  Create Aliases

NEW:

   In POST or PUT requests, at least one of the 'target-',

   attributes MUST be present.  DOTS

   agents can safely ignore Vendor-Specific parameters they don't

   understand.

Regards

Jon

---

From: <[email-masked]>
Date: Thu, 20 Sep 2018 07:49:16 +0000

Hi Jon,

Please remind that aliases are meant to identify resources.  A single port number does not identify a resource; the combination of an ip address/fqdn and ports does.

If you want to include only an port number or a protocol, you can create an alias which will set the target-prefix to all prefixes of the domain.

I don't see the need to modify the current text. Thanks.

Cheers,
Med

De : Dots [mailto:[email-masked]] De la part de Jon Shallow
Envoyé : jeudi 20 septembre 2018 09:36
À : [email-masked]
Objet : [Dots] Are we being too restrictive in the Alias definition requirements?

Hi there,

So, it is not possible to have an Alias template that contains just ports or protocols that can be used in a mitigation request that does include the 'target-prefix', 'target-fqdn', or 'target-uri' attributes.  Is this too restrictive?

Possible updates

NEW:
   In the PUT request at least one of the attributes 'target-prefix',
   'target-fqdn', 'target-uri', or 'alias-name' where the alias contains at least one of the attributes 'target-prefix', 'target-fqdn', 'target-uri', MUST be present.

NEW:

Regards

Jon

---

From: "Jon Shallow" <[email-masked]>
Date: Thu, 20 Sep 2018 09:25:19 +0100

Hi Med,

Not a problem, I just needed to ask the question.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
Sent: 20 September 2018 08:49
To: Jon Shallow; [email-masked]
Subject: Re: [Dots] Are we being too restrictive in the Alias definition
requirements?

Hi Jon, 

Please remind that aliases are meant to identify resources.  A single port
number does not identify a resource; the combination of an ip address/fqdn
and ports does. 

If you want to include only an port number or a protocol, you can create an
alias which will set the target-prefix to all prefixes of the domain. 

I don’t see the need to modify the current text. Thanks.

Cheers,

Med

De : Dots [mailto:[email-masked]] De la part de Jon Shallow
Envoyé : jeudi 20 septembre 2018 09:36
À : [email-masked]
Objet : [Dots] Are we being too restrictive in the Alias definition
requirements?

Hi there,

   understand.

Possible updates

NEW:

NEW:

   understand.

Regards

Jon

---

From: <[email-masked]>
Date: Thu, 20 Sep 2018 08:32:28 +0000

Re-,

Thank you for raising the point.

Cheers,
Med

De : Jon Shallow [mailto:[email-masked]]
Envoyé : jeudi 20 septembre 2018 10:25
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]
Objet : RE: [Dots] Are we being too restrictive in the Alias definition requirements?

Hi Med,

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of [email-masked]
Sent: 20 September 2018 08:49
To: Jon Shallow; [email-masked]
Subject: Re: [Dots] Are we being too restrictive in the Alias definition requirements?

Hi Jon,

Cheers,
Med

Hi there,

Possible updates

NEW:

NEW:

Regards

Jon