Subject: [Dots] Shepherd feedback on draft-ietf-dots-data-channel-21

From: Roman Danyliw <[email-masked]>
Date: Wed, 26 Sep 2018 20:36:03 +0000

Hi!

In preparing my write-up for draft-ietf-dots-data-channel-21 I found no issues beyond one of formatting.  idnits 2.15.01 reported:

--[ snip idnits output ]--
tmp/draft-ietf-dots-data-channel-21.txt(933): Line is too long: the offending characters are 'tor'
tmp/draft-ietf-dots-data-channel-21.txt(934): Line is too long: the offending characters are ')?'
tmp/draft-ietf-dots-data-channel-21.txt(937): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(939): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(944): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(946): Line is too long: the offending characters are 'ator)'
tmp/draft-ietf-dots-data-channel-21.txt(947): Line is too long: the offending characters are 'operator'
tmp/draft-ietf-dots-data-channel-21.txt(948): Line is too long: the offending characters are ')?'
tmp/draft-ietf-dots-data-channel-21.txt(959): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(961): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(966): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(1003): Line is too long: the offending characters are 'tor'
tmp/draft-ietf-dots-data-channel-21.txt(1004): Line is too long: the offending characters are ')?'
tmp/draft-ietf-dots-data-channel-21.txt(1015): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(1017): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(1022): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(1024): Line is too long: the offending characters are 'ator)'
tmp/draft-ietf-dots-data-channel-21.txt(1025): Line is too long: the offending characters are 'operator'
tmp/draft-ietf-dots-data-channel-21.txt(1026): Line is too long: the offending characters are ')?'
tmp/draft-ietf-dots-data-channel-21.txt(1029): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(1031): Line is too long: the offending characters are 'r'
tmp/draft-ietf-dots-data-channel-21.txt(1036): Line is too long: the offending characters are 'r'

  ** There are 22 instances of too long lines in the document, the longest
     one being 8 characters in excess of 72.
--[ end ]--

To get more context on which were the offending lines:

--[ snip]--
$ cat draft-ietf-dots-data-channel-21.txt | awk 'length($0) > 72 {print NR ":" $0}'
933:       |              |     |     |     +--rw source-port-range-or-operator
934:       |              |     |     |        +--rw (port-range-or-operator)?
937:       |              |     |     |           |  |       inet:port-number
939:       |              |     |     |           |          inet:port-number
944:       |              |     |     |                      inet:port-number
946:       |              |     |        +--:(destination-port-range-or-operator)
947:       |              |     |           +--rw destination-port-range-or-operator
948:       |              |     |              +--rw (port-range-or-operator)?
959:       |              |     |                 |  |       inet:port-number
961:       |              |     |                 |          inet:port-number
966:       |              |     |                            inet:port-number
1003:       |              |     |     |     +--rw source-port-range-or-operator
1004:       |              |     |     |        +--rw (port-range-or-operator)?
1015:       |              |     |     |           |  |       inet:port-number
1017:       |              |     |     |           |          inet:port-number
1022:       |              |     |     |                      inet:port-number
1024:       |              |     |        +--:(destination-port-range-or-operator)
1025:       |              |     |           +--rw destination-port-range-or-operator
1026:       |              |     |              +--rw (port-range-or-operator)?
1029:       |              |     |                 |  |       inet:port-number
1031:       |              |     |                 |          inet:port-number
1036:       |              |     |                            inet:port-number
--[snip]--

Can these please be fixed in a -22 prior to requesting publication.

Thanks,
Roman

---

From: <[email-masked]>
Date: Thu, 27 Sep 2018 05:36:36 +0000

Hi Roman, 

The diagrams were generated using a command which allows to break long lines. This is why you can see in the draft, e.g.,

       |              |     |     |           +--:(range)
       |              |     |     |           |  +--rw lower-port
       |              |     |     |           |  |       inet:port-number
       |              |     |     |           |  +--rw upper-port
       |              |     |     |           |          inet:port-number
       |              |     |     |           +--:(operator)
       |              |     |     |              +--rw operator?
       |              |     |     |              |       operator
       |              |     |     |              +--rw port
       |              |     |     |                      inet:port-number

For the nits you reported, I have already tried both commands:  

pyang -f tree --tree-line-length 69 ...

and 

pyang -f tree --tree-line-length 50 ...

but with the same result. 

I suggest to leave this to be fixed by the RFC editor. 

Thanks you. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de Roman Danyliw
> Envoyé : mercredi 26 septembre 2018 22:36
> À : [email-masked]
> Objet : [Dots] Shepherd feedback on draft-ietf-dots-data-channel-21
> 
> Hi!
> 
> In preparing my write-up for draft-ietf-dots-data-channel-21 I found no
> issues beyond one of formatting.  idnits 2.15.01 reported:
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 28 Sep 2018 13:07:28 +0000

Hi Med!

> -----Original Message-----
> From: Dots [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Thursday, September 27, 2018 1:37 AM
> To: Roman Danyliw <[email-masked]>; [email-masked]
> Subject: Re: [Dots] Shepherd feedback on draft-ietf-dots-data-channel-21
> 
> Hi Roman,
> 
> The diagrams were generated using a command which allows to break long
> lines. This is why you can see in the draft, e.g.,
> 
>        |              |     |     |           +--:(range)

Thanks for making the changes in -22 to clean this up.

Roman