Subject: [Dots] Erik Kline's No Objection on draft-ietf-dots-signal-filter-control-06: (with COMMENT)

From: Erik Kline via Datatracker <[email-masked]>
Date: Tue, 23 Jun 2020 21:19:56 -0700

Erik Kline has entered the following ballot position for
draft-ietf-dots-signal-filter-control-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-filter-control/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

[[ questions ]]

[ section 3.2.1 ]

* "If not, the polling mechanism ... has to be followed".  Should this use some
  actual 2119 language?

* Is the specified client behaviour in the event of a 5.03 really MUST? That
  would definitely seem like recommended behaviour to me, but does it perhaps
  risk being over-specified to say retries without parameters MUST be
  attempted? I.e., should it be a SHOULD?

[[ nits ]]

[ section 6 ]

* "entitled to access only to resources" ->
  "entitled to access only the resources"

---

From: <[email-masked]>
Date: Wed, 24 Jun 2020 05:59:38 +0000

Hi Erik, 

Thanks for the comments. 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Erik Kline via Datatracker [mailto:[email-masked]]
> Envoyé : mercredi 24 juin 2020 06:20
> À : The IESG
> Cc : [email-masked]; [email-masked];
> [email-masked]; Valery Smyslov; Liang Xia; [email-masked]
> Objet : Erik Kline's No Objection on draft-ietf-dots-signal-filter-control-
> 06: (with COMMENT)
> 

[Med] We have already discussed in the wg "s/has to/MUST". The reason why we are not using the normative language here is that it is fine for a dots client to use any alternative method (including future ones) to get the status as a backup if the recommended behavior is not followed.    

>   attempted? I.e., should it be a SHOULD?

[Med] Please note that "MUST" applies for "initial mitigation or a mitigation with adjusted scope". 

   If the DOTS client receives a 5.03 (Service Unavailable) with a
   ^^
   diagnostic payload indicating a failed ACL update as a response to an
   initial mitigation or a mitigation with adjusted scope, the DOTS
   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   client MUST immediately send a new request which repeats all the
   parameters as sent in the failed mitigation request but without
   including the ACL attributes.

This behavior is meant to place the mitigation request without ACLs so that attack mitigation starts immediately.

>   "entitled to access only the resources"
[Med] Fixed. Thanks. 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.