Subject: [Dots] Murray Kucherawy's No Objection on draft-ietf-dots-signal-filter-control-06: (with COMMENT)

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Sun, 21 Jun 2020 11:28:42 -0700

Murray Kucherawy has entered the following ballot position for
draft-ietf-dots-signal-filter-control-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-filter-control/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Some minor stuff only:

Section 1.1:

OLD:

   A typical case is a conflict between filtering rules installed by a
   DOTS client and the mitigation actions of a DDoS mitigator.  Such
   case is a DOTS client which configures during 'idle' time (i.e., no
   mitigation is active) some filtering rules using the DOTS data
   channel protocol to permit traffic from accept-listed sources, but
   during a volumetric DDoS attack the DDoS mitigator identifies the
   source addresses/prefixes in the accept-listed filtering rules are
   attacking the target.  For example, an attacker can spoof the IP
   addresses of accept-listed sources to generate attack traffic or the
   attacker can compromise the accept-listed sources and program them to
   launch a DDoS attack.

NEW:

   A typical case is a conflict between filtering rules installed by a
   DOTS client and the mitigation actions of a DDoS mitigator.  Consider,
   for instance, a DOTS client that configures during 'idle' time (i.e., no
   mitigation is active) some filtering rules using the DOTS data
   channel protocol to permit traffic from accept-listed sources.  However,
   during a volumetric DDoS attack the DDoS mitigator identifies the
   source addresses/prefixes in the accept-listed filtering rules are
   attacking the target.  For example, an attacker can spoof the IP
   addresses of accept-listed sources to generate attack traffic or the
   attacker can compromise the accept-listed sources and program them to
   launch a DDoS attack.

Section 1.2:

* "An augment to the DOTS signal channel ..." -- s/augment/amendment/
("augment" isn't a thing, it's an action)

Section 3.2.1:

* Although this section declares the acronym "ACE" for "Access Control Entry",
that acronym is used nowhere else in the document.

* "... notifies that DOTS client with the change ..." -- s/with/of, I think?

Section 6:

* "... does not allow to create new filtering rules ..." -- s/to
create/creation of/

* "... entitled to access only to resources ..." -- s/only to/only those/

---

From: <[email-masked]>
Date: Mon, 22 Jun 2020 05:52:05 +0000

Hi Murray, 

Thank you for the review. 

I implemented almost all your suggestions. 

An updated version can be seen at:

https://github.com/boucadair/filter-control/blob/master/draft-ietf-dots-signal-filter-control-06.txt 

FWIW, a diff is available here: https://github.com/boucadair/filter-control/blob/master/IESG-Review%20Murray.pdf

Cheers,
Med

> -----Message d'origine-----
> De : Murray Kucherawy via Datatracker [mailto:[email-masked]]
> Envoyé : dimanche 21 juin 2020 20:29
> À : The IESG
> Cc : [email-masked]; [email-masked];
> [email-masked]; Valery Smyslov; Liang Xia
> Objet : Murray Kucherawy's No Objection on draft-ietf-dots-signal-filter-
> control-06: (with COMMENT)
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.