Subject: [Dots] I-D Action: draft-ietf-dots-telemetry-24.txt

From: [email-masked]
Date: Wed, 23 Feb 2022 03:55:22 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Telemetry
        Authors         : Mohamed Boucadair
                          Tirumaleswar Reddy.K
                          Ehud Doron
                          Meiling Chen
                          Jon Shallow
	Filename        : draft-ietf-dots-telemetry-24.txt
	Pages           : 120
	Date            : 2022-02-23

Abstract:
   This document aims to enrich the DOTS signal channel protocol with
   various telemetry attributes, allowing for optimal Distributed
   Denial-of-Service (DDoS) attack mitigation.  It specifies the normal
   traffic baseline and attack traffic telemetry attributes a DOTS
   client can convey to its DOTS server in the mitigation request, the
   mitigation status telemetry attributes a DOTS server can communicate
   to a DOTS client, and the mitigation efficacy telemetry attributes a
   DOTS client can communicate to a DOTS server.  The telemetry
   attributes can assist the mitigator to choose the DDoS mitigation
   techniques and perform optimal DDoS attack mitigation.

   This document specifies a YANG module for representing DOTS telemetry
   message types.  It also specifies a second YANG module to share the
   attack mapping details over the DOTS data channel.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-telemetry/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-dots-telemetry-24

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-telemetry-24

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: <[email-masked]>
Date: Wed, 23 Feb 2022 12:09:49 +0000

Hi all, 

When reviewing the telemetry use cases and checking against the telemetry spec, I saw that a yang error was displayed for the telemetry draft (https://yangcatalog.org/results/[email-masked]). I don't have that error when compiling locally and also when submitting the draft. Anyway, this version fixes that yang error.

There are still some warnings but these are not correct:
* [email-masked]:6: warning: imported module "ietf-dots-signal-channel" not used ==> this one was already clarified in the writeup.  
* [email-masked]:67: warning: RFC 8407: 3.1: The IETF Trust Copyright statement ==> This is a pyang problem as changing 2021 to 2022 breaks the checks. Also, the TLP check uses "Simplified" instead of "Revised" (which is correct). See also, https://github.com/mbj4668/pyang/issues/770

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce <[email-masked]> De la part de
> [email-masked]
> Envoyé : mercredi 23 février 2022 12:55
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D Action: draft-ietf-dots-telemetry-24.txt
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.