Subject: Re: [Dtls-iot] Fwd: [dice] #9 (profile): Maximum Fragment Length Negotiation

From: Michael StJohns <[email-masked]>
Date: Thu, 17 Jul 2014 13:54:41 -0400

On 6/21/2014 2:20 PM, Hannes Tschofenig wrote:
>
>
> -------- Original Message --------
> Subject: [dice] #9 (profile): Maximum Fragment Length Negotiation
> Date: Fri, 20 Jun 2014 15:22:06 -0000
> From: dice issue tracker <[email-masked]>
> To: [email-masked]
> CC: [email-masked]
>
> #9: Maximum Fragment Length Negotiation
>
>   This extension lowers the maximum fragment length support needed for the
>   Record Layer from 2^14 bytes to 2^9 bytes.
>
>   This is a very useful extension that allows the client to indicate to the
>   server how much buffers it has. The goal is to allows client
>   implementations to make use of much lower RAM since the client does not
>   need to accept packets of extremely large size (such as 16k bytes as
>   required by plain TLS/DTLS).
>
>   Recommendation: Client implementations must support this extension.
>

I generally agree with this - but I would argue with the size. Maybe 
more like 2^10.

Mike

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 20 Jul 2014 20:01:43 +0200

Hi Mike,

thanks for your feedback.

The Maximum Fragment Length Negotiation extension allows you to indicate
the supported length. It offers a couple of different options and
implementations will have the possibility to tailor the setting to the
numbers that fit the hardware platform.

I wouldn't recommend a specific value in this spec but rather refer to
the use of the extension, which is what I am doing right now.

Ciao
Hannes

On 07/17/2014 07:54 PM, Michael StJohns wrote:
> _______________________________________________
> dtls-iot mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtls-iot