Subject: Re: [Dtls-iot] Fwd: [dice] #7 (profile): Truncated MAC extension

From: Michael StJohns <[email-masked]>
Date: Thu, 17 Jul 2014 13:43:50 -0400

On 6/21/2014 2:19 PM, Hannes Tschofenig wrote:
>
>
> -------- Original Message --------
> Subject: [dice] #7 (profile): Truncated MAC extension
> Date: Fri, 20 Jun 2014 15:15:33 -0000
> From: dice issue tracker <[email-masked]>
> To: [email-masked]
> CC: [email-masked]
>
> #7: Truncated MAC extension
>
>   This extension reduces the size of the MAC at the Record Layer. This is a
>   useful extension for those environments where TLS ciphersuites use older
>   modes of operation.
>
>   For CoAP, however, the recommended ciphersuites use the AEAD construct,
>   namely the CBC-MAC mode (CCM) with eight-octet authentication tags.
>
>   Recommendation: This extension does not add any value given the CoAP
>   selected ciphersuites. Recommend against supporting it.

Agreed with the caveat that IoT prohibits use of anything but AEAD ciphers.

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 20 Jul 2014 20:01:31 +0200

Hi Mike,

I added the note about the AEAD ciphers. Given that TLS 1.3 also heads
into this direction and the current IETF IoT-relevant specifications
also say that I believe this is a safe bet.

Ciao
Hannes

On 07/17/2014 07:43 PM, Michael StJohns wrote:
> _______________________________________________
> dtls-iot mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtls-iot