Subject: [dtn-security] BSP mutable canonicalization of CBHE

From: "Zoller, David A. (MSFC-EO50)[HOSC SERVICES CONTRACT]" <[email-masked]>
Date: Fri, 10 May 2013 10:04:49 -0500

Noticed while looking through the new DTN2 ciphersuite code...
Is there a specification of the BSP mutable canonicalization of a primary header in Compressed Bundle Header Encoding format (RFC 6260)?
Would you generate the string "ipn:<scheme offset>:<ssp offset>" and use that for the EIDs and lengths?
And use "dtn:none" for the case where the offsets are both zero?
Thanks,
DZ

---

From: "Burleigh, Scott C (313B)" <[email-masked]>
Date: Fri, 10 May 2013 15:25:52 +0000

Interesting question, David.  I would say there's no problem, though, because the CBHE specification says that (formally) the compression happens at the convergence layer, after the bundle has been queued for forwarding.  All of the BSP signing and encryption procedures should already have been performed prior to this time - i.e., on the original uncompressed bundle - when all EIDs still existed in string form to support canonicalization.

Scott

From: [email-masked] [mailto:[email-masked]] On Behalf Of Zoller, David A. (MSFC-EO50)[HOSC SERVICES CONTRACT]
Sent: Friday, May 10, 2013 8:05 AM
To: dtn-security
Subject: [dtn-security] BSP mutable canonicalization of CBHE

---

From: "Zoller, David A. (MSFC-EO50)[HOSC SERVICES CONTRACT]" <[email-masked]>
Date: Fri, 10 May 2013 12:55:23 -0500

Agreed. I believe this may have uncovered a non-conformant implementation of 6260 in DTN2. The CBHE is done at the block processing level instead of the CLA and in the receive processing does not re-create the uncompressed primary block needed for BSP validation.
Thanks and I'll investigate further,
DZ

From: Burleigh, Scott C (313B) [mailto:[email-masked]]
Sent: Friday, May 10, 2013 10:26 AM
To: Zoller, David A. (MSFC-EO50)[HOSC SERVICES CONTRACT]; dtn-security
Subject: RE: BSP mutable canonicalization of CBHE

Scott

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Zoller, David A. (MSFC-EO50)[HOSC SERVICES CONTRACT]
Sent: Friday, May 10, 2013 8:05 AM
To: dtn-security
Subject: [dtn-security] BSP mutable canonicalization of CBHE