Subject: [dtn-users] Neighbor Discovery CORE

From: Rui Quelhas <[email-masked]>
Date: Wed, 18 May 2011 10:36:45 +0100

Hi there,

i'm having some problems when I try to enable IP neighbor discovery mechanisms on DTN2. I've followed the guidelines provided on http://www.dtnrg.org/wiki/NeighborDiscovery and it seems to work well in a setup with two virtual machines on the same network. However, in an emulation environment like CORE, it only works on a setup with explicitly connected (wired) nodes. When using a wireless ad-hoc environment I get the following errors:

> [… /dtn/discovery/ip/sock/28 debug] poll_with_notifier timed out
> [… /dtn/discovery/ip debug] announce ready for sending
> [… /dtn/discovery/ip/sock/28 debug] poll_with_notifier: 1/2 fds ready, status 0x4 0x0
> [… /dtn/discovery/ip/sock/28 debug] poll_with_notifier: normal fd has event
> [… /dtn/discovery/bt/sock/28 debug] ::sendto() fd 28 0x97be700/32 cc -1
> [… /dtn/discovery/ip error] sento failed: Network is unreachable (101)
> [… /udpclient debug] closing socket in state INIT

I'm only using the required configuration parameters on "discovery add" and "discovery announce" like it is done on the wiki's example. The setup has two simple nodes where I use the following discovery configuration:

> discovery add ipdisc0 ip port=6789
> discovery announce announce-tcp0 ipdisc0 tcp interval=2

I'm guessing it might be some quirk in CORE, so my question is if anyone already has successfully deployed something like this? Or if you think that it might be something else wrong, I would also appreciate any guess.

Keep up the good work.

---
Best regards,
Rui Quelhas.

---

From: Darren Long <[email-masked]>
Date: Wed, 18 May 2011 13:51:03 +0100

I think this is a long standing issue that is caused by the interface that the discovery code is bound to going away when the wifi connection is dropped. I've had more success with bonjour disco, but avahi isn't entirely free from issues in this respect.

Cheers,

Darren
 ----- Original message -----
> Hi there,
> 
> i'm having some problems when I try to enable IP neighbor discovery
> mechanisms on DTN2. I've followed the guidelines provided on
> http://www.dtnrg.org/wiki/NeighborDiscovery and it seems to work well in
> a setup with two virtual machines on the same network. However, in an
> emulation environment like CORE, it only works on a setup with
> explicitly connected (wired) nodes. When using a wireless ad-hoc
> environment I get the following errors:
> 
> > [… /dtn/discovery/ip/sock/28 debug] poll_with_notifier: 1/2 fds ready,
> > status 0x4 0x0 [… /dtn/discovery/ip/sock/28 debug] poll_with_notifier:
> > normal fd has event [… /dtn/discovery/bt/sock/28 debug] ::sendto() fd
> > 28 0x97be700/32 cc -1 [… /dtn/discovery/ip error] sento failed:
> > Network is unreachable (101) [… /udpclient debug] closing socket in
> > state INIT
> 
> I'm only using the required configuration parameters on "discovery add"
> and "discovery announce" like it is done on the wiki's example. The
> setup has two simple nodes where I use the following discovery
> configuration:
> 
> I'm guessing it might be some quirk in CORE, so my question is if anyone
> already has successfully deployed something like this? Or if you think
> that it might be something else wrong, I would also appreciate any guess.
> 
> Keep up the good work.
> 
> 
> ---
> Best regards,
> Rui Quelhas.
>