Subject: [dtn-users] DTN configure fails while looking for oasys/lib

From: "Tom O'Reilly" <[email-masked]>
Date: Thu, 27 Oct 2011 13:01:12 -0700

I'm attempting to install DTN 2.8.0 on Mac OS 10.5.8

Running dtn-2.8.0/.configure, I get this error message:

Configure error finding oasys.

This script first looks for an oasys installation in the same location
as the tool that is using the oasys library (where this configure
script is run from). In other words, it first tries ../oasys.

If ../oasys does not exist, it looks for an oasys installation in
/usr. If that is not found, you need to specify the location of oasys
using the --with-oasys argument to configure.

If problems still exist, then look in the config.log to see exactly
what the failing command was.

Download oasys-1.5 (or later)
from http://dtn.hg.sourceforge.net/hgweb/dtn/oasys to /usr.
You will then probably have to run ./configure and make
in the oasys code tree in order to be able to compile DTN2

configure: error: nonexistent oasys library directory oasys/lib

In fact I have downloaded, configured, and installed oasys-1.5 in / 
usr, per the above message.
Looking in config.log for oasys-related messages I see this:

configure:3242: checking for an oasys installation (version 1.5 or  
better)
configure:3331: error: nonexistent oasys library directory oasys/lib

Why can't configure find /usr/oasys/lib? That directory does exist and  
contains libraries...

Thanks,
Tom

------------------------------
Thomas C. O'Reilly
Monterey Bay Aquarium Research Institute
7700 Sandholdt Road
Moss Landing, CA 95039
831-775-1766
[email-masked]
http://www.mbari.org
"The machine does not isolate man from the great mysteries of nature,  
but plunges him more deeply into them."

    - ANTOINE DE SAINT-EXUPERY
      "Wind, Sand, and Stars" (1939)

---

From: Ricardo Martins <[email-masked]>
Date: Fri, 28 Oct 2011 00:06:33 +0100

Hi,

On 27 October 2011 21:01, Tom O'Reilly <[email-masked]> wrote:
> In fact I have downloaded, configured, and installed oasys-1.5 in /usr, per
> the above message.
> configure:3242: checking for an oasys installation (version 1.5 or better)

Usually I don't install oasys. On Mac OS X 10.6.6 I do the following:

mkdir -p $HOME/dtn/src && \
cd $HOME/dtn/src && \
curl -C - -O  http://switch.dl.sourceforge.net/project/dtn/oasys/oasys-1.5.0/oasys-1.5.0.tgz
&& \
tar xf oasys-1.5.0.tgz && \
curl -C - -O  http://switch.dl.sourceforge.net/project/dtn/DTN2/dtn-2.8.0/dtn-2.8.0.tgz
&& \
tar xf dtn-2.8.0.tgz && \
cd oasys-1.5.0 && \
./configure && \
make && \
cd .. && \
cd dtn-2.8.0 && \
./configure --disable-ecl --disable-edp --prefix=$HOME/dtn && \
make && \
make install

Regards,
Ricardo Martins

> "The machine does not isolate man from the great mysteries of nature, but
> plunges him more deeply into them."
>