Subject: [dtn-users] RFC: public DTN service in a cloud

From: Dmitry Monakhov <[email-masked]>
Date: Wed, 22 Feb 2012 11:21:22 +0000

Hello,
I want use dnt as exchange protocol in MANET for mobile devices
for a general purpose data exchange. Ideally user just have to install
an DTN application on his phone and all services just works
1) file transfer
2) email/twitter/block posting
Bytewalla already allow to exchange files via devices.
But in order to route data via internet we need  dedicated
DTN services/gateways which is very not suitable for non experienced
users because some extra work is required.

As an alternative we can exploit a cloud service for that purpose.
For example we can use google gdata api like follows:

*Specify eid for cloud like follows dtn://dnt.google.docs/dst_user
*Send_to_cloud procedure:
  0) login to gdata api
  1) create empty file
  2) copy bundle content to it
  3) add required attributes to that document (dtn_tag, eid_tag and etc.)
  3) share this document with dst_user
*Recv from cloud procedure
  0) login to gdata api
  1) search for documents with dtn_tag
  2) copy file to local storage
  3) import file to local dnt service.

What do you think about that? Was it discussed already?
What is the best way to implement such gateway?
Currently I'm look in to external router level.

---

From: Joerg Ott <[email-masked]>
Date: Wed, 22 Feb 2012 13:40:14 +0200

Take a look at:

http://www.floating-content.net/
(which uses http://www.ict-scampi.eu/, based upon RFC 5050) for the
implementation

http://grid-app.net/

and for a number of other DTN applications at (needs some updating :-)

http://www.netlab.tkk.fi/~jo/dtn/

Jörg

On 22.02.2012 13:21, Dmitry Monakhov wrote:
> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users
>

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 22 Feb 2012 11:49:33 +0000

I think its a fine idea. Go for it!

Like Joerg says some of this has been discussed, but
I don't recall the idea of using google docs or
equivalents (megaupload maybe:-) as a public service.

While this could be fine in a closed group, I'm
not so sure how bundles would get deleted from
google docs. I guess senders could go back and
delete expired stuff and receivers could ignore
stuff they've received already.

S.