Subject: [dtn-users] a contribution for 2 additional tutorials

From: Scott Hissam <[email-masked]>
Date: Mon, 28 Oct 2013 13:36:02 +0000

Dear DTN2 users,

I found the 3 tutorials at (http://www.dtnrg.org/docs/code/DTN2/doc/manual/) to be very helpful - Thank you!

I wanted to offer the two attachments as follow-ons to those 3 which I believe may be helpful to others who (like me) are trying to get up to speed quickly with the DTN reference implementation discussed here.

I have one additional tutorial that I would like to contribute. That tutorial, building on the original 3 and the two introduced here, would create a "toy" gateway as an example to illustrate naming and interoperation across regions using different convergence layers (wifi, wired-IP, and Bluetooth) . I completed that investigation last week and if the community here believes that would be a helpful contribution (a 6th tutorial), I will write it up and submit it as well.

Please consider the attachments as a contribution, please edit/change as you see fit - being a n00b to this area, it is quite possible I got some of the terminology wrong.

Best regards,
Scott

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Mon, 28 Oct 2013 15:08:28 +0000

HI Scott,

It would be great if you put these on the wiki.  We are in the process of moving it to Google.  The new site is:

https://sites.google.com/site/dtnresgroup/home/docs#TOC-Tutorials

If you ask Hans, he can get you an account so you can add these tutorials.  I looked at what you have.  The hyperlinks would have to be modified to point to the correct  "third" and "fourth" tutorials and "manual".  Minor things like that.

Thanks for supplying these.

Cheers,

Will

From: Scott Hissam <[email-masked]<mailto:[email-masked]>>
Date: Monday, October 28, 2013 9:36 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [dtn-users] a contribution for 2 additional tutorials

Dear DTN2 users,

I found the 3 tutorials at (http://www.dtnrg.org/docs/code/DTN2/doc/manual/) to be very helpful – Thank you!

I have one additional tutorial that I would like to contribute. That tutorial, building on the original 3 and the two introduced here, would create a “toy” gateway as an example to illustrate naming and interoperation across regions using different convergence layers (wifi, wired-IP, and Bluetooth) . I completed that investigation last week and if the community here believes that would be a helpful contribution (a 6th tutorial), I will write it up and submit it as well.

Please consider the attachments as a contribution, please edit/change as you see fit – being a n00b to this area, it is quite possible I got some of the terminology wrong.

Best regards,
Scott

---

From: Scott Hissam <[email-masked]>
Date: Mon, 28 Oct 2013 15:30:56 +0000

Will, Hans,

Sure, I believe I can do that. So, please consider this a friendly request for wiki "write" permission.

If I understand you correctly, the idea would be to integrate additional tutorials (past numbers 1-3) with that which currently exists. However,  I did a quick peek at the google site indicated in your response, and I could not find a URL specifically pointing to the tutorial beginning (what was known as tutorial-1.html and so on).

On the "legacy" site, I found tutorials 1-3 at (http://www.dtnrg.org/docs/code/DTN2/doc/manual/). Following the "Code" branch at the google site (https://sites.google.com/site/dtnresgroup/home/code) lead me to a potential page ("DTN2 Documentation" <https://sites.google.com/wiki/Dtn2Documentation>) which appears to be a broken link or yet-to-be developed page.

Best regards,
Scott

From: Ivancic, William D. (GRC-RHN0) [mailto:[email-masked]]
Sent: Monday, October 28, 2013 11:08 AM
To: Scott Hissam; Kruse, Hans
Cc: [email-masked]
Subject: Re: [dtn-users] a contribution for 2 additional tutorials

HI Scott,

Cheers,

Will

Dear DTN2 users,

Best regards,
Scott

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Mon, 28 Oct 2013 15:56:00 +0000

Will, Hans,

Sure, I believe I can do that. So, please consider this a friendly request for wiki “write” permission.

On the “legacy” site, I found tutorials 1-3 at (http://www.dtnrg.org/docs/code/DTN2/doc/manual/). Following the “Code” branch at the google site (https://sites.google.com/site/dtnresgroup/home/code) lead me to a potential page (“DTN2 Documentation” <https://sites.google.com/wiki/Dtn2Documentation>) which appears to be a broken link or yet-to-be developed page.

Thanks for pointing it out.  I am in the process of fixing that branch.

Will