Subject: [dtn-users] Unavailable opportunistic links

From: "Mehta, Devanshu - 0665 - MITLL" <[email-masked]>
Date: Mon, 13 Jan 2014 16:29:17 -0500

Folks,
If I have a simple two-node network using an OPPORTUNISTIC (TCP) link that becomes UNAVAILABLE because the nodes are out of range for >30 seconds, what is the appropriate automated method for setting this link back to AVAILABLE when they are back in range?

By "appropriate", I mean consistent with the DTN architecture and the rest of dtn 2.9.0.

(My actual network is not this simple, but the above illustration gets to the heart of what I want to get done)

Thanks,
--
Devanshu Mehta
Airborne Networks
MIT Lincoln Laboratory

---

From: "Zoller, David A. (MSFC-EO50)[HOSC SERVICES CONTRACT]" <[email-masked]>
Date: Wed, 15 Jan 2014 15:31:01 +0000

Hi Devanshu,
I have not experimented with the opportunistic links enough to give you a definitive answer but the when an alwayson link drops it tries to reconnect every now and then based on the parameters link_min_retry_interval and link_max_retry_interval. I suspect that opportunistic works the same way but it will not try to reconnect unless it has bundles pending for the destination.
Hope this helps a bit,
DZ

From: dtn-users [mailto:[email-masked]] On Behalf Of Mehta, Devanshu - 0665 - MITLL
Sent: Monday, January 13, 2014 3:29 PM
To: [email-masked]
Subject: [dtn-users] Unavailable opportunistic links

Folks,

Thanks,
--
Devanshu Mehta
Airborne Networks
MIT Lincoln Laboratory