Subject: [dtn-users] FEC in DTN

From: James Jones <[email-masked]>
Date: Wed, 15 Jan 2014 16:45:03 +0000

Greetings,

I am still quite new to this list and DTN. I had a few really quick questions:

  1.  What is currently being used for FEC (Forward Error Correction), if any?
  2.  If there is already work being done is there anyway to do testing against vs a different FEC method?
  3.  Is most DTNs IP based?

-James

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Wed, 15 Jan 2014 17:52:48 +0000

FEC and DTN has many connotations.  Perhaps you might specify  where you want the FEC.

Basically FEC on the point-to-point link between DTN forwarding agents is a transport thing.

FEC  or rather erasure codes somewhere in the Application/DTN chain is a bit of a different animal.  Look at some of the BBN proposals.
http://tools.ietf.org/html/draft-irtf-dtnrg-zinky-erasure-coding-extension-00
http://tools.ietf.org/html/draft-irtf-dtnrg-zinky-erasure-coding-objects-00
Here is a presentation:
http://www.ietf.org/proceedings/81/slides/DTNRG-2.pdf

Most DTNs you will probably find information on have been run over IP simply because it is the easiest to start and DTN is a network overlay.  NASA JPL has run DTN over, I believe, CCSDS space links.  The DARPA program BBN Spindle implementation ran IP over DTN with, I believe,  DTN mapped to the radio MAC.  (Others, feel free to add or correct these statements.)

Cheers,

Will

From: James Jones <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, January 15, 2014 11:45 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [dtn-users] FEC in DTN

Greetings,

-James

---

From: Daniel Ellard <[email-masked]>
Date: Wed, 15 Jan 2014 15:54:35 -0500

> Most DTNs you will probably find information on have been run over IP simply because it is the easiest to start and DTN is a network overlay.  NASA JPL has run DTN over, I believe, CCSDS space link…

A minor correction:  the SPINDLE implementation ran DTN over several
convergence layers, including TCP, UDP and radio MACs.  The WNaN
project, which used the SPINDLE codebase, used DTN-over-radio-MAC to
implement reliable IP.

The layers were completely independent, so you could, if you wanted
to, run the SPINDLE TCP CLA on top of the IP layer provided by
running the SPINDLE MAC CLA over the radio...

-Dan

-- 
Daniel Ellard, Ph.D.
Senior Scientist, Network Research
Raytheon BBN Technologies
[email-masked]
617-873-8004

---

From: <[email-masked]>
Date: Wed, 15 Jan 2014 21:57:31 +0000

Actually, I think it's fair to say that most DTNs are *TCP*/IP based - and most use of the bundle
protocol has been over TCP.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: dtn-users [[email-masked]] On Behalf Of James Jones [[email-masked]]
Sent: 15 January 2014 16:45
To: [email-masked]
Subject: [dtn-users] FEC in DTN

Greetings,

-James