Subject: Re: [dtn] the relationship between Oppnet and DTN

From: Carlo Caini <[email-masked]>
Date: Mon, 22 Jun 2015 12:23:26 +0200

Dear Xuan,
      your question is interesting, as there is a 
lot of ambiguity in the literature.
In brief, my answer is that opportunistic 
networks may be a subset of DTNs, as DTNs include 
also deterministic networks (e.g. space networks).

More in depth, note that:
1) DTN may stand for Delay Tolerant Networking, Disruption Tolerant Networking
, or better for both Delay-/Disruption- Tolerant 
Networking (my preference). Your "Distributed" is likely a typo.
Instead of Networking or "Networking 
architecture", which is an architecture, you can 
use Network, which of course denotes a set of 
nodes and not a networking architecture. In this 
case, however, some ambiguity arises.
2) In fact, a network of nodes connected by links 
with long delays or disruption, or opportunistic, 
or with huge errors (and on), is not, in my 
opinion a DTN in itself. In fact, it is just a 
"challenged network", i.e. a network where the 
TCP/IP architecture cannot work well.
3) a "challenged network" needs some sort of DTN 
protocols and architecture (e.g. the bundle 
protocol) to be applied to it to become a DTN 
network, i.e. a network where transmission is 
possible despite long delays and/or disruption.
Some consequences:
1) not all DTN networks are opportunistic; you 
can have DTN networks where "disruption" is scheduled, as in space networks.
2) As "D" in DTN can stand for "delay" only, it 
means that link disruption is not necessary; you 
can have continous links, where it is the long 
propagation delay the sole challenge (e.g. in GEO 
satellite system with fixed terminals); more 
generally one "challenge" is enough to have a 
challenged network, although usually you have more than one.
An excellent introduction on DTN is in:

>
><http://www.computer.org/csdl/mags/ic/2009/06/mic2009060082-abs.html>Delay- 
>and Disruption-Tolerant Networking
>
><http://www.computer.org/csdl/mags/ic/2009/06/mic2009060082-abs.html>
>
>Issue No.06 - November/December (2009 vol.13)
>pp: 82-87
><http://www.computer.org/web/search?cs_search_action=advancedsearch&searchOperation=exact&search-options=dl&searchText=Alex+McMahon>Alex 
>McMahon , Trinity College Dublin
><http://www.computer.org/web/search?cs_search_action=advancedsearch&searchOperation=exact&search-options=dl&searchText=Stephen+Farrell>Stephen 
>Farrell , Trinity College Dublin
>DOI Bookmark: 
><http://doi.ieeecomputersociety.org/10.1109/MIC.2009.127>http://doi.ieeecomputersociety.org/10.1109/MIC.2009.127
Yours,
     Carlo Caini

At 10:59 22/06/2015, Xuan Liu wrote:
>Hi everyone,
>    There are many related literatures 
> describing the relationship between 
> opportunistic networks and Delay/Distributed 
> tolerant networks, such as equivalent and 
> subset, and I would like to know if there
>is the most accurate definition.
>    Thanks.
>
>
>Regards,
>Xuan Liu(ÁõÐý)
>Future Network Research Center, Southeast University
>_______________________________________________
>dtn mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dtn

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Mon, 22 Jun 2015 15:46:11 +0000

Right, I think the "D" in "DTN" is a source of continuing confusion, but I don't think that's going to get resolved any time soon.  I prefer "Delay", myself, because I think it includes the sense in which the protocols also address "Disruption".

The essence of DTN, for me, is that in a DTN environment your network activity can't rely on conversational data exchanges as it does in the Internet.  The signal propagation times from one node to the next are very long (what we usually think of as "delay"), or the interval between reception and transmission at a forwarding node is very long due to a lapse of continuous end-to-end connectivity (the practical impact of "disruption"), or both; therefore a server's response to a client's query might not arrive until long after the query was originally transmitted.  The DTN architecture is designed to withstand lengthy delays in round-trip communication, whatever causes them.  It turns out that this architecture offers a number of other advantages as well, but I see that as serendipitous rather than essential.

This opinion is by no means universally held, though.

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Carlo Caini
Sent: Monday, June 22, 2015 3:23 AM
To: Xuan Liu; dtn
Subject: Re: [dtn] the relationship between Oppnet and DTN

Dear Xuan,
      your question is interesting, as there is a lot of ambiguity in the literature.
In brief, my answer is that opportunistic networks may be a subset of DTNs, as DTNs include also deterministic networks (e.g. space networks).

More in depth, note that:
1) DTN may stand for Delay Tolerant Networking, Disruption Tolerant Networking , or better for both Delay-/Disruption- Tolerant Networking (my preference). Your "Distributed" is likely a typo.
Instead of Networking or "Networking
architecture", which is an architecture, you can use Network, which of course denotes a set of nodes and not a networking architecture. In this case, however, some ambiguity arises.
2) In fact, a network of nodes connected by links with long delays or disruption, or opportunistic, or with huge errors (and on), is not, in my opinion a DTN in itself. In fact, it is just a "challenged network", i.e. a network where the TCP/IP architecture cannot work well.
3) a "challenged network" needs some sort of DTN protocols and architecture (e.g. the bundle
protocol) to be applied to it to become a DTN network, i.e. a network where transmission is possible despite long delays and/or disruption.
Some consequences:
1) not all DTN networks are opportunistic; you can have DTN networks where "disruption" is scheduled, as in space networks.
2) As "D" in DTN can stand for "delay" only, it means that link disruption is not necessary; you can have continous links, where it is the long propagation delay the sole challenge (e.g. in GEO satellite system with fixed terminals); more generally one "challenge" is enough to have a challenged network, although usually you have more than one.
An excellent introduction on DTN is in:

><http://www.computer.org/web/search?cs_search_action=advancedsearch&sea
>rchOperation=exact&search-options=dl&searchText=Alex+McMahon>Alex
><http://www.computer.org/web/search?cs_search_action=advancedsearch&sea
>rchOperation=exact&search-options=dl&searchText=Stephen+Farrell>Stephen
><http://doi.ieeecomputersociety.org/10.1109/MIC.2009.127>http://doi.iee
>ecomputersociety.org/10.1109/MIC.2009.127
Yours,
     Carlo Caini

At 10:59 22/06/2015, Xuan Liu wrote:
>Hi everyone,
>    There are many related literatures  describing the relationship 
>between  opportunistic networks and Delay/Distributed  tolerant 
>networks, such as equivalent and  subset, and I would like to know if 
>there is the most accurate definition.
>    Thanks.
>
>
>Regards,
>Xuan Liu(ÁõÐý)

---

From: [email-masked]
Date: Mon, 22 Jun 2015 20:37:08 +0200 (CEST)

Hi Scott,

>>I prefer "Delay", myself, because I think it includes the sense in which the protocols also address "Disruption".
The  constrains of a challenged networks can be unambiguous reduce to the impact of the "Delay" ?Patrick 

----- Mail d'origine -----
De: Scott C Burleigh (312B) <[email-masked]>
À: dtn <[email-masked]>
Envoyé: Mon, 22 Jun 2015 17:46:11 +0200 (CEST)
Objet: Re: [dtn] the relationship between Oppnet and DTN

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Carlo Caini
Sent: Monday, June 22, 2015 3:23 AM
To: Xuan Liu; dtn
Subject: Re: [dtn] the relationship between Oppnet and DTN

Dear Xuan,

An excellent introduction on DTN is in:

>De
>lay-
><http: www.computer.org="" web="" search?cs_search_action="advancedsearch&sea>rchOperation=exact&search-options=dl&searchText=Alex+McMahon>Alex
><http: www.computer.org="" web="" search?cs_search_action="advancedsearch&sea>rchOperation=exact&search-options=dl&searchText=Stephen+Farrell>Stephen
>http://doi.iee
Yours,
   Carlo Caini

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Mon, 22 Jun 2015 19:07:19 +0000

Hi, Patrick.  I guess it depends on what is included under the heading of “challenged networks.”  But in general I’d say that an architecture that addresses all sources of round-trip “delay” implicitly addresses all sources of “disruption” as well – because disruption is one contributor to round-trip delay – but the reverse is not true.

Scott

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, June 22, 2015 11:37 AM
To: Burleigh, Scott C (312B)
Cc: dtn
Subject: Re : Re: [dtn] the relationship between Oppnet and DTN

Hi Scott,

>>I prefer "Delay", myself, because I think it includes the sense in which the protocols also address "Disruption".
The  constrains of a challenged networks can be unambiguous reduce to the impact of the "Delay" ?
Patrick

----- Mail d'origine -----
De: Scott C Burleigh (312B) <[email-masked]<mailto:[email-masked]>>
À: dtn <[email-masked]<mailto:[email-masked]>>
Envoyé: Mon, 22 Jun 2015 17:46:11 +0200 (CEST)
Objet: Re: [dtn] the relationship between Oppnet and DTN

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Carlo Caini
Sent: Monday, June 22, 2015 3:23 AM
To: Xuan Liu; dtn
Subject: Re: [dtn] the relationship between Oppnet and DTN

Dear Xuan,

Yours,
Carlo Caini

At 10:59 22/06/2015, Xuan Liu wrote:
>[email-masked]<mailto:[email-masked]>

_______________________________________________
dtn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dtn

_______________________________________________
dtn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dtn

---

From: Carlo Caini <[email-masked]>
Date: Mon, 22 Jun 2015 19:13:28 +0000

Dear Scott and Patrick,
       In general I think that DTN aims to provide a general answer for all challenged networks. A challenged network is a network where one or more challenges prevent the use of TCP/IP architecture and protocols. Usually delay and/or disruption, which lucky for us start with the same letter, and as shown by Scott can be collected under "delay", but in few cases not only. For example, a very high asymmetry on a link may impair TCP performance, independently from the delay and disruption, thus forcing the use of a different transport protocol (or a different variant of TCP) on this link, which is possible only by splitting the end-to-end path in multiple DTN hops (this splitting is instrumental to use a specific transport on a specific link). Note that this implicitly redefines the end-to-end semantics of transport layer (end-to.end only on one DTN hop). The same holds true for radio channel with very high packet losses.
Yours,
   Carlo

________________________________________
Da: dtn [[email-masked]] per conto di [email-masked] [[email-masked]]
Inviato: lunedì 22 giugno 2015 20.37
A: Scott C Burleigh (312B)
Cc: dtn
Oggetto: [dtn] Re : Re:  the relationship between Oppnet and DTN

Hi Scott,

----- Mail d'origine -----
De: Scott C Burleigh (312B) <[email-masked]>
À: dtn <[email-masked]>
Envoyé: Mon, 22 Jun 2015 17:46:11 +0200 (CEST)
Objet: Re: [dtn] the relationship between Oppnet and DTN

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Carlo Caini
Sent: Monday, June 22, 2015 3:23 AM
To: Xuan Liu; dtn
Subject: Re: [dtn] the relationship between Oppnet and DTN

Dear Xuan,

Yours,
Carlo Caini

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Mon, 22 Jun 2015 19:28:06 +0000

Hi, Carlo.  Here again I'd suggest that some of the useful features of DTN are serendipitous rather than essential to the architectural concept.  Store (possibly for a long time)-and-forward at forwarding nodes is required because contemporaneous end-to-end connectivity is not continuous, so the network nodes need robust buffering capacity and must be the terminal points for TCP connections.  This has the happy side effect of making them natural points for rate matching and the integration of multiple transport variants, even when contemporaneous end-to-end connectivity actually is continuous.

Scott

-----Original Message-----
From: Carlo Caini [mailto:[email-masked]] 
Sent: Monday, June 22, 2015 12:13 PM
To: [email-masked]; Burleigh, Scott C (312B)
Cc: dtn
Subject: RE: [dtn] Re : Re: the relationship between Oppnet and DTN

Dear Scott and Patrick,

Hi Scott,

----- Mail d'origine -----
De: Scott C Burleigh (312B) <[email-masked]>
À: dtn <[email-masked]>
Envoyé: Mon, 22 Jun 2015 17:46:11 +0200 (CEST)
Objet: Re: [dtn] the relationship between Oppnet and DTN

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Carlo Caini
Sent: Monday, June 22, 2015 3:23 AM
To: Xuan Liu; dtn
Subject: Re: [dtn] the relationship between Oppnet and DTN

Dear Xuan,

Yours,
Carlo Caini

At 10:59 22/06/2015, Xuan Liu wrote:
>Hi everyone,
> There are many related literatures describing the relationship between 
>opportunistic networks and Delay/Distributed tolerant networks, such as 
>equivalent and subset, and I would like to know if there is the most 
>accurate definition.
> Thanks.
>
>
>Regards,
>Xuan Liu(ÁõÐý)

---

From: [email-masked]
Date: Mon, 22 Jun 2015 21:49:09 +0200 (CEST)

Hello Carlo,

>>A challenged network is a network where one or more challenges prevent the use of TCP/IP architecture and protocols.
I built myself the same understanding.  

>>In general I think that DTN aims to provide a general answer for all challenged networks.
All challenged network mean network with a combination of this constraint :

Long delay,
High asymmetry, or only one-way
High packet losses,
...

?

With TCP/IP and DTN we  can covering the "topology" of all the manifold network ?

Thank,
Patrick

----- Mail d'origine -----
De: Carlo Caini <[email-masked]>
À: gelard patrick <[email-masked]>, Scott C Burleigh (312B) <[email-masked]>
Cc: dtn <[email-masked]>
Envoyé: Mon, 22 Jun 2015 21:13:28 +0200 (CEST)
Objet: RE: [dtn] Re : Re: the relationship between Oppnet and DTN

Dear Scott and Patrick,

Hi Scott,

----- Mail d'origine -----
De: Scott C Burleigh (312B) 
À: dtn 
Envoyé: Mon, 22 Jun 2015 17:46:11 +0200 (CEST)
Objet: Re: [dtn] the relationship between Oppnet and DTN

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Carlo Caini
Sent: Monday, June 22, 2015 3:23 AM
To: Xuan Liu; dtn
Subject: Re: [dtn] the relationship between Oppnet and DTN

Dear Xuan,

Yours,
Carlo Caini

---

From: "Ivancic, William D. (GRC-LCA0)" <[email-masked]>
Date: Mon, 22 Jun 2015 22:49:52 +0000

Sorry, but the characteristics below  just define requirements for a transport protocol.  The hard part is disconnection (Store, Carry and Forward) which is independent of transport.

Long delay,

IMHO, the more common disconnected network will be, an opportunistic network where entities meet and communicate over short delay, symmetric, links with very likely low loss.

Will

---

From: Gelard Patrick <[email-masked]>
Date: Tue, 23 Jun 2015 05:41:39 +0000

Do you have some reference who give this kind of requirement (delay, asymmetry, packet loss, ..) for an end-to-end transport protocol ?

Thank
Patrick

De : dtn [mailto:[email-masked]] De la part de Ivancic, William D. (GRC-LCA0)
Envoyé : mardi 23 juin 2015 00:50
À : [email-masked]; Carlo Caini
Cc : dtn
Objet : Re: [dtn] Re : RE: Re : Re: the relationship between Oppnet and DTN

Long delay,

Will