Subject: [dtn] BPbis comment on service class

From: Brian Sipos <[email-masked]>
Date: Tue, 12 Apr 2016 16:11:55 +0000

This is a comment on "draft-ietf-dtn-bpbis-03".

In the current BPbis spec, there is no mention of a bundle's class of service (e.g. bulk, normal, expedited). I notice that this was dropped between -01 and -02 versions of the spec. I have no direct need for this information, but it is something that is called out as a property of "bundle" transport in general (and specifically in the draft AMP BP-Agent ADM).

Is the service class indicator intended to be left out? I am just curious after diving in to BPbis details a bit more.

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Tue, 12 Apr 2016 17:30:23 +0000

Hi, Brian.  Yes, at IETF 94 (I think) we agreed to remove all quality of service indications (including not only ECOS but also the class of service) from the base Bundle Protocol specification and address QoS in a separate QoS extension block, yet to be designed.  While bundle transmission priority - which is really what class of service is - is indispensable to some use cases, such as space flight operations, there was widespread sentiment that it would be meaningless and/or misused in some large terrestrial networks and therefore ought to migrate into an extension block.

Scott

From: dtn [mailto:[email-masked]] On Behalf Of Brian Sipos
Sent: Tuesday, April 12, 2016 9:12 AM
To: [email-masked]
Subject: [dtn] BPbis comment on service class

---

From: Brian Sipos <[email-masked]>
Date: Wed, 13 Apr 2016 14:45:55 +0000

That makes perfect sense. Thank you.

________________________________
From: Burleigh, Scott C (312B) <[email-masked]>
Sent: Tuesday, April 12, 2016 13:30
To: Brian Sipos; [email-masked]
Subject: RE: BPbis comment on service class

Scott