Subject: [dtn] Minimalistic Bundle Protocol use case (bpbis)

From: Brian Sipos <[email-masked]>
Date: Tue, 5 Apr 2016 14:59:03 +0000

All,

I'm digging deeper into a notional design of a non-geostationary multi-satellite management network (i.e. lots of links but all are intermittent) with some specific requirements on data confidentiality/integrity. I had looked into RFC5050 Bundle Protocol a while ago and was put off by some of the overhead of bundle processing and known issues with the BP security handling. I have been following from afar the bpbis specification, and it feels like bpbis+CBOR is more amenable to a lightweight, tailored implementation.

My only requirements in this area are use of a symmetric cipher for confidentiality and integrity (i.e. AES256-GCM with long-term keys) and a a custody hand-off between ground-side systems but I would prefer not to have the custody bookkeeping overhead between ground--space interconnect. My preference is for a lot of the policy choices (e.g. forwarding vs dropping when link fails, to be made by the systems and not within the protocol). I have no specific need for inter-network operations on either ground-side or space-side.

>From my perspective this looks suspiciously similar to what is provided by bpbis+CBOR, assuming that I can allocate IPN EIDs within a private namespace. And I think that the ongoing work with BPSEC will also allow me to (if necessary) identify my own ciphersuite tailored to my needs.

Any thoughts on this application from those more familiar with BP/BPbis than I am?

Thanks very much,
Brian S.

---

From: Carlo Caini <[email-masked]>
Date: Tue, 5 Apr 2016 17:28:27 +0000

Dear Brian,
    just a comment about custody. The Custody option is a special processing that is requested by the bundle source, by rising the custody option flag. DTN nodes can read this flag but are free of accepting or refusing the request made by the source. This makes perfectly possible to limit the burden of custody to nodes that are willing to act as custodians. Others can just refuse and pass the bundle as it is to the next node. The flag is still set, as all QoS flags set by the source, thus if a subsequent node want to accept the custody, it can. Luckily, this seems to match your needs.
Yours,
   Carlo

________________________________________
Da: dtn [[email-masked]] per conto di Brian Sipos [[email-masked]]
Inviato: martedì 5 aprile 2016 16.59
A: [email-masked]
Oggetto: [dtn] Minimalistic Bundle Protocol use case (bpbis)

All,

Thanks very much,
Brian S.

5x1000 AI GIOVANI RICERCATORI
DELL'UNIVERSITÀ DI BOLOGNA
Codice Fiscale: 80007010376

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Tue, 5 Apr 2016 23:15:57 +0000

Hi, Brian.  I think the approach you're taking is reasonable, but one caveat: there are not yet any software implementations of either bpbis+CBOR or full-fledged bpsec, as those standards don't quite have formal existence yet.  If you need something right away, existing implementations of RFC 5050 et al could get you started while you wait for bpbis/CBOR/bpsec software development to catch up.

Allocation of ipn-scheme EIDs within a private namespace is fine (there's provision for this in the IANA scheme registry, so long as the namespace remains private), and the bpsec architecture is specifically intended to support the use of an unlimited variety of cipher suites (again, so long as you're not trying to interoperate with other networks' nodes).  As Carlo points out, custody transfer is always optional both at the point of origin of the bundle and at every potential custodial node.  Most of the kinds of policy choices I think you're contemplating are intentionally not mandated by the protocol specifications, but you may need to shop around a bit for an implementation that exposes them to you.

Scott

From: dtn [mailto:[email-masked]] On Behalf Of Brian Sipos
Sent: Tuesday, April 5, 2016 7:59 AM
To: [email-masked]
Subject: [dtn] Minimalistic Bundle Protocol use case (bpbis)

All,

Thanks very much,
Brian S.

---

From: Lloyd Wood <[email-masked]>
Date: Tue, 5 Apr 2016 23:32:31 +0000 (UTC)

blockquote, div.yahoo_quoted { margin-left: 0 !important; border-left:1px #715FFA solid !important;  padding-left:1ex !important; background-color:white !important; }  "standards?"

Lloyd Wood
http://sat-net.com/L.Wood/dtn

On Wednesday, April 6, 2016, 09:16, Burleigh, Scott C (312B) <[email-masked]> wrote:

Hi, Brian.  I think the approach you’re taking is reasonable, but one caveat: there are not yet any software implementations of either bpbis+CBOR or full-fledged bpsec, as those standards don’t quite have formal existence yet.  If you need something right away, existing implementations of RFC 5050 et al could get you started while you wait for bpbis/CBOR/bpsec software development to catch up.

Allocation of ipn-scheme EIDs within a private namespace is fine (there’s provision for this in the IANA scheme registry, so long as the namespace remains private), and the bpsec architecture is specifically intended to support the use of an unlimited variety of cipher suites (again, so long as you’re not trying to interoperate with other networks’ nodes).  As Carlo points out, custody transfer is always optional both at the point of origin of the bundle and at every potential custodial node.  Most of the kinds of policy choices I think you’re contemplating are intentionally not mandated by the protocol specifications, but you may need to shop around a bit for an implementation that exposes them to you.

Scott

From: dtn [mailto:[email-masked]]On Behalf Of Brian Sipos
Sent: Tuesday, April 5, 2016 7:59 AM
To: [email-masked]
Subject: [dtn] Minimalistic Bundle Protocol use case (bpbis)

All,

 

 
 
Thanks very much,
Brian S.
 _______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn

---

From: Brian Sipos <[email-masked]>
Date: Wed, 6 Apr 2016 12:49:30 +0000

Scott,

Fortunately, my perspective is from system architecture/planning in a software shop. I see my current options are really either: DIY minimalist protocol + implementation effort, or use BPbis/BPSEC + implementation effort. So at least in this case I will be saving the effort in constructing a (new, fragile, stovepiped) protocol and (hopefully) neither gain nor lose effort on implementation. Since most of the BP agent policy appears to be node-defined, it seems like I can tailor a minimal BP agent to my needs without taking on unnecessary 'baggage'.

I'm going through a similar "buy / build" trade with the AMA/AMP in discussions with Ed Birrane. In both cases (AMA and BPbis) I would gladly use my own early prototyping to support the protocol design. I do protocol rapid prototyping in Python+scapy, which allows bit-level packet generation/parsing and allows a boilerplate construction of upper/lower network layers. I have spoken with Ed about a timeline for AMP spec work, do you have a timeline for BPbis spec? It seems to be very close.

Digging deeper into BPbis, it seems that the notion of "custody" is a mutual coordination to exchange a bundle, but the notion of "forwarding" is more of a one-way, next-hop transfer of a bundle. Am I interpreting this correctly? My reason for asking is that I would prefer to use custody transfer for ground--ground links, but would like to have some notion of "yes, the bundle was sent" on the ground--space link without requiring explicit BP-level space--ground acknowledgment. I'm going to be using reliable transport (LTP) so the success/failure of point-point transfer is known by the sender intrinsically. It sounds like forwarding fits this bill, but I'm not absolutely sure.

________________________________
From: Burleigh, Scott C (312B) <[email-masked]>
Sent: Tuesday, April 5, 2016 19:15
To: Brian Sipos; [email-masked]
Subject: RE: Minimalistic Bundle Protocol use case (bpbis)

Scott

All,

Thanks very much,
Brian S.

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 6 Apr 2016 15:49:37 +0000

I agree, Brian, the approach you're taking makes sense.  My understanding is that, as of the IETF DTN WG meeting on April4, the timeline for the bpbis spec now comes down to a 4-week Last Call starting about April 18, after which I hope we'll be able to move ahead to the RFC editors' queue fairly soon.  So yes, I think it's close.

Custody transfer is really a sort of augmentation of bundle forwarding.  The basic forwarding procedures apply to all bundle transmission.  Custody transfer kicks in when the forwarded bundle has its "custody transfer requested" flag set, which tells the receiving node that the user application would like it to formally commit to successfully forwarding the bundle on the next hop along its end-to-end path, retrying in the event that the next-hop forwarding attempt fails.  Forwarding can be custodial or not, and this option is orthogonal to your choice of convergence-layer protocol, so the configuration you're contemplating should work fine.

Scott

From: Brian Sipos [mailto:[email-masked]]
Sent: Wednesday, April 6, 2016 5:50 AM
To: Burleigh, Scott C (312B) <[email-masked]>; [email-masked]
Subject: Re: Minimalistic Bundle Protocol use case (bpbis)

Scott,

________________________________
From: Burleigh, Scott C (312B) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, April 5, 2016 19:15
To: Brian Sipos; [email-masked]<mailto:[email-masked]>
Subject: RE: Minimalistic Bundle Protocol use case (bpbis)

Scott

From: dtn [mailto:[email-masked]] On Behalf Of Brian Sipos
Sent: Tuesday, April 5, 2016 7:59 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [dtn] Minimalistic Bundle Protocol use case (bpbis)

All,

Thanks very much,
Brian S.

---

From: Lloyd Wood <[email-masked]>
Date: Wed, 6 Apr 2016 20:49:47 +0000 (UTC)

blockquote, div.yahoo_quoted { margin-left: 0 !important; border-left:1px #715FFA solid !important;  padding-left:1ex !important; background-color:white !important; } "there are not yet any software implementations of either bpbis+CBOR or full-fledged bpsec"

so, no interop. and yet you're talking of standards, last call and the editor queue?

are you familiar with how the IETF process is supposed to work?

Lloyd Woodhttp://sat-net.com/L.Wood/dtn

On Thursday, April 7, 2016, 1:49 AM, Burleigh, Scott C (312B) <[email-masked]> wrote:

I agree, Brian, the approach you’re taking makes sense.  My understanding is that, as of the IETF DTN WG meeting on April4, the timeline for the bpbis spec now comes down to a 4-week Last Call starting about April 18, after which I hope we’ll be able to move ahead to the RFC editors’ queue fairly soon.  So yes, I think it’s close.

Custody transfer is really a sort of augmentation of bundle forwarding.  The basic forwarding procedures apply to all bundle transmission.  Custody transfer kicks in when the forwarded bundle has its “custody transfer requested” flag set, which tells the receiving node that the user application would like it to formally commit to successfully forwarding the bundle on the next hop along its end-to-end path, retrying in the event that the next-hop forwarding attempt fails.  Forwarding can be custodial or not, and this option is orthogonal to your choice of convergence-layer protocol, so the configuration you’re contemplating should work fine.

Scott

 
Scott,

 

 

 

Scott

 
All,

 

 
 
Thanks very much,
Brian S.