Subject: [dtn] AMP comment on report vs. RPT

From: Brian Sipos <[email-masked]>
Date: Mon, 4 Apr 2016 21:15:19 +0000

This is a comment against "draft-birrane-dtn-amp-02".

When I originally read over the AMP spec, I was slightly confused by the apparent dual-purpose of the term "report". In one case the "report" was being used to mean the collection-of-MIDs packaged together within what I will call a "report template". The other case is that "report" is used to mean the collection-of-typed-values packaged together within a RPT-typed value.

This has no impact on the actual protocol itself, only the specificaiton, but is there a better way to distinguish between the "report template" and the "report value". I think that just using two different terms like those (I don't really care what the terms are, as long as they are distinct) would go a long way to avoiding confusion when discussing AMP data units. The long-term effect of this would be less confusion when coming to the protocol the first time, and less confusion when discussing protocol data when testing or troubleshooting (for example).

---

From: "Birrane, Edward J." <[email-masked]>
Date: Wed, 6 Apr 2016 16:31:46 +0000

Brian,

  I completely agree!  The next version of AMP should address this with more clear terminology.

-Ed

---
Edward J. Birrane, III, Ph.D.
Embedded Applications Group Supervisor
Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423 / (F) 443-228-3839
________________________________
From: dtn <[email-masked]> on behalf of Brian Sipos <[email-masked]>
Sent: Monday, April 4, 2016 5:15 PM
To: [email-masked]
Subject: [dtn] AMP comment on report vs. RPT