Subject: [dtn] AMP-Agent ADM comment on ADM visibility

From: Brian Sipos <[email-masked]>
Date: Thu, 14 Apr 2016 19:25:29 +0000

This is a comment on "draft-birrane-dtn-adm-agent-01".

It appears that, by convention, each of the ADMs defines metadata to identify the ADM itself. I think there is a lot of value in the AMP Agent itself (or some other purpose-built ADM) providing a more detailed listing of available ADMs than the current "ListADMs" control. This behavior does rely on a table-like convention in AMP.

This would have a function nearly identical to the SNMP "sysORTable" that would identify the set of ADMs available on the managed node by:

 - ADM root MID

 - Some textual name (already part of metadata convention)

 - Some version name (already part of metadata convention)

This would allow a manager node to quickly identify the capabilities of a managed node in a heterogeneous environment, and provides a basic form of discovery for a troubleshooting situation to correlate the version reported here against the manager's ADM version.

I have no strong preference whether to add to the AMP-Agent ADM or define a new one. Having this in separate ADM _would_ allow this behavior to be optional on a node.

---

From: "Birrane, Edward J." <[email-masked]>
Date: Sun, 17 Apr 2016 20:19:39 +0000

Brian,

  I agree that the ListADM should have more information in it. Originally there was both a ListADM and a DescribeADM control, but the DescribeADM control was removed. However, some of the metadata never migrated into the ListADM.

  I think the Agent ADM should be updated as the text name, version, and root MID are items that all ADMs must provide.

-Ed

---
Edward J. Birrane, III, Ph.D.
Embedded Applications Group Supervisor
Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423 / (F) 443-228-3839

From: dtn [mailto:[email-masked]] On Behalf Of Brian Sipos
Sent: Thursday, April 14, 2016 3:25 PM
To: [email-masked]
Subject: [dtn] AMP-Agent ADM comment on ADM visibility

 - ADM root MID