Subject: [dtn] Hop Count exceeding

From: Lucas Kahlert <[email-masked]>
Date: Sun, 12 Mar 2017 20:02:19 +0100

Hello,

draft-ietf-dtn-bpbis-06 states in section 4.3.4 "a bundle SHOULD be 
deleted when its hop count exceeds its hop limit".
My question is: which method should be invoked:

  - 5.14. Bundle Deletion or
  - 5.15. Discarding a Bundle

And if a "Bundle Deletion" should be performed what is the appropriate 
reason code for a potential Bundle Status Report?

Maybe this point can be clarified in the document?

Regards,
Lucas

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Mon, 13 Mar 2017 22:24:02 +0000

Hi, Lucas.  My answer would be that bundle deletion (5.14) is the correct method to invoke, because the disappearance of a bundle needs to be documented if that documentation was requested.  As to reason code, I guess it wouldn't be altogether misleading to use "(1) Lifetime expired" but, since the hop count mechanism was added after the status code reason list was developed, I don't see any reason why we couldn't add a new reason code like "(9) Hop limit exceeded".

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Lucas Kahlert
Sent: Sunday, March 12, 2017 12:02 PM
To: dtn <[email-masked]>
Subject: [dtn] Hop Count exceeding

Hello,

draft-ietf-dtn-bpbis-06 states in section 4.3.4 "a bundle SHOULD be deleted when its hop count exceeds its hop limit".
My question is: which method should be invoked:

And if a "Bundle Deletion" should be performed what is the appropriate reason code for a potential Bundle Status Report?

Regards,
Lucas

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn

---

From: Rick Taylor <[email-masked]>
Date: Tue, 14 Mar 2017 10:12:42 +0000

Scott,

I'm a fan of explicit status codes for these kinds of fundamental
things that routing protocols might want to use for their own purposes,
so "(9) Hop Limit Exceeded" gets a +1 from me.

Rick

On Mon, 2017-03-13 at 22:24 +0000, Burleigh, Scott C (312B) wrote:
> Hi, Lucas.  My answer would be that bundle deletion (5.14) is the
> correct method to invoke, because the disappearance of a bundle needs
> to be documented if that documentation was requested.  As to reason
> code, I guess it wouldn't be altogether misleading to use "(1)
> Lifetime expired" but, since the hop count mechanism was added after
> the status code reason list was developed, I don't see any reason why
> we couldn't add a new reason code like "(9) Hop limit exceeded".
> 
> Scott
> 
> And if a "Bundle Deletion" should be performed what is the
> appropriate reason code for a potential Bundle Status Report?
>