Subject: [dtn] bpsec implementations

From: "Marc Blanchet" <[email-masked]>
Date: Thu, 19 Jul 2018 15:14:07 -0400

Hello,
  given its relative complexity, it would be good to know if the BPSEC 
specification (draft-ietf-dtn-bpsec and cipher profiles) have been 
implemented. If you have implemented this specifications, please say so 
here or directly to the chairs ([email-masked]).

Marc.

---

From: Mehmet Adalier <[email-masked]>
Date: Thu, 19 Jul 2018 13:33:26 -0700

Marc,
We have defined/ implemented a BPsec Cipher Suite, designed to be interoperable with the bpsec-interop cipher suite 
	It supports both PSK and ECDHE based on ECDSA curves P384 and P256.
	Confidentiality: AES 128 (compatibility) and 256-bit, modes GCM and CTR
	Integrity: HMAC256, HMAC384, ECDSA P256 and P384 signatures.
	For symmetric bundle key encryption, we use NIST SP.800-38F key wrap/unwrap.

We have also implemented BPsec based on the draft, based on Ed and Scott's work within the ION 3.6.1 code base.

Afaik, ION is not BPbis compliant yet, so I guess technically our implementation may be more sbsp.

Mehmet Adalier
Antara Teknik LLC 

On 7/19/18, 12:14 PM, "dtn on behalf of Marc Blanchet" <[email-masked] on behalf of [email-masked]> wrote:

    Hello,
    
    Marc.
    
    _______________________________________________
    dtn mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/dtn