Subject: [eap] Re: Review process for EAP SIM/AKA

From: Bernard Aboba <[email-masked]>
Date: Mon, 20 Sep 2004 12:43:42 -0700 (PDT)

Just a reminder:  No one has volunteered to review EAP AKA.  Any takers?

On Mon, 23 Aug 2004, Bernard Aboba wrote:

> A request has been made to publish the EAP SIM and EAP AKA specifications
> as individual submissions to the RFC Editor, utilizing the process
> outlined in http://www.ietf.org/internet-drafts/draft-iesg-rfced-documents-03.txt.
>
> EAP SIM and EAP AKA, which are 3GPP  dependencies, are being handled as AD
> sponsored individual submissions.  The specifications are available for
> inspection here:
>
> http://www.ietf.org/internet-drafts/draft-haverinen-pppext-eap-sim-13.txt
> http://www.ietf.org/internet-drafts/draft-arkko-pppext-eap-aka-12.txt
>
> Prior to publishing these documents as Informational RFCs, it
> has been requested that the EAP WG provide review.  The suggested review
> process includes the following elements:
>
> a. RFC 3748 compatibility review.  Since EAP SIM/AKA have already
> received a Type allocation, the review process described in RFC 3748
> is not required.  Nevertheless, it is desirable to review whether EAP
> SIM/AKA conform to the requirements of RFC 3748.  In this review, the
> Expert Review process described in RFC 3748 will be utilized (e.g.
> appointment of an Expert, publication of the review to the EAP WG mailing
> list, etc.)
>
> If you are willing to serve as an Expert in the review of EAP SIM or
> EAP AKA, please contact the EAP WG Chairs.
>
> b. EAP WG "pseudo-WG last call".  Since these documents were developed
> outside the IETF and are not work items of the EAP WG, the WG does not
> have change control.  For example, the SIM and AKA algorithms need to be
> taken as a given.  Nevertheless, WG review may produce comments that the
> editors may choose to incorporate.
>
> EAP WG "pseudo-WG" last call on EAP SIM/AKA will last until September 23,
> 2004.  Reviewers should send comments to the EAP WG mailing list
> ([email-masked]) in the format specified on the EAP Issues list:
> http://www.drizzle.com/~aboba/EAP/eapissues.html
>
_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Florent Bersani <[email-masked]>
Date: Tue, 21 Sep 2004 16:03:33 +0200

Bernard Aboba wrote:

>Just a reminder:  No one has volunteered to review EAP AKA.*
>
I do not think this is a true statement ;-)

>  Any takers?
I did (with the help of Henri Gilbert) volunteer to review EAP-AKA and I 
do it again (publicly this time, the last time you asked for private email)

Florent

---

From: Jari Arkko <[email-masked]>
Date: Wed, 22 Sep 2004 00:24:50 +0300

That's right Florent, you did volunteer. I'm sorry
but there's been a bit of confusion in this matter,
due to lack of communication on my part. I should
have told you and the list what's going on but didn't
get to it. Back in August we asked for volunteers and
also did some thinking of our own of who might be a
good reviewer. I managed to convince Bernard that he
should be the expert reviewer for these two documents.
However, he's become busy due to some other reasons and
can now review only one of the documents, EAP-SIM.
This means the expert position for EAP-AKA is open
again.

Note: given that we'd like to complete the review
and any corrections before the I-D deadlines (and
pending 3GPP deadlines), we are in a hurry with the
reviews at this point.

By the way, just as a clarification: we need one
formal "expert" for EAP methods when we review them,
but other reviews from the WG are also most welcome.
If you or others have comments on these documents,
please speak now.

--Jari