Subject: Re: [earlywarning] What problem is ATOCA trying to address?

From: "DALY, BRIAN K (ATTCINW)" <[email-masked]>
Date: Fri, 26 Mar 2010 12:49:43 -0700

It is not that simple. For example if you attempt to run Twitter over a wireless network and try to handle a large number of alerts (consider the EAN case) then congestion will result in delays. This is why SMS does not work and as more data enabled devices are used multicast/broadcast is essential.
------Original Message------
From: Brian Rosen
To: Art Botterell
To: [email-masked]
Subject: Re: [earlywarning] What problem is ATOCA trying to address?
Sent: Mar 26, 2010 8:44 AM

We're not at the mechanism state yet.  While I imagine that the mechanisms
may include something that is "if you have multicast, use it", I don't think
that would be enough because multicast is not enabled in way too many
networks.  Sites like Twitter show us that we can get enough messages sent
out in reasonable periods of time without multicast.

Brian

On 3/26/10 11:34 AM, "Art Botterell" <[email-masked]> wrote:

> On Mar 26, 2010, at 3/26/10 6:42 AM, Marc Linsner wrote:
>> Any IP device, any IP network, any message (not just Fed. Gov't), all under
>> end-user control (opt-in, opt-out, additional locations, etc.).
> 
> So is it possible we're really just revisiting IP multicast?
> 
> - Art
> _______________________________________________
> earlywarning mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/earlywarning

_______________________________________________
earlywarning mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/earlywarning

Brian K. Daly
-------
Sent from my Blackberry

---

From: "DALY, BRIAN K (ATTCINW)" <[email-masked]>
Date: Fri, 26 Mar 2010 14:28:02 -0700

Also CMAS is the solution recognized by FEMA, DHS, 3GPP and operators and is not some "parallel uncoordinated effort". CMAS is mainstream.

We have been down the path with the FCC and FEMA and have defined the end to end solution. I view it more does IETF desire to work in the scope of CMAS or not? But CMAS is the solution for commercial mobile devices.
Brian K. Daly
-------
Sent from my Blackberry

----- Original Message -----
From: [email-masked] <[email-masked]>
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Sent: Fri Mar 26 14:16:42 2010
Subject: Re: [earlywarning] What problem is ATOCA trying to address?

Disagree - we have designed an optimized system for commercial mobile devices that will deliver alerts to devices on those networks in an efficient manner. Regardless of what IETF does CMAS will continue to be the method operators will use for delivering alerts to any device connected to the network where the operator supports CMAS. That is fact.
Brian K. Daly
-------
Sent from my Blackberry

----- Original Message -----
From: David R Oran <[email-masked]>
To: DALY, BRIAN K (ATTCINW)
Cc: Art Botterell <[email-masked]>; [email-masked] <[email-masked]>
Sent: Fri Mar 26 13:10:11 2010
Subject: Re: [earlywarning] What problem is ATOCA trying to address?

On Mar 26, 2010, at 3:56 PM, DALY, BRIAN K (ATTCINW) wrote:

> Agree Art - Twitter is like SMS - no guarantee, unreliable, and prone to
> congestion. While in general it is good to try to get the message out as
> many ways as possible, at least one should be deemed "reliable".
> 
Sometimes reliability is the enemy of resilience. I would argue we're mostly shooting for the latter, and the former is often over-rated, especially if people start thinking it will work when needed and don't think more broadly, like maybe the cell tower just fell down.

That's why I think it's extremely short-sighted to try to "exempt" any particular device from the general IETF solution, and we should view the particular L2-specific mechanisms as optimizations to reduce load/congestion.

It also makes sense to view the cell-broadcast capability as an "underlay" for delivery of the more general Internet-generated and managed emergency alerts as opposed to some parallel and un-coordinated capability. 

Cheers, DaveO.

> Brian
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Art Botterell
> Sent: Friday, March 26, 2010 9:37 AM
> On Mar 26, 2010, at 3/26/10 9:14 AM, Henning Schulzrinne wrote:
>> And to bore everyone again with the same thing: In many cases,
> notifications are routinely sent to people outside a specific area or
> beyond a single network.
> 
> Which is why I thought it might be useful to reflect on WHY, after all
> these years, IP multicast has such limited scope, and on whether similar
> constraints might apply here.
> 
> Meanwhile, unicast approaches like Twitter rarely try to reach everyone
> on a particular local network, and they don't have any strict
> constraints on latency or even reliability, so I'd be cautious about
> assuming their suitability in emulation of a multicasting function.
> Anyone who's ever tried to text on New Year's Eve or Mother's Day should
> be able to relate.
> 
> - Art