Subject: Re: [earlywarning] Finishing the Charter Text Discussions

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 7 Apr 2010 16:30:57 -0400

The point is that people speak as individuals in the IETF and there is no particular notion that a corporate opinion has any more weight than that of any individual. Thus, stating a corporate opinion is out of place and against IETF custom and convention.

Henning

On Apr 7, 2010, at 4:28 PM, DOLLY, MARTIN C (ATTLABS) wrote:

> They sure do, look at everyone's badge
> 
> ----- Original Message -----
> From: [email-masked] <[email-masked]>
> To: DALY, BRIAN K (ATTCINW)
> Cc: [email-masked] <[email-masked]>
> Sent: Wed Apr 07 16:21:20 2010
> Subject: Re: [earlywarning] Finishing the Charter Text Discussions
> 
> I didn't know that the IETF had corporate opinions. But maybe the IETF rules have changed recently?
> 
> Henning
> 
> On Apr 7, 2010, at 4:13 PM, DALY, BRIAN K (ATTCINW) wrote:
> 
>> For the record, AT&T is in opposition to removing the last sentence.
>> 
>> Brian Daly
>> AT&T
> 
> _______________________________________________
> earlywarning mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/earlywarning

---

From: "DALY, BRIAN K (ATTCINW)" <[email-masked]>
Date: Wed, 7 Apr 2010 13:32:51 -0700

Fine but my "personal" view does not change.

Brian Daly

-----Original Message-----
From: Henning Schulzrinne [mailto:[email-masked]] 
Sent: Wednesday, April 07, 2010 1:31 PM
To: DOLLY, MARTIN C (ATTLABS)
Cc: DALY, BRIAN K (ATTCINW); [email-masked]
Subject: Re: [earlywarning] Finishing the Charter Text Discussions

The point is that people speak as individuals in the IETF and there is
no particular notion that a corporate opinion has any more weight than
that of any individual. Thus, stating a corporate opinion is out of
place and against IETF custom and convention.

Henning

---

From: "MUSGROVE, CHARLES P (ATTCINW)" <[email-masked]>
Date: Wed, 7 Apr 2010 13:33:51 -0700

Folks,

I agree with the proposed text additions to the charter as amended by
Brian Daly.

Peter Musgrove

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Henning Schulzrinne
Sent: Wednesday, April 07, 2010 1:31 PM
To: DOLLY, MARTIN C (ATTLABS)
Cc: [email-masked]
Subject: Re: [earlywarning] Finishing the Charter Text Discussions

Henning

---

From: "SENNETT, DEWAYNE A (ATTCINW)" <[email-masked]>
Date: Wed, 7 Apr 2010 13:37:01 -0700

My "personal" view is that the charter as currently written is not
correct or adequate.

DeWayne 

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of DALY, BRIAN K
(ATTCINW)
Sent: Wednesday, April 07, 2010 1:33 PM
To: Henning Schulzrinne; DOLLY, MARTIN C (ATTLABS)
Cc: [email-masked]
Subject: Re: [earlywarning] Finishing the Charter Text Discussions

Brian Daly

-----Original Message-----
From: Henning Schulzrinne [mailto:[email-masked]] 
Sent: Wednesday, April 07, 2010 1:31 PM
To: DOLLY, MARTIN C (ATTLABS)
Cc: DALY, BRIAN K (ATTCINW); [email-masked]
Subject: Re: [earlywarning] Finishing the Charter Text Discussions

Henning

---

From: Richard Barnes <[email-masked]>
Date: Wed, 7 Apr 2010 16:37:55 -0400

Could you please clarify how you believe it to be deficient?

On Apr 7, 2010, at 4:37 PM, SENNETT, DEWAYNE A (ATTCINW) wrote:

>> I didn't know that the IETF had corporate opinions. But maybe the  
>> IETF
> rules have changed recently?
>>
>> Henning
>>

---

From: "SENNETT, DEWAYNE A (ATTCINW)" <[email-masked]>
Date: Wed, 7 Apr 2010 13:47:57 -0700

It is deficient because it does not take into account the impacts that
will occur to the various access technologies.  All access technologies
do not have the same capacity, bandwidth, etc. Therefore any design that
has the potential to send information to all citizens within an area via
any variety of access technologies needs to consider these factors.  For
example, consider the scenario of trying to send an alert to the 100,000
fans at a college football game.

The current draft charter of ATOCA does not address this which is why
the additional sentences for the second paragraph were proposed. 

DeWayne

-----Original Message-----
From: Richard Barnes [mailto:[email-masked]] 
Sent: Wednesday, April 07, 2010 1:38 PM
To: SENNETT, DEWAYNE A (ATTCINW)
Cc: DALY, BRIAN K (ATTCINW); Henning Schulzrinne; DOLLY, MARTIN C
(ATTLABS); [email-masked]
Subject: Re: [earlywarning] Finishing the Charter Text Discussions

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 07 Apr 2010 16:09:22 -0500

At 03:30 PM 4/7/2010, Henning Schulzrinne wrote:
>The point is that people speak as individuals in the IETF and there 
>is no particular notion that a corporate opinion has any more weight 
>than that of any individual. Thus, stating a corporate opinion is 
>out of place and against IETF custom and convention.

+1

> > They sure do, look at everyone's badge

not everyone at the IETF is employed, so this position is not universal

James

> IETF rules have changed recently?
> >
> > Henning
> >

---

From: Brian Rosen <[email-masked]>
Date: Wed, 07 Apr 2010 17:22:42 -0400

But your proposed text doesn't say that: it addresses other services, and
other solutions, not the impact of this (new) service on the network.

Brian

---

From: Richard Barnes <[email-masked]>
Date: Wed, 7 Apr 2010 17:41:46 -0400

Ok, I can grant that that's something that's not clearly explained in  
the current charter.  However, it's also an issue that will tend to be  
layer-2 specific.  How about something like this:

"
Emergency alerts that are delivered to large numbers of endpoints can  
put a large load on the network, particularly when many affected users  
are on the same local network (e.g., the 100,000 attendees at a  
sporting event).  This working group will consider mechanisms for  
minimizing this load, such as IP multicast.  In particular, some  
approaches have been developed to handle emergency alerting in  
different types networks, and it will be a goal of this working group  
to facilitate interoperability with these approaches, for example, to  
enable gateways to relay messages from this Internet mechanism into a  
specific layer-2 channel.
"

On Apr 7, 2010, at 4:47 PM, SENNETT, DEWAYNE A (ATTCINW) wrote:

>> is

---

From: Brian Rosen <[email-masked]>
Date: Wed, 07 Apr 2010 17:54:56 -0400

I'm not bothered by the first part.  I don't like the last phrase, because
I'm not sure we should specifically describe such capabilities, and it may
not be a gateway.  How about changing the last sentence to "A goal of the
work will be to be able to use layer-2 specific mechanisms, where available,
to minimize load on the network."

---

From: Richard Barnes <[email-masked]>
Date: Wed, 7 Apr 2010 17:56:23 -0400

Fine with me.

---

From: Padma Valluri <[email-masked]>
Date: Thu, 8 Apr 2010 09:18:42 -0400

I'm not sure what "use" means here other than to imply 
interoperable/interworking with existing capabilities that are more 
efficient in certain segments of the network and deployed already. Why 
can't we be up front about making the interoperabilty as one of the main 
requirements of this charter to provide an end-to-end solution?

thanks,
Padma .

From:
Brian Rosen <[email-masked]>
To:
Richard Barnes <[email-masked]>, "SENNETT, DEWAYNE A (ATTCINW)" 
<[email-masked]>
Cc:
[email-masked], "DOLLY, MARTIN C \(ATTLABS\)" <[email-masked]>
Date:
04/07/2010 05:55 PM
Subject:
Re: [earlywarning] Finishing the Charter Text Discussions

work will be to be able to use layer-2 specific mechanisms, where 
available,

---

From: Brian Rosen <[email-masked]>
Date: Thu, 08 Apr 2010 09:34:11 -0400

Because it¹s pretty hard to define ³interoperability² with L2 mechanisms
that deliver alerts.  One of the biggest problems I have with most existing
L2 specific mechanisms is that they assume they are the only way alerts are
received. As a result, if you get an alert from some other mechanism, you
have no idea if its the same alert or a different one.  Your UI can't help
you at all with this.  One of the things I think we need is some ID
mechanism which is protocol agnostic and simply serves as the way to know if
you got an alert from multiple sources that they are the same alert.

Actually, no one is asking for interoperability.  They are discussing
various forms of peaceful co-existence.  Designing the protocol to take
advantage of some kinds of L2 packet delivery mechanisms may be possible
however.

Brian

On 4/8/10 9:18 AM, "Padma Valluri" <[email-masked]> wrote:

> interoperable/interworking with existing capabilities that are more efficient
> in certain segments of the network and deployed already. Why can't we be up
> front about making the interoperabilty as one of the main requirements of this
> charter to provide an end-to-end solution?
> 
> thanks, 
> Padma . 
> 
> 
> From: Brian Rosen <[email-masked]>
> To: Richard Barnes <[email-masked]>, "SENNETT, DEWAYNE A (ATTCINW)"
> <[email-masked]> 
> Cc: [email-masked], "DOLLY, MARTIN C \(ATTLABS\)" <[email-masked]>
> Date: 04/07/2010 05:55 PM
>>> From: Richard Barnes [mailto:[email-masked] <mailto:[email-masked]> ]
>>>> [mailto:[email-masked]
>>>> <mailto:[email-masked]> ] On Behalf Of DALY, BRIAN K
>>>> (ATTCINW)
>>>> From: Henning Schulzrinne [mailto:[email-masked]
>>>> <mailto:[email-masked]> ]
>>>>> <https://www.ietf.org/mailman/listinfo/earlywarning>
>>>> 
>>>> <https://www.ietf.org/mailman/listinfo/earlywarning>
>>>> <https://www.ietf.org/mailman/listinfo/earlywarning>
>>> 
>> 
>> <https://www.ietf.org/mailman/listinfo/earlywarning>
> 
> 
> <https://www.ietf.org/mailman/listinfo/earlywarning>
> 
> 
>

---

From: Padma Valluri <[email-masked]>
Date: Thu, 8 Apr 2010 09:50:33 -0400

I was thinking of a usecase where the issuing authority can use the SIP mechanism to send an alert and it continues until it hits an acess network brocast point where this gets converted to a L2 alert like it happens in other IMS protocols. Won't that require some kind of interworking?

Padma Valluri
CSC

15000 Conference Center Dr., Chantilly, VA  20151
Enforcement Security & Intelligence | w: 703-818-4937 | f: 703-818-4053 [email-masked] | www.csc.com

This is a PRIVATE message. If you are not the intended recipient, please delete without copying and kindly advise us by e-mail of the mistake in delivery.
NOTE: Regardless of content, this e-mail shall not operate to bind CSC to any order or other contract unless pursuant to explicit written agreement or government initiative expressly permitting the use of e-mail for such purpose.

-----Brian Rosen <[email-masked]> wrote: -----

To: Padma Valluri/USA/CSC@CSC
From: Brian Rosen <[email-masked]>
Date: 04/08/2010 09:34AM
cc: "SENNETT, DEWAYNE A (ATTCINW)" <[email-masked]>, <[email-masked]>, <[email-masked]>, "DOLLY, MARTIN C (ATTLABS)" <[email-masked]>, Richard Barnes <[email-masked]>
Subject: Re: [earlywarning] Finishing the Charter Text Discussions

Brian

---

From: "DALY, BRIAN K (ATTCINW)" <[email-masked]>
Date: Thu, 8 Apr 2010 07:33:41 -0700

Brian - 

If "no one" is asking for interoperability (and I am not sure who "no one" is :-) ) then I agree this can be a somewhat peaceful co-existence of mandated services (CMAS, EAS, iPAWS, DMOpen vs a market driven service that is not and will not be designed with the intention to integrate into or interoperate with services such as CMAS.

However, because of the potential for confusion by the reader and regulators, all we are asking is that the charter clearly state this fact that apparently we are in agreement on.

Can we craft some language for the charter that emphasizes this?

Brian D.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian Rosen
Sent: Thursday, April 08, 2010 6:34 AM
To: Padma Valluri
Cc: [email-masked]; SENNETT, DEWAYNE A (ATTCINW); [email-masked]; DOLLY, MARTIN C (ATTLABS)
Subject: Re: [earlywarning] Finishing the Charter Text Discussions

Brian

---

From: [email-masked]
Date: Fri, 9 Apr 2010 12:09:24 -0400 (EDT)

In Europe they are working toward a Pan-European alerting and warning
infrastructure with full interoperability. However, I am not sure at what
level in the "stack" this work is being done - perhaps more at the higher
levels in the application arena. I do not see discussions on L2 or CMAS or
whatever. The European programs are initially being funded as part of the
FP 6 and 7 initiatives. Check out ORCHESTRA
(http://www.eu-orchestra.org/), GMES/SAFER
(http://www.emergencyresponse.eu/site/FO/scripts/myFO_accueil.php?lang=EN)
and SANY (http://www.sany-ip.eu/). SANY is interesting because the focus
is on integrating sensor alerts into a modeling, warning, and alerting
infrastructure.

Similar activities are occurring in Asia, such as Debris Flow Monitoring
and Alerting in Taiwan, Tsunami Alerting in Indonesia, and earthquake
warning in Japan.

Regards

Carl

> Brian -
>
> If "no one" is asking for interoperability (and I am not sure who "no one"
> is :-) ) then I agree this can be a somewhat peaceful co-existence of
> mandated services (CMAS, EAS, iPAWS, DMOpen vs a market driven service
> that is not and will not be designed with the intention to integrate into
> or interoperate with services such as CMAS.
>
> However, because of the potential for confusion by the reader and
> regulators, all we are asking is that the charter clearly state this fact
> that apparently we are in agreement on.
>
> Cc: [email-masked]; SENNETT, DEWAYNE A (ATTCINW);
> [email-masked]; DOLLY, MARTIN C (ATTLABS)
>> efficient

---

From: "MUSGROVE, CHARLES P (ATTCINW)" <[email-masked]>
Date: Fri, 9 Apr 2010 10:43:04 -0700

Europe is looking at a warning system based on the 3GPP Public Warning System (PWS) based on cell broadcast. They are studying the US-based CMAS as a model for their PWS with a long-term goal of supporting PWS for international roamers (among European countries as well as to/from US/Asia/elsewhere). The Netherlands is already moving toward implementation of a cell broadcast-based system.

Regards,
Peter Musgrove

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 09, 2010 9:09 AM
To: DALY, BRIAN K (ATTCINW)
Cc: DOLLY, MARTIN C (ATTLABS); [email-masked]; [email-masked]
Subject: Re: [earlywarning] Finishing the Charter Text Discussions

Regards

Carl

---

From: [email-masked]
Date: Fri, 9 Apr 2010 13:53:18 -0400 (EDT)

As I was thinking - there are multiple levels of standardization work
going on in Europe. The OGC community is dealing at the application level
- not the infrastructure level.

Thanks!

Carl
> Europe is looking at a warning system based on the 3GPP Public Warning
> System (PWS) based on cell broadcast. They are studying the US-based CMAS
> as a model for their PWS with a long-term goal of supporting PWS for
> international roamers (among European countries as well as to/from
> US/Asia/elsewhere). The Netherlands is already moving toward
> implementation of a cell broadcast-based system.
>
> Regards,
> Peter Musgrove
>
>> [mailto:[email-masked]]
>> On Behalf Of Brian Rosen
>> mechanism which is protocol agnostic and simply serves as the way to
>> know
>> if
>>> in certain segments of the network and deployed already. Why can't we
>>> be
>>> up

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 9 Apr 2010 22:07:56 +0200

Carl, I think the problem is that your statement: "I do not see discussions on L2 or CMAS or whatever", implies on first reading that there are none, rather than you are not aware of them.

Indeed there are activities taking place on trialing cell broadcast for such alerts, and at least the intent I was seeing from the people involved in this was that they would be looking to activities in ETSI to channel this work into 3GPP, and that they would be using the CMAS work as a starting point. One key problem to solve is that in multilingual countries, the alert would have to be delivered in multiple languages - not a problem except procedures need to be defined to cycle round such messages, which does not exist in CMAS at the moment. I also gathered some clear statements that they wanted a solution independent of any work that took place elsewhere on other infrastructures.

So to me this emphasises that the ATOCO work has to progess in a manner that works in a complementary fashion to other mechanisms already in deployment, and which in certain scenarios may be the only reliable mechanism of delivering the alert, and not just assume from its charter that the mechanism it provides when it is finished is the only fish in the pond.

regards

Keith

> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Friday, April 09, 2010 6:53 PM
> To: MUSGROVE, CHARLES P (ATTCINW)
> Cc: [email-masked]; [email-masked]; 
> DALY, BRIAN K (ATTCINW); DOLLY, MARTIN C (ATTLABS)
> As I was thinking - there are multiple levels of 
> standardization work going on in Europe. The OGC community is 
> dealing at the application level
> > System (PWS) based on cell broadcast. They are studying the 
> US-based 
> > CMAS as a model for their PWS with a long-term goal of 
> supporting PWS 
> > for international roamers (among European countries as well 
> as to/from 
> > On Behalf Of [email-masked]
> > infrastructure with full interoperability. However, I am 
> not sure at 
> > what level in the "stack" this work is being done - perhaps more at 
> > the higher levels in the application arena. I do not see 
> discussions 
> > on L2 or CMAS or whatever. The European programs are 
> initially being 
> > funded as part of the FP 6 and 7 initiatives. Check out ORCHESTRA 
> (http://www.emergencyresponse.eu/site/FO/scripts/myFO_accueil.php?lang
> > =EN) and SANY (http://www.sany-ip.eu/). SANY is interesting because 
> > the focus is on integrating sensor alerts into a modeling, warning, 
> > and alerting infrastructure.
> >
> > Similar activities are occurring in Asia, such as Debris Flow 
> > Monitoring and Alerting in Taiwan, Tsunami Alerting in 
> Indonesia, and 
> > earthquake warning in Japan.
> >
> > Regards
> >
> > Carl
> >
> >
> >
> >
> >
> >> Brian -
> >>
> >> If "no one" is asking for interoperability (and I am not 
> sure who "no 
> >> one"
> >> mandated services (CMAS, EAS, iPAWS, DMOpen vs a market driven 
> >> service that is not and will not be designed with the intention to 
> >> integrate into or interoperate with services such as CMAS.
> >>
> >> regulators, all we are asking is that the charter clearly 
> state this 
> >> fact that apparently we are in agreement on.
> >>
> >> Because it¹s pretty hard to define ³interoperability² with L2 
> >> mechanisms that deliver alerts.  One of the biggest 
> problems I have 
> >> with most existing
> >> L2 specific mechanisms is that they assume they are the only way 
> >> alerts are received. As a result, if you get an alert from 
> some other 
> >> mechanism, you have no idea if its the same alert or a 
> different one.  
> >> Your UI can't help you at all with this.  One of the 
> things I think 
> >> we need is some ID mechanism which is protocol agnostic and simply 
> >> serves as the way to know if you got an alert from 
> multiple sources 
> >> that they are the same alert.
> >>
> >> various forms of peaceful co-existence.  Designing the protocol to 
> >> take advantage of some kinds of L2 packet delivery 
> mechanisms may be 
> >> possible however.
> >>
> >> Brian
> >>
> >>
> >>> efficient in certain segments of the network and deployed 
> already. 
> >>> Why can't we be up front about making the interoperabilty 
> as one of 
> >>> the main requirements of this charter to provide an end-to-end 
> >>> solution?
> >>>
> >>> thanks,
> >>> Padma .
> >>>
> >>>
> >>> I'm not bothered by the first part.  I don't like the 
> last phrase, 
> >>> because I'm not sure we should specifically describe such 
> >>> capabilities, and it may not be a gateway.  How about 
> changing the 
> >>> last sentence to "A goal of the work will be to be able to use 
> >>> layer-2 specific mechanisms, where available, to minimize load on 
> >>> the network."
> >>>
> >>>
> >>>> Ok, I can grant that that's something that's not clearly 
> explained 
> >>>> in the current charter.  However, it's also an issue 
> that will tend 
> >>>> to be
> >>>> Emergency alerts that are delivered to large numbers of 
> endpoints 
> >>>> can put a large load on the network, particularly when many 
> >>>> affected users are on the same local network (e.g., the 100,000 
> >>>> attendees at a sporting event).  This working group will 
> consider 
> >>>> mechanisms for minimizing this load, such as IP multicast.  In 
> >>>> particular, some approaches have been developed to 
> handle emergency 
> >>>> alerting in different types networks, and it will be a 
> goal of this 
> >>>> working group to facilitate interoperability with these 
> approaches, 
> >>>> for example, to enable gateways to relay messages from this 
> >>>> Internet mechanism into a specific layer-2 channel.
> >>>> "
> >>>>
> >>>>
> >>>>
> >>>>> It is deficient because it does not take into account 
> the impacts 
> >>>>> that will occur to the various access technologies.  All access 
> >>>>> technologies do not have the same capacity, bandwidth, etc. 
> >>>>> Therefore any design that has the potential to send 
> information to 
> >>>>> all citizens within an area via any variety of access 
> technologies 
> >>>>> needs to consider these factors.
> >>>>> For
> >>>>> example, consider the scenario of trying to send an 
> alert to the 
> >>>>> 100,000 fans at a college football game.
> >>>>>
> >>>>> The current draft charter of ATOCA does not address 
> this which is 
> >>>>> why the additional sentences for the second paragraph 
> were proposed.
> >>>>>
> >>>>> DeWayne
> >>>>>
> >>>>>> My "personal" view is that the charter as currently written is 
> >>>>>> not correct or adequate.
> >>>>>>
> >>>>>> DeWayne
> >>>>>>
> >>>>>>
> >>>>>> <mailto:[email-masked]> ] On Behalf Of 
> DALY, BRIAN 
> >>>>>> K
> >>>>>> (ATTCINW)
> >>>>>> The point is that people speak as individuals in the IETF and 
> >>>>>> there is no particular notion that a corporate opinion has any 
> >>>>>> more weight than that of any individual. Thus, stating a 
> >>>>>> corporate opinion is out of place and against IETF custom and 
> >>>>>> convention.
> >>>>>>
> >>>>>>
> >>>>>> Henning
> >>>>>>
> >>>>>>> <[email-masked]>
> >>>>>>> I didn't know that the IETF had corporate opinions. But maybe 
> >>>>>>> the IETF

---

From: [email-masked]
Date: Fri, 9 Apr 2010 19:27:29 -0400 (EDT)

Keith -

Apologies. You are correct. I am personally not aware of any. As you and
others have stated, there are definitely discussions and work being done
at other levels in the warning/alerting standards stack - such as using
CMAS as a starting point.

Multi-language is definitely something the OGC Members are tuned into.

Thanks!

Carl

> Carl, I think the problem is that your statement: "I do not see
> discussions on L2 or CMAS or whatever", implies on first reading that
> there are none, rather than you are not aware of them.
>
> Indeed there are activities taking place on trialing cell broadcast for
> such alerts, and at least the intent I was seeing from the people involved
> in this was that they would be looking to activities in ETSI to channel
> this work into 3GPP, and that they would be using the CMAS work as a
> starting point. One key problem to solve is that in multilingual
> countries, the alert would have to be delivered in multiple languages -
> not a problem except procedures need to be defined to cycle round such
> messages, which does not exist in CMAS at the moment. I also gathered some
> clear statements that they wanted a solution independent of any work that
> took place elsewhere on other infrastructures.
>
> So to me this emphasises that the ATOCO work has to progess in a manner
> that works in a complementary fashion to other mechanisms already in
> deployment, and which in certain scenarios may be the only reliable
> mechanism of delivering the alert, and not just assume from its charter
> that the mechanism it provides when it is finished is the only fish in the
> pond.
>
> regards
>
> Keith
>