Subject: RE: [Ecrit] New requirements draft -09 available

From: "Roger Marshall" <[email-masked]>
Date: Thu, 18 May 2006 15:45:16 -0700

Sounds good to me.  Hannes? Marc? 

-roger.

>-----Original Message-----
>From: James M. Polk [mailto:[email-masked]] 
>Sent: Thursday, May 18, 2006 3:08 PM
>To: Brian Rosen; Roger Marshall; [email-masked]
>Subject: RE: [Ecrit] New requirements draft -09 available
>
>At 05:26 PM 5/18/2006 -0400, Brian Rosen wrote:
>>Roger
>>
>>Thank you for all your work on this.
>>
>>Can we be done now?
>>
>>We are clearly over the line when we make a change to the 
>requirements 
>>in light of a draft for the solution (service urn).  We need to get 
>>this document out now, because we're not helping the solution, we're 
>>just polishing the apple.
>>
>>I respectfully ask that we complete WGLC, and any further comments be 
>>subject to a "does this REALLY matter now" test.
>
>I second this motion
>
>
>>The best quality requirements documents are always written after the 
>>product is in the market, but those don't help the 
>implementation team much.
>>
>>Brian
>>
>>-----Original Message-----
>>From: Roger Marshall [mailto:[email-masked]]
>>Sent: Thursday, May 18, 2006 4:28 PM
>>To: [email-masked]
>>Subject: [Ecrit] New requirements draft -09 available
>>
>>Here's a summary of changes for the new edition of the ECRIT 
>>requirements draft, recently submitted to the I-D editor.
>>
>>A URL for this Internet-Draft is:
>>http://www.ietf.org/internet-drafts/draft-ietf-ecrit-requireme
>nts-09.tx
>>t
>>
>>A diff version of this is available at:
>>http://tools.ietf.org/wg/ecrit/draft-ietf-ecrit-requirements/
>>
>>This new version contains changes which are generally described below:
>>
>>A.  Quite a bit of renumbering and reordering has been done with both 
>>the terminology section and the various requirements.
>>
>>B.  Received review comments from Hannes (5/12) & a few 
>others.  Tried 
>>to incorporate all or respond with reasons why, if not.
>>
>>C.  Rewording of Introduction section, paragraph 6, etc. 
>talking about 
>>identifiers.
>>
>>D.  Tried to clean up confusion around terminology.  For example, 
>>replaced the term 'emergency identifier' with 'emergency service 
>>identifier'.
>>
>>E.  In light of the ecrit-service-urn draft, added some new terms & 
>>defns, such as:
>>
>>Service identifier (examples include: urn:service:info or a tel URI,
>>etc.)
>>Service URN (an implementation of above, namely conforms to 
>the example
>>urn:service:*)
>>Emergency service identifier ((ESI), from the set of service 
>>identifiers, context=emergency services only, with examples of 
>>urn:service:sos or a tel URI) Emergency service URN (an 
>implementation 
>>of an ESI, example is urn:service:sos, urn:service:sos.fire, etc. - 
>>also sometimes referred to as an 'sos service URN')
>>
>>(In the last case of an emergency service URN, I don't like 
>to have two 
>>names for the same thing, but felt that this name was preferable, 
>>rather than use 'sos service URN'.)
>>
>>F. Updated the issues in the issues tracker
>>(http://www.ietf-ecrit.org:8080/ecrit-req/index):
>>
>>Only a few issues remain.  Since some rewording changes we 
>made, these 
>>are still left to age (i.e., time for comment).
>>
>>Issues which I have left open are:
>>#52 protocol specific, end devices out of scope - reworded to 
>make more 
>>general/
>>#35 Location Validation - removed 1 existing, 2 of the new 
>>requirements, marked 'done'/
>>#38 Ma5. URI alternate contact - some rewording + renumbered now as 
>>Ma9, marked 'done'/
>>#39 Ma6. URL properties  - replacement of URL with URI, renumbered as 
>>Ma11, marked 'done'/
>>
>>#52 will be marked as "Resolved" after several days, assuming no 
>>objections arise from the list.
>>
>>G.  No new issues have been logged.
>>
>>H.  Removed requirements Id4, "Prevention of Fraud, based on review 
>>comment that it be covered within the security draft.
>>
>>I.  Added IANA section to draft.
>>
>>
>>Roger Marshall.
>>
>>_______________________________________________
>>Ecrit mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/ecrit
>>
>>
>>_______________________________________________
>>Ecrit mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 19 May 2006 16:28:33 +0200

have you, Brian and James, read draft version -08 or -09?
Are you OK with the -09 version?

Ciao
Hannes

---

From: "Brian Rosen" <[email-masked]>
Date: Fri, 19 May 2006 11:34:08 -0400

I have now looked at -09 and I am happy with it.

Brian

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: Friday, May 19, 2006 10:29 AM
To: Roger Marshall
Cc: James M. Polk; Brian Rosen; [email-masked]
Subject: Re: [Ecrit] New requirements draft -09 available

Ciao
Hannes