Subject: RE: [Ecrit] Review of draft-ietf-ecrit-requirements-08.txt

From: "Roger Marshall" <[email-masked]>
Date: Fri, 5 May 2006 16:34:29 -0700

Ted, Hannes:

I've merged the two defn's (Emergency Address & PSAP URI) together, and
given XMPP, removed IM reference:, (Andy's comment).  

See if you can live with the result.

CHANGE FROM:
PSAP URI: PSAP URI is a general term, used to refer to 
the output of the mapping protocol, and represents either the actual 
PSAP IP address, or the IP address of some other intermediary, e.g., an 
ESRP, which points to the actual PSAP.

CHANGE TO:
PSAP URI: The URI (e.g., SIP:URI, SIPS:URI, XMPP:URI, 
etc.) at which the PSAP may be contacted with an emergency call.  This 
contact could be done directly, or via an intermediary, (e.g., ESRP).
The 
URI contains information about the protocol used (encoded in the
scheme), 
so that a focus on the IP address that it may resolve to is not
appropriate. 
There are even cases where the SIP:URI and the XMPP:URI for the same 
PSAP might not point to the same box. 

-roger.

>-----Original Message-----
>From: Hannes Tschofenig [mailto:[email-masked]] 
>Sent: Friday, May 05, 2006 2:25 PM
>To: Ted Hardie
>Cc: Roger Marshall; [email-masked]
>Subject: Re: [Ecrit] Review of draft-ietf-ecrit-requirements-08.txt
>
>I like your definition, Ted. Now, we just need to make sure 
>that it is used at the right places in the draft.
>
>Btw, I think that it might be good to add the term 'sos 
>service type' to draft-ietf-ecrit-requirements-08.txt as used 
>in draft-ietf-ecrit-service-urn-02.txt.
>
>draft-ietf-ecrit-service-urn-02.txt denotes each of the 
>following strings as sos service types (at least I think so):
>
>urn:service:sos
>urn:service:sos.ambulance
>urn:service:sos.animal-control
>....
>urn:service:sos.mental-health
>
>To have a generic term for all these identifiers the term 
>'emergency identifier' seems to be appropriate.
>
>Ciao
>Hannes
>
>PS: Let me know if I got totally confused.
>
>
>Ted Hardie wrote:
>> At 10:31 PM +0200 5/5/06, Hannes Tschofenig wrote:
>> 
>>>>CHANGE FROM:
>>>>Emergency address: The URI (e.g., SIP:URI, SIPS:URI, 
>XMPP:URI, IM:URI, etc.) which represents the address of the 
>PSAP useful for the completion of an emergency call.
>>>>
>>>>CHANGE TO:
>>>>Emergency address: The PSAP URI (e.g., SIP:URI, SIPS:URI, 
>XMPP:URI, IM:URI, etc.) which represents the IP address of the 
>PSAP useful for the completion of an emergency call.
>>>
>>>A URI cannot represent an IP address. A URI can be resolved 
>to an IP address.
>>>
>>>Ciao
>>>Hannes
>> 
>> 
>> I believe we may mean:
>> 
>> "Emergency address:  The URI (e.g. , SIP:URI, SIPS:URI, XMPP:URI, 
>> IM:URI, etc.) at which the PSAP may be contacted with an 
>emergency call."
>> 
>> The URI contains information about the protocol used (encoded in the 
>> scheme), so a focus on the IP address is not appropriate. There are 
>> even cases where the SIP:URI and the IM:URI might not point 
>to the same box.
>> 				regards,
>> 					Ted Hardie
>> 
>> 
>
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Ted Hardie <[email-masked]>
Date: Sat, 6 May 2006 05:48:55 -0700

>PSAP might not point to the same box.

I hadn't actually intended for the lines above to be included; I meant
them as further information about the URI for the group.  If people
think that it is valuable to include it, though, I  would elide
"so that a focus on the IP address that it may resolve to is not
appropriate.".
		regards,
			Ted Hardie