Subject: RE: [Ecrit] Re: Commments I.D-ecrit-service-urn-03 Child helpline

From: "Roger Marshall" <[email-masked]>
Date: Wed, 17 May 2006 15:49:51 -0700

As used for emergency services, I assume LoST produces the following
outputs:

A. ) given location as input, LoST returns service identifier (e.g.
urn:service:sos)
B. ) given location + service identifier as input, LoST returns PSAP URI
C. ) given location + service identifier as input, LoST returns PSAP URI
+ dial string
D. ) given location + service identifier as input, LoST returns PSAP URI
+ dial string + PSAP_preference_info

Are there more cases?

Roger Marshall

>-----Original Message-----
>From: Henning Schulzrinne [mailto:[email-masked]] 
>Sent: Wednesday, May 17, 2006 2:56 PM
>To: Spencer Dawkins
>Cc: [email-masked]
>Subject: Re: [Ecrit] Re: Commments I.D-ecrit-service-urn-03 
>Child helpline
>
>LoST maps location and service URN to a set of answers. Thus, you have
>
>query to LoST: "I'm in Tokyo, Japan and interested in the fire brigade"
>
>response: "Your dialstring is XYZ and the PSAP URL is 
>[email-masked]"
>
>Spencer Dawkins wrote:
>> Having looked at this yesterday, "dialstring" is part of the LoST 
>> RESPONSE example in the current LoST draft, not part of the request, 
>> so I think we are confused here (which may be as simple as the LoST 
>> draft being out of phase with what people think, or may be 
>something else)...
>> 
>> Please check my math in draft-hardie-ecrit-lost-00.txt.
>> 
>> Comments? It's "location *to* service translation", right? :-)
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Ted Hardie <[email-masked]>
Date: Wed, 17 May 2006 16:00:04 -0700

>A. ) given location as input, LoST returns service identifier (e.g.

I don't think I understand this.  You want the LoST server to return
the supported service identifiers in response to a query containing
only location?

>+ dial string + PSAP_preference_info

Is PSAP_preference_info the same as a fallback PSAP, or something else?

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 17 May 2006 19:17:51 -0400

I hadn't thought about it before, but it does make sense to return a list of
all the service identifiers that LoST could return a URI for.

I'm not so sure about PSAP preference info.  Normally, I would expect to get
that in the INVITE response.  Is there something outside of that you think
would be interesting?  What? How is it represented?

Brian