Subject: RE: [Ecrit] Related services

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 23 May 2006 10:00:29 -0400

Please explain what you mean or don't mean by "tree structure".

Talking about a services and sub-services sounds like a tree to me.

Mike

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]] 
> Sent: Monday, May 22, 2006 9:27 PM
> To: Andrew Newton
> Cc: [email-masked]
> Subject: Re: [Ecrit] Related services
> 
> >
> > My alarm panel, which uses VoIP, has three buttons 
> (actually 6, 2 rows 
> > of three that require both buttons in each row to be 
> pressed).  One is 
> > labeled "Police", one is labeled "Ambulance" and one is labeled 
> > "Fire".  If I press fire, urn:service.sos.fire is sent to the LoST 
> > server.  The lost server then responds with 
> > urn:service.sos.scuba-accidents, urn:service.sos.crazy-persons, and 
> > urn:service.sos.duck-patrol.  Why is it not proper for the 
> LoST server 
> > simply to
> 
> I'm not suggesting that the server respond with 
> scuba-accidents or the like; I'm not sure where I gave you 
> this impression.
> 
> 
> > respond with "you want urn:service.sos" and here is the URI 
> for that 
> > PSAP."  Why must the client have to requery by knocking of a label?
> 
> Why not just provide the PSAP URL in that case, even if it's 
> the same answer that urn:service:sos would return? After all, 
> this PSAP is, by definition, able to provide access to fire 
> department services. That it is not an organizationally 
> separate entity seems to be of no interest to the caller.
> 
> >
> > BTW:  I thought there was no tree structure for these URNs, so what 
> > does "next-layer-up" mean?
> 
> There is no tree structure, but I thought earlier discussion 
> had agreed that the top-level service (urn:service.x) is 
> always valid if there are any sub-services?
> 
> >
> > -andy
> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 23 May 2006 10:11:24 -0400

If you take a look at the service URN draft, you will notice that 
service descriptions are indeed hierarchical, i.e., a "tree". You could 
define (and register) a service such a

urn:service:sos.fire.grease.hamburger

In practice, it would seem unlikely that the nesting would be deeper 
than maybe three levels.