Subject: RE: [Ecrit] Review of draft-ietf-ecrit-requirements-08.txt

From: "Roger Marshall" <[email-masked]>
Date: Fri, 5 May 2006 11:59:10 -0700

I think our intention for the requirements draft to describe the
following set:

Emergency dial string (e.g., "9-1-1", "1-1-2")
Emergency identifiers (e.g., "service:urn:sos")
Emergency address (e.g., a PSAP URI, which resolves to an IP address)
PSAP:URI (e.g., "[email-masked]", "[email-masked]")

Since this is not what the draft actually says, I propose changing the
following:

CHANGE FROM:
Emergency address: The URI (e.g., SIP:URI, SIPS:URI, 
XMPP:URI, IM:URI, etc.) which represents the address of the PSAP 
useful for the completion of an emergency call.

CHANGE TO:
Emergency address: The PSAP URI (e.g., SIP:URI, SIPS:URI, 
XMPP:URI, IM:URI, etc.) which represents the IP address of the PSAP 
useful for the completion of an emergency call.

I'll do a consistency check in addition to other comments received.

Thanks.

-roger.

>-----Original Message-----
>From: Tom-PT Taylor [mailto:[email-masked]] 
>Sent: Friday, May 05, 2006 10:34 AM
>To: Hannes Tschofenig
>Cc: Roger Marshall; [email-masked]
>Subject: Re: [Ecrit] Review of draft-ietf-ecrit-requirements-08.txt
>
>My security I-D uses definitions from the requirements 
>document. These definitions and terms have changed. I may be 
>forced to create definitions of my own as a result.
>
>Hannes Tschofenig wrote:
>> Hi Tom,
>> 
>> I guess you refer to the distinction between 'emgerency identifier' 
>> and 'emergency address'. We have used 'emergency identifier' 
>for what 
>> we call 'emergency address' in this document. You might remember the 
>> extremely long discussion regarding the 'emergency identifier' vs.
>> 'emergency dial strings'.
>> 
>> Now, I agree that it is necessary to have some form of 
>emergency call 
>> marking. That's also in the requirements document listed as a 
>> requirement. There is no need to use a separate term for it, 
>> particularly when it conflicts with something else. Actually, I 
>> haven't come accross such a emergency call marking in one of our 
>> solution specific documents. Shouldn't that be in Henning's 
>Service URN document?
>> I want to review the latest version (after resubmitted it).
>> 
>> Ciao
>> Hannes
>> Tom-PT Taylor wrote:
>>> There is a functional distinction between something that identifies 
>>> the call as an emergency call (and must be present even 
>after mapping 
>>> has been performed so that downstream elements are aware of the 
>>> nature of the call) and something that says where the call 
>should be 
>>> directed. By calling them both 'identifier' you lose this 
>>> distinction. I think it is important that we keep it.
>>>
>
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 05 May 2006 22:31:39 +0200

Hi Roger,

> Emergency dial string (e.g., "9-1-1", "1-1-2")
fine.

> Emergency identifiers (e.g., "service:urn:sos")
fine.

> PSAP:URI (e.g., "[email-masked]", "[email-masked]")

We use the term PSAP URI for this purpose. We don't need the emergency 
address terminology.

> useful for the completion of an emergency call.

A URI cannot represent an IP address. A URI can be resolved to an IP 
address.

Ciao
Hannes

---

From: Andrew Newton <[email-masked]>
Date: Fri, 05 May 2006 16:40:08 -0400

Hannes Tschofenig wrote:
>> Emergency address: The URI (e.g., SIP:URI, SIPS:URI, XMPP:URI, IM:URI, 
>> etc.) which represents the address of the PSAP useful for the 
>> completion of an emergency call.
>>
>> CHANGE TO:
>> Emergency address: The PSAP URI (e.g., SIP:URI, SIPS:URI, XMPP:URI, 
>> IM:URI, etc.) which represents the IP address of the PSAP useful for 
>> the completion of an emergency call.
> 

Uh, what!? What about http://192.138.228.1?  I think using the 
terminology, "resolves to" is what is being sought here.  I also don't 
understand this SIPS:URI stuff.

How about:

Emergency address:  The PSAP URI (e.g., SIP URI, SIPS URI, XMPP URI, IM 
URI, etc...) which resolves to the communication end point of a PSAP.

BTW, what protocol is the IM scheme?

-andy

---

From: Ted Hardie <[email-masked]>
Date: Fri, 5 May 2006 13:54:28 -0700

At 10:31 PM +0200 5/5/06, Hannes Tschofenig wrote:
>>CHANGE FROM:
>>Emergency address: The URI (e.g., SIP:URI, SIPS:URI, XMPP:URI, IM:URI, etc.) which represents the address of the PSAP useful for the completion of an emergency call.
>>
>>CHANGE TO:
>>Emergency address: The PSAP URI (e.g., SIP:URI, SIPS:URI, XMPP:URI, IM:URI, etc.) which represents the IP address of the PSAP useful for the completion of an emergency call.
>
>A URI cannot represent an IP address. A URI can be resolved to an IP address.
>
>Ciao
>Hannes

I believe we may mean:

"Emergency address:  The URI (e.g. , SIP:URI, SIPS:URI, XMPP:URI, IM:URI, etc.) at
which the PSAP may be contacted with an emergency call."

The URI contains information about the protocol used (encoded in the scheme), so
a focus on the IP address is not appropriate. There are even cases where the SIP:URI and
the IM:URI might not point to the same box.
				regards,
					Ted Hardie

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 05 May 2006 22:56:49 +0200

Hi Andy,
Hi Roger,

I was wrong with my previous statement. I should rephrase my statement: 
You cannot write "The URI which represents the IP address of the PSAP."

Let us look where this term is actually used in the document:

    Id3.  Emergency identifier marking: The mapping protocol MUST include
       an emergency identifier with the signaling, if one does not exist,
       for the purpose of marking the call as an emergency call.

       Motivation: Marking ensures proper handling as an emergency call
       by downstream elements that may not recognize, for example, a
       local variant of a logical emergency address, etc.

# What is a "local variant of a logical emergency address"?

       This marking
       mechanism is assumed to be different than a QoS marking mechanism.

    Id8.  Emergency dial string replacement: The mapping protocol SHOULD
       support replacement of the original dial string with a reserved
       emergency identifier for each signaling protocol used for an
       emergency call.  This replacement of the original dial string
       should be based on local conventions, regulations, or preference
       (e.g., as in the case of an enterprise).

       Motivation: Any signaling protocol requires the use of some
       identifier to indicate the called party, and the user terminal may
       lack the capability to determine the actual emergency address
       (PSAP URI).

# We could just use the term PSAP URI instead of the emergency address 
here.

       The use of local conventions may be required as a
       transition mechanism.  Note: Such use complicates international
       movement of the user terminal. Evolution to a standardized
       emergency identifier or set of identifiers is preferred.

    Ma7.  Traceable resolution: The mapping protocol SHOULD support the
       ability of the mapping client to be able to determine the entity
       or entities which provided the emergency address resolution
       information.

# Here it would actually be better to write:
"... determine the entity or entities that computed the mapping."

       Motivation: It is important for public safety reasons, that there
       is a method to provide operational traceability in case of errors.

The term is used three times in the document and in all these cases it 
is not needed.

Ciao
Hannes

Andrew Newton wrote:
>>> Emergency address: The URI (e.g., SIP:URI, SIPS:URI, XMPP:URI, 
>>> IM:URI, etc.) which represents the address of the PSAP useful for the

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 05 May 2006 23:24:50 +0200

I like your definition, Ted. Now, we just need to make sure that it is 
used at the right places in the draft.

Btw, I think that it might be good to add the term 'sos service type' to 
draft-ietf-ecrit-requirements-08.txt as used in 
draft-ietf-ecrit-service-urn-02.txt.

draft-ietf-ecrit-service-urn-02.txt denotes each of the following 
strings as sos service types (at least I think so):

urn:service:sos
urn:service:sos.ambulance
urn:service:sos.animal-control
....
urn:service:sos.mental-health

To have a generic term for all these identifiers the term 'emergency 
identifier' seems to be appropriate.

Ciao
Hannes

PS: Let me know if I got totally confused.