Subject: RE: List services use case (was Re: [Ecrit] Re:CommmentsI.D-ecrit-service-urn-03 Child helpline)

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 19 May 2006 13:53:39 -0400

It is the "database somewhere" part that snags me.  
Will there be a pointer to that database as well?

Mike 

> -----Original Message-----
> From: Brian Rosen [mailto:[email-masked]] 
> Sent: Friday, May 19, 2006 1:27 PM
> To: Michael Hammer (mhammer); 'Henning Schulzrinne'
> Cc: [email-masked]; 'Thomson, Martin'
> Subject: RE: List services use case (was Re: [Ecrit] 
> Re:CommmentsI.D-ecrit-service-urn-03 Child helpline)
> 
> Yes, that's why we don't really care about the "shape" of the tree.
> The URNs are protocol elements; the "name" is not designed to 
> be shown to a user.  That's why I think there is a database 
> somewhere which has
> (localized) information on what these URNs mean.
> 
> The LoST mechanism merely gives you the list of services 
> available at the current location, which may be much smaller 
> than the list of all possible service URNs.
> 
> Brian
> 
> -----Original Message-----
> From: Michael Hammer (mhammer) [mailto:[email-masked]]
> Sent: Friday, May 19, 2006 1:06 PM
> To: Henning Schulzrinne; Brian Rosen
> Cc: [email-masked]; Thomson, Martin
> Subject: RE: List services use case (was Re: [Ecrit]
> Re:CommmentsI.D-ecrit-service-urn-03 Child helpline)
> 
> If I were French would I miss the difference between poison 
> and poisson?
> 
> There was a statement earlier that the urn's were protocol 
> elements not visible to the end-user.  
> Is that true or not? 
> 
> Mike
> 
> 
> > -----Original Message-----
> > From: Henning Schulzrinne [mailto:[email-masked]]
> > Sent: Friday, May 19, 2006 12:59 PM
> > To: Brian Rosen
> > Cc: [email-masked]; 'Thomson, Martin'
> > Subject: Re: List services use case (was Re: [Ecrit]
> > Re:CommmentsI.D-ecrit-service-urn-03 Child helpline)
> > 
> > I agree with Brian.
> > 
> > It seems quite common for GSM phones to show a text message 
> indicating 
> > "welcome to Teluristan; you can get concierge services at 
> *311 and can 
> > talk to our sales rep at *411." when roaming into a new country or 
> > service area. The problem with these messages is that they are not 
> > structured, so there is no easy way for them to be 
> integrated into the 
> > phone's address book, for example. With the service listing 
> proposed, 
> > this would be fairly straightforward. Given the generic URN service 
> > names, it would also make it easy to have symbols or 
> visitor-language 
> > descriptions on the phone. Thus, tourists could always 
> easily access 
> > the local version of the poison control center, for 
> example, even if 
> > they have no clue that they'd dial 1-800-222-1222 in the US 
> for that.
> > 
> > Henning
> > 
> > Brian Rosen wrote:
> > > I would imagine that there would be, somewhere, some kind
> > of a "pretty
> > > print" description of what these services are.  The phone
> > would access
> > > this along with the list of service urns available at their
> > location
> > > and offer an interesting GUI for what it finds.
> > > 
> > > Brian
> > > 
> > > -----Original Message-----
> > > From: Andrew Newton [mailto:[email-masked]]
> > > Sent: Friday, May 19, 2006 12:46 PM
> > > To: Brian Rosen
> > > Cc: 'Henning Schulzrinne'; [email-masked]; 'Thomson, Martin'
> > > Subject: Re: List services use case (was Re: [Ecrit] Re:
> > > CommmentsI.D-ecrit-service-urn-03 Child helpline)
> > > 
> > > Brian Rosen wrote:
> > >> While I can see some really smart phones trying to make
> > sense out of
> > >> the list, in my mind the purpose here is to develop a
> > COMPLETE list
> > >> of dial strings that need to be recognized and translated
> > into service URNs.
> > > 
> > > Exactly what "smart" thing would they do?
> > > 
> > > -andy
> > 
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> > 
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 19 May 2006 14:17:02 -0400

> Will there be a pointer to that database as well?

This information could easily be contained in the LoST record for the 
URN and location; I believe the current schema (where "current" is 
somewhat fuzzy...) contains such descriptive information.

Henning