Subject: RE: [Ecrit] Audio Codecs for 911 CALLS.

From: "Stark, Barbara" <[email-masked]>
Date: Tue, 8 Aug 2006 13:46:02 -0500

I suspect that if we were to not put A-law on an even par with mu-law, the world outside North America would be most unhappy and see this as yet another example of North American hubris. In fact, I have seen devices that supported only A-law and not mu-law (provided to me by a Korean vendor, who was unaware that mu-law was used by anybody). I've never seen a device that didn't support A-law.

If we don't treat these as equals, then we're opening up the debate that created the European A-law and North American mu-law all over again. I'd really rather just say that both must be supported, and preference is up to the device (which is generally set according to regional preferences).

By the way, my point was not that compressed codecs were more resilient to packet loss than 711, but that packet loss was more likely to occur when running a codec that needs 106kbps (711 at 20ms sampling on a PPPoE/ATM with LLC encoding connection), than one that (for example) requires about 64kbps (729a at 20ms sampling on PPPoE/ATM with LLC encoding), when the connection is at 128kbps upstream. Noise on this line might cause the connection rate to drop to, say, 100kbps, at which point 711 is definitely experiencing loss.
Barbara

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Tuesday, August 08, 2006 12:40 PM
> To: Andrew Newton
> Cc: 'Karihaloo, Ujjval'; [email-masked]
> Subject: Re: [Ecrit] Audio Codecs for 911 CALLS.
> 
> 
> Practically speaking, we're likely to have two classes of IP 
> end systems:
> 
> (1) residential and enterprise, all of which speak G.711 mu-law today;
> 
> (2) 3GPP and 3GPP2, which all support AMR (although I'm not 
> sure which 
> of the set of codecs in the AMR family are mandatory to support)
> 
> Thus, I don't see this as particularly hard. I see no need to support 
> A-law, unless somebody can show that there's a VoIP device out there 
> that only speaks A-law.
> 
> Also, it is not necessarily true that G.711 is more resilient against 
> packet loss than compressed codecs.
> 
> See http://www.globalipsound.com/datasheets/EG711.pdf for 
> some comparisons.
> 
> Clearly, we're using compressed codecs (G.729 and GSM-FR, primarily, 
> although I'm not sure what Sprint's CDMA network uses) today for 
> emergency calls, given that roughly half originate from cell phones.
> 
> Henning
> 
> Andrew Newton wrote:
> > 
> > On Aug 8, 2006, at 9:18 AM, Brian Rosen wrote:
> >> Do we not agree that forcing every PSAP to support every 
> codec that every
> >> carrier in its service area chooses makes no sense?  I'm 
> assuming we 
> >> can't
> >> just pick one ourselves and demand the carriers support that one, 
> >> right :)
> > 
> > A lot of "nots" in the sentence.  Yes, PSAPs ought to be 
> encouraged to 
> > support the codecs of the wireless carriers in the service area.
> > 
> >> Do we not agree that supporting compressed codecs other 
> than the native
> >> wireless codecs is a bad idea (they all do g.711 also)?
> > 
> > I really don't know about this.  I believe Barbara has a point.
> > 
> > Also, I've been told that 3GPP2 has settled on a codec that MUST be 
> > supported.
> > 
> > -andy
> > 
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 

*****

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from all computers. 163

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Raymond Forbes" <[email-masked]>
Date: Wed, 9 Aug 2006 10:18:02 +0100

I support Barbara, G.711 mu-law is only a requirement in North America.

If the IETF and Ecrit wants to develop a worldwide specification, the Rest 
of the World uses G.711 A-law coding. For example all PSAPS in the UK 
currently only support G.711 A-law encoding, and may optionally support 
AMR for more efficient interworking with GSM.

It is your choice but Ecrit RFCs will not change the encoding supported in 
PSAPs in the Rest of the World.

Regards,

Ray Forbes.

+44 24 7656 3106 phone
+44 24 7656 3816 fax.
+44 771 851 1361 Mobile/text
------------
This e-mail and any attachments are confidential.  If you are not the 
intended recipient, please notify us immediately by reply e-mail and then 
delete this message from your system. Do not copy this e-mail or any 
attachments, use the contents for any purpose, or disclose the contents to 
any other person: to do so could be a breach of confidence.

"Stark, Barbara" <[email-masked]>
08/08/2006 19:46
 
        To:     "Henning Schulzrinne" <[email-masked]>, "Andrew 
Newton" <[email-masked]>
        cc:     "Karihaloo, Ujjval" <[email-masked]>, 
[email-masked]
        Subject:        RE: [Ecrit] Audio Codecs for 911 CALLS.

I suspect that if we were to not put A-law on an even par with mu-law, the 
world outside North America would be most unhappy and see this as yet 
another example of North American hubris. In fact, I have seen devices 
that supported only A-law and not mu-law (provided to me by a Korean 
vendor, who was unaware that mu-law was used by anybody). I've never seen 
a device that didn't support A-law.

If we don't treat these as equals, then we're opening up the debate that 
created the European A-law and North American mu-law all over again. I'd 
really rather just say that both must be supported, and preference is up 
to the device (which is generally set according to regional preferences).

By the way, my point was not that compressed codecs were more resilient to 
packet loss than 711, but that packet loss was more likely to occur when 
running a codec that needs 106kbps (711 at 20ms sampling on a PPPoE/ATM 
with LLC encoding connection), than one that (for example) requires about 
64kbps (729a at 20ms sampling on PPPoE/ATM with LLC encoding), when the 
connection is at 128kbps upstream. Noise on this line might cause the 
connection rate to drop to, say, 100kbps, at which point 711 is definitely 
experiencing loss.
Barbara

*****

The information transmitted is intended only for the person or entity to 
which it is addressed and may contain confidential, proprietary, and/or 
privileged material. Any review, retransmission, dissemination or other 
use of, or taking of any action in reliance upon this information by 
persons or entities other than the intended recipient is prohibited. If 
you received this in error, please contact the sender and delete the 
material from all computers. 163