Subject: RE: [Ecrit] FW: [NENA-ltd] LoST

From: "Romascanu, Dan \(Dan\) " <[email-masked]>
Date: Sat, 2 Dec 2006 15:06:54 +0200

A similar discussion is happening in the NETCONF Working Group. 

Dan

> -----Original Message-----
> From: Andrew Newton [mailto:[email-masked]] 
> Sent: Saturday, December 02, 2006 3:44 AM
> To: Marc Linsner
> Cc: [email-masked]
> Subject: Re: [Ecrit] FW: [NENA-ltd] LoST
> 
> In the IETF RAI area, there is a strong consensus towards 
> moving toward Relax NG and away from XML Schema.  This is 
> also echoed by many of the members of the IETF's XML 
> Directorate, most notably Tim Bray -- one of the authors of XML.
> 
> To be even more specific, the experience within IETF 
> standards with XML Schema has exposed two recurring issues 
> that are solved by Relax
> NG:  1) The UPA restriction, and 2) readability of XSDs.
> 
> And to your specific points about existing IETF standards and 
> existing software:
> 
> 1) It is true that a lot of IETF standards use XML Schema.  
> That is due in part to the fact that XML Schema has been 
> around longer, but also of the mistaken belief that BCP 70 
> mandated the use of XML Schema in IETF RFCs.  BCP 70 actually 
> says no such thing, but this misperception existed for quite 
> some time until the XML Directorate made the clarification.
> 
> 2) At present, there does exist more software that uses XML 
> Schema than Relax NG.  But at one time there was also very 
> little software for XML Schema.  As Relax NG heads through 
> the ISO standardization process and more IETF standards 
> emerge that use Relax NG, more software supporting it will appear.
> 
> -andy
> 
> 
> 
> On Dec 1, 2006, at 12:18 PM, Marc Linsner wrote:
> 
> > The NENA Long Term Definition work group has been closely following 
> > the LoST work evidenced by early requirements Terry's 
> concerns a week 
> > or two ago.
> >
> > I again queried that group to see if they have any 
> outstanding issues 
> > with Terry's concerns, or any additional.  Hence I forwarded below 
> > (with
> > permission) Pierre's question about Relax NG.
> >
> > Thanks,
> >
> > -Marc-
> >
> > -----Original Message-----
> > From: Desjardins, Pierre [mailto:[email-masked]]
> > Sent: Friday, December 01, 2006 9:28 AM
> > To: Marc Linsner; [email-masked]
> > Subject: RE: [NENA-ltd] LoST
> >
> > Marc,
> >
> > I have no further issues with regards to Terry's concerns, 
> however I 
> > did voice a negative comment about the choice of RELAX NG as the 
> > schema language for defining LoST messages.
> >
> > I have been around XML for a very long time and this is not 
> about the 
> > merits of one schema language over another but rather about making 
> > life easier for future implementers.
> >
> > Like it or not, W3C XML Schema (WXS) is the mainstream XML schema 
> > language and it shows in the multiplicity and diversity of 
> tools out 
> > there (commercial or otherwise).
> >
> > The geopriv schemas were are all published using WXS which 
> I believe 
> > favored accelerated adoption. It seems to me that we all 
> want the same 
> > benefit for LoST.
> >
> > I am willing to help with putting a WXS version together -- 
> I may even 
> > be able to come up with a skeleton schema this weekend...
> >
> > What do you think?
> >
> > /Pier
> >
> > -----Original Message-----
> > From: [email-masked] 
> > [mailto:[email-masked]] On Behalf Of Marc Linsner
> > Sent: Friday, December 01, 2006 8:30 AM
> > To: [email-masked]
> > Subject: [NENA-ltd] LoST
> >
> > All,
> >
> > Sorry I couldn't make yesterday's call.
> >
> > I am curious if discussion took place wrt Terry's 
> questions/ concerns 
> > about LoST.  Is this community satisfied with responses to those 
> > concerns?  Are there still open issues?
> >
> >
> > Thanks,
> >
> > -Marc-
> > _______________________________________________
> > Nena-ltd mailing list
> > [email-masked]
> > https://lists.cs.columbia.edu/cucslists/listinfo/nena-ltd
> >
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Sat, 2 Dec 2006 16:52:20 -0500

And what is their conclusion?

Andy's answer is a bit troubling.  We're not XML developers, XML is a "tool"
(distinguishing from the tools we use with XML) to us.  We get disadvantaged
when we are early adopters of new XML thingies.  The XML development tools
probably matter more than the UPA restriction, and readability is in the eye
of the beholder: to anyone who has been looking at XML schemas for the last
several years, Relax NG is definitely not more readable.  Now, I wouldn't
really use the latter as an excuse to NOT switch to a new form, because that
would keep us on obsolete tools, but it is also not a compelling reason to
switch.

I had thought the development tools were okay with Relax NG.  If that is not
the case, then I question whether we should be using it.

Brian

> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> Sent: Saturday, December 02, 2006 8:07 AM
> To: Andrew Newton; Marc Linsner
> Cc: Andy Bierman; [email-masked]
> Subject: RE: [Ecrit] FW: [NENA-ltd] LoST
>

---

From: Andrew Newton <[email-masked]>
Date: Sat, 2 Dec 2006 17:50:00 -0500

The tool issue is a bit of FUD, IMO.  It is still possible to use SAX  
or DOM or pull APIs just like with XML Schemas and DTDs and all the  
other types XML schema languages.  There is nothing about Relax NG  
that requires an implementation to use a special XML parser.  The  
tools people are talking about are normally code generators, which  
are usually the hallmark of sloppy programming practices (my opinion,  
but I've seen it a lot).  I certainly would hope that anyone serious  
about fielding LoST knows how XML works and does not have to rely on  
such crutches.  I've had no trouble finding tools for validation.   
And both my desktop XML editors support Relax NG, one supporting it  
much better than XML Schema.

BTW, regarding your statement about "We're not XML developers."   
Well, you better understand it.  Just like you better have an  
understanding of how TCP/IP works too.  Or would you prefer that  
people writing software be able to stand behind statements like  
"We're not Internet applications developers."

-andy

---

From: "Desjardins, Pierre" <[email-masked]>
Date: Mon, 4 Dec 2006 11:21:02 -0500

For better or worst, XML Schema is an integral and valuable component of
many other XML technology standards and is leveraged in all important
web services development & delivery platforms. Editor and validator
availability is but one aspect of the more general issue -- how the
schema language integrates with other XML-based technologies is what
counts when we are talking about encouraging implementations -- which is
by no means LoST specific.

/Pier

-----Original Message-----
From: Andrew Newton [mailto:[email-masked]] 
Sent: Saturday, December 02, 2006 5:50 PM
To: Brian Rosen
Cc: 'Andy Bierman'; [email-masked]
Subject: Re: [Ecrit] FW: [NENA-ltd] LoST

The tool issue is a bit of FUD, IMO.  It is still possible to use SAX or
DOM or pull APIs just like with XML Schemas and DTDs and all the other
types XML schema languages.  There is nothing about Relax NG that
requires an implementation to use a special XML parser.  The tools
people are talking about are normally code generators, which are usually
the hallmark of sloppy programming practices (my opinion, but I've seen
it a lot).  I certainly would hope that anyone serious about fielding
LoST knows how XML works and does not have to rely on  
such crutches.  I've had no trouble finding tools for validation.   
And both my desktop XML editors support Relax NG, one supporting it much
better than XML Schema.

BTW, regarding your statement about "We're not XML developers."   
Well, you better understand it.  Just like you better have an
understanding of how TCP/IP works too.  Or would you prefer that people
writing software be able to stand behind statements like "We're not
Internet applications developers."

-andy

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 4 Dec 2006 12:03:19 -0500

I checked with our developers.  We use xerces, gSOAP and xmlspy.  None of
them support Relax NG as far as I can determine.

Brian

> Cc: 'Romascanu, Dan (Dan) '; 'Marc Linsner'; 'Andy Bierman';
> [email-masked]

---

From: Andrew Newton <[email-masked]>
Date: Mon, 4 Dec 2006 13:38:43 -0500

On Dec 4, 2006, at 11:21 AM, Desjardins, Pierre wrote:
> Editor and validator
> availability is but one aspect of the more general issue...

Actually, if validation isn't THE issue, I fail to see what the big  
deal is.  Even then, validation is not necessary.

On Dec 4, 2006, at 12:03 PM, Brian Rosen wrote:

> We use xerces, gSOAP and xmlspy.

There's nothing stopping you from using Xerces to parse well-formed  
XML defined with Relax NG.  I don't know gSOAP, but it sounds like a  
SOAP stack and we are not using SOAP.  However, your professional  
software engineers may want to consult with the grad students at  
Columbia who report success in this area.  And regarding XMLSpy, what  
a pity that such expensive commercial software does not support a  
feature its much less expensive brethren have supported for years.

The high and low of it is this:  The switch to Relax NG was made  
quite some time ago.  It was in the issue tracker, called out in  
release notes, and discussed in our meetings.  Our methodology has  
even been run by the IETF's XML Directorate to help ensure no late  
surprises.  This is an issue that has been put to bed.  It is not  
worth re-opening and delaying the spec further unless somebody can  
come up with a very specific issue.  There is absolutely no reason  
why any competent developer cannot take an XML compliant parser and  
use it to parse LoST XML as it is defined right now.

-andy