Subject: [Ecrit] Little LoST Nits

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 11 Dec 2006 16:45:17 -0600

Related to the use of geodetic/GML objects in LoST, there are several bugs.

 - Drop the <position> element.  It is unnecessary in this context, particularly if you have Polygon at the same level.

 - The CRS URNs are missing colons.  They should be "urn:ogc:def:crs:EPSG::4326".

 - The three dimensional CRS is not necessary for a 2D profile, drop 4979 for 4326.

 - You haven't allowed for more than one point in the LinearRing.  There should be a minimum of 4 <pos> elements.

 - The <pos> element should use a more constrained type.  This should be a list of doubles.  (Simple type definition is the one place where RelaxNG concedes to XML Schema.)

Cheers,
Martin 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Andrew Newton <[email-masked]>
Date: Mon, 11 Dec 2006 20:31:47 -0500

Martin,

Comments in-line:

On Dec 11, 2006, at 5:45 PM, Thomson, Martin wrote:

>  - Drop the <position> element.  It is unnecessary in this context,  
> particularly if you have Polygon at the same level.

Quite right.

> "urn:ogc:def:crs:EPSG::4326".

Given the lack of NID registration, you should excuse me for not  
being able to find the correct syntax.  Where did you find it?  (And  
yes, I'm aware this is being worked on).

>  - The three dimensional CRS is not necessary for a 2D profile,  

Left over baggage from my attempt at doing 3d.  Fortunately, somebody  
wrote a geo-shapes docs that led me to believe I might never get it  
right.

>  - You haven't allowed for more than one point in the LinearRing.   
> There should be a minimum of 4 <pos> elements.

A simple oversight.  Agreed.

>  - The <pos> element should use a more constrained type.  This  
> should be a list of doubles.  (Simple type definition is the one  
> place where RelaxNG concedes to XML Schema.)

Again, left overs from where it might have supported two or three  
doubles.  I'll add the constraint.  (And you haven't seen cool unless  
you've read up on what you can do with RNG lists: http:// 
books.xmlschemata.org/relaxng/relax-CHP-7-SECT-9.html).

-andy

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 11 Dec 2006 20:21:27 -0600

Andy,

Thanks for the quick response.  Inline...

> yes, I'm aware this is being worked on).

<http://www.opengeospatial.org/standards/bp>
->
<http://portal.opengeospatial.org/files/?artifact_id=16339>

> wrote a geo-shapes docs that led me to believe I might never get it

;)

> (And you haven't seen cool unless
> you've read up on what you can do with RNG lists: <http://
> books.xmlschemata.org/relaxng/relax-CHP-7-SECT-9.html>).

That's neat.  Obviously the same constraints apply as do with elements - lists of mixed types are possible, which is something that XML Schema cannot do (perhaps for good reason, but the elegant simplicity of RelaxNG is still an advantage).  I just wish that they had added support for cardinality other than the set of {0, 1, 0+, 1+}.

M_T