Subject: [Ecrit] Fwd: I-D ACTION:draft-bakker-sipping-3gpp-ims-xml-body-handling-00.txt

From: "James M. Polk" <[email-masked]>
Date: Tue, 12 Feb 2008 14:51:15 -0600

forwarding for those of us who want to know of anything related to 
emergency calling, this ID has a relevant abstract for you...

>To: [email-masked]
>Cc:
>From: [email-masked]
>Subject: I-D ACTION:draft-bakker-sipping-3gpp-ims-xml-body-handling-00.txt
>Date: Tue, 12 Feb 2008 10:45:02 -0800 (PST)
>
>A New Internet-Draft is available from the on-line Internet-Drafts
>directories.
>
>         Title           : Specification of 3GPP IM CN Subsystem XML 
> body handling
>         Author(s)       : J. Bakker
>         Filename        : 
> draft-bakker-sipping-3gpp-ims-xml-body-handling-00.txt
>         Pages           : 8
>         Date            : 2008-2-12
>
>This document registers new disposition-types for the Content-
>    Disposition header that apply to the application/3gpp-ims+xml body
>    used by 3GPP, since Release 5.  The applicability of these content-
>    disposition values are limited to 3GPP IMS.  The application/
>    3gpp-ims+xml body has the following two distinct uses: (1) for
>    redirecting the emergency session to use a different domain (e.g.
>    using a Circuit Switched call), and (2) for delivering user profile
>    specific information from the SIP registrar to an Application Server.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-bakker-sipping-3gpp-ims-xml-body-handling-00.txt
>
>To remove yourself from the I-D Announcement list, send a message to
>[email-masked] with the word unsubscribe in the body of
>the message.
>You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
>to change your subscription settings.
>
>Internet-Drafts are also available by anonymous FTP. Login with the
>username "anonymous" and a password of your e-mail address. After
>logging in, type "cd internet-drafts" and then
>"get draft-bakker-sipping-3gpp-ims-xml-body-handling-00.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>         [email-masked].
>In the body type:
>         "FILE 
> /internet-drafts/draft-bakker-sipping-3gpp-ims-xml-body-handling-00.txt".
>
>NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
>
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>
>Content-Type: text/plain
>Content-ID: <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-bakker-sipping-3gpp-ims-xml-body-handling-00.txt
>
>
><ftp://ftp.ietf.org/internet-drafts/draft-bakker-sipping-3gpp-ims-xml-body-handling-00.txt>
>_______________________________________________
>I-D-Announce mailing list
>[email-masked]
>http://www.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
Ecrit mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 12 Feb 2008 23:00:08 +0200

Hi James,

Thanks for pointing me to this document since I was not aware of this work.
Tomorrow is the 3GPP - IETF conference call. I will try to learn a bit 
about the history of it.

Ciao
Hannes

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 12 Feb 2008 15:05:10 -0600

At 03:00 PM 2/12/2008, Hannes Tschofenig wrote:
>Tomorrow is the 3GPP - IETF conference call.

good timing then -- excellent!

>I will try to learn a bit about the history of it.

cool, since this seems to be a little different than most things out 
there, can you provide a note to the WG (or just to me) with what you find out?

>>>         Title           : Specification of 3GPP IM CN Subsystem 
>>> XML body handling
>>>         Author(s)       : J. Bakker
>>>         Filename        :

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 12 Feb 2008 23:08:49 +0200

Sure. I will post my summary of the chat since emergency calling is 
again on the agenda for tomorrows call.

Ciao
Hannes

James M. Polk wrote:
>>>> Subject: I-D 
>>>> ACTION:draft-bakker-sipping-3gpp-ims-xml-body-handling-00.txt
>>>> FILE 
>>>> /internet-drafts/draft-bakker-sipping-3gpp-ims-xml-body-handling-00.txt 
>>>>
>>>>
>>>>

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 14 Feb 2008 11:45:49 +0200

So, I got some information regarding this document.

In early work on IMS emergency services (Release 5) the 3GPP decided to 
use a Circuit Switched call for their emergency calls. However, there 
are failure cases where the call is still placed on the packet based IMS 
and the proxy indicates that the mobile phone has to use CS instead.

As such, this is somewhat old work done by the 3GPP (and even 
implemented) but they forgot to make the IANA registration.

Hence, this document makes this IANA registration.

Ciao
Hannes