Subject: [Ecrit] AI for SOS Parameter

From: "Hannes Tschofenig" <[email-masked]>
Date: Wed, 11 Nov 2009 13:43:55 +0900

During the meeting we had a discussion about the error cases for the SOS
parameter document. 

Here is the issue. 

What happens if a SIP UA uses the parameter defined in this document but
contacts a registrar that does not understand this extension. The fear was
the mechanism defined in this document leads to undesireable outcome. 

Ciao
Hannes

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 11 Nov 2009 12:51:01 +0800

Specifically:  the device does not know that the registrar understood the parameter.

Text is desired that will document that this is the case, making it clearer that the purpose of the parameter is for the consumption of the registrar only - so that it can apply different policy (i.e. allow the registration even though the user might not be fully paid up).

Cullen's concern relates to whether this is a desirable attribute of the solution and whether there might be cases where the device could be given a false impression:

The specific scenario is where the registration is accepted by a registrar that does not support the extension.  If the UA then assumes that - because its emergency registration was accepted - that an emergency call will be permitted, the net effect might be a failed emergency call.

I'm not overly concerned about this problem - as long as we make it clear that a call is not guaranteed to work if the registration succeeds, for many reasons, including the sorts of policy things that this emergency registration is intended to wave aside.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Hannes Tschofenig
> Sent: Wednesday, 11 November 2009 1:44 PM
> To: [email-masked]
> Subject: [Ecrit] AI for SOS Parameter
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit