Subject: [Ecrit] AI for ECRIT Direct

From: "Hannes Tschofenig" <[email-masked]>
Date: Wed, 11 Nov 2009 13:45:05 +0900

We had a lot of discussion on this topic on the list and during the meeting.

There are two issues: 

A) The technical aspects of how to deal with SIP signaling exchanges when
there is no VSP/ASP involved. As I mentioned in my other mail there is a
relationship to the work in the unauthenticated draft. 

B) Deployment policy on whether calls would be routed with or without (the
Xbox example) involvement of the VSP in the emergency call exchange. There
are regulatory issues, migration aspects, and many security challenges
involved. 

I believe we need a solution for (A). The hard part is (B): Making progress
on (B) will be impacted by our judgement of trustworthy location vs. the
value of identity, as discussed in
http://tools.ietf.org/id/draft-tschofenig-ecrit-trustworthy-location-02.txt.
So, I suggest to finally get our head around this issue first. 

Other suggestions? 
 
Ciao
Hannes

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 11 Nov 2009 12:47:15 +0800

Hi Hannes,

I don't believe that the trustworthy location element comes into play here.
I believe that there is a relationship between this and the unauthenticated draft, but only in some scenarios, certainly not all scenarios.

Cheers
James

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Hannes Tschofenig
> Sent: Wednesday, 11 November 2009 3:45 PM
> To: [email-masked]
> Subject: [Ecrit] AI for ECRIT Direct
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 11 Nov 2009 12:56:38 +0800

I think that the point is that the concerns that were raised were not applicable to this specific draft.  We're actually discussing problems that exist with the system as a whole.

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Winterbottom, James
> Sent: Wednesday, 11 November 2009 1:47 PM
> To: Hannes Tschofenig; [email-masked]
> Subject: Re: [Ecrit] AI for ECRIT Direct
> 
> Hi Hannes,
> 
> I believe that there is a relationship between this and the
> unauthenticated draft, but only in some scenarios, certainly not all
> scenarios.
> 
> Cheers
> James
> 
>

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 11 Nov 2009 12:57:57 +0800

In that case it seems to me that either we hold back all work until it is solved, or we can allow all work to proceed.

Cheers
James

> From: Thomson, Martin
> Sent: Wednesday, 11 November 2009 3:57 PM
> To: Winterbottom, James; Hannes Tschofenig; [email-masked]
> Subject: RE: [Ecrit] AI for ECRIT Direct
> 
> I think that the point is that the concerns that were raised were not
> applicable to this specific draft.  We're actually discussing problems
> that exist with the system as a whole.
>

---

From: "Bernard Aboba" <[email-masked]>
Date: Tue, 10 Nov 2009 22:03:37 -0800

I'd agree with Martin on this.  

While I certainly understand the potential security issues involved in ECRIT
Direct, the same set of issues also exist with enabling the PSAPs to
interconnect with any VSP on the planet.  

So while I can understand Brian's assertion that ECRIT Direct would be
difficult to implement securely, I take that as a tacit admission that
interconnection of PSAPs with all VSPs is also difficult to implement
securely.  

What bothers me most about this is that is seems to be yet another symptom
of Cullen's comment on "revisionitis".  These are very basic questions --
and if we haven't answered them yet and are having these kind of discussions
now, I shudder to think about what these discussions will be like once we
actually try to deploy this and try to figure out how to secure it.  

In some ways, the difficulty of this problem makes some of the "smart grid"
security discussions look simple by comparison.  At least in those scenarios
we don't have an expectation that anyone should be able to read the home
meter or gain access to a nuclear power plant.  The closest analogy I can
come up with is the problems we've had with SPAM -- and we know how that one
turned out.   

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Thomson, Martin
Sent: Tuesday, November 10, 2009 8:57 PM
To: Winterbottom, James; Hannes Tschofenig; [email-masked]
Subject: Re: [Ecrit] AI for ECRIT Direct

I think that the point is that the concerns that were raised were not
applicable to this specific draft.  We're actually discussing problems that
exist with the system as a whole.

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Wed, 11 Nov 2009 15:44:24 +0900

Hi James, 

>I don't believe that the trustworthy location element comes 

The important sticking point seems to be security in this discussion. 
The trustworthy location is about security of location vs. identity. 

>unauthenticated draft, but only in some scenarios, certainly 
>not all scenarios.
The technical text in the unauthenticated draft (see Section 7) is very
similar to the solution in ECRIT direct (with some delta). 

The arguments on why these things are different in the two docs.  

Ciao
Hannes

>> Of Hannes Tschofenig
>> A) The technical aspects of how to deal with SIP signaling exchanges 
>> when there is no VSP/ASP involved. As I mentioned in my other mail 
>> there is a relationship to the work in the unauthenticated draft.
>> 
>> B) Deployment policy on whether calls would be routed with 
>or without 
>> (the Xbox example) involvement of the VSP in the emergency call 
>> exchange. There are regulatory issues, migration aspects, and many 
>> security challenges involved.
>> 
>> I believe we need a solution for (A). The hard part is (B): Making 
>> progress on (B) will be impacted by our judgement of trustworthy 
>> location vs. the value of identity, as discussed in