Subject: [Ecrit] draft-ietf-ecrit-psap-callback

From: Cullen Jennings <[email-masked]>
Date: Sun, 7 Nov 2010 15:51:45 -0700

The part of this problem I find particularly interesting about call back is the authorization. I can't tell if this draft is proposing PAI, Identity, SAML Traits, or Tokens. I don't really see how any of them work but it seems like this should be a big topic of discussion if this draft is going to make any progress.

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 8 Nov 2010 01:35:03 +0100

Hi Cullen, 

sorry if the draft did not make the approach clear. 

It decouples three elements: 

a) marking 
b) authentication and identity handling 
c) authorization

For (a) a scheme is described in the document. There is a bug in there but I will fix it with a draft update today. 

For (b) we suggest to re-use PAI and SIP Identity

For (c) the draft discusses two possible approaches, namely to use the authenticated identity for authorization or a trait. On the latter aspect, the draft does not define a solution using SIP SAML at the moment. 

Ciao
Hannes

On Nov 7, 2010, at 11:51 PM, Cullen Jennings wrote:

> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit