Subject: [Ecrit] draft-ietf-ecrit-trustworthy-location and who can sign location

From: Cullen Jennings <[email-masked]>
Date: Sun, 7 Nov 2010 15:52:16 -0700

Enterprises could operate a LIS for wireline phones or wifi phones in the enterprise - would they be able to get a cert rooted in VESA to sign location?

---

From: Bernard Aboba <[email-masked]>
Date: Sun, 7 Nov 2010 16:21:03 -0800

The statements in NENA i2 would seem to imply that any LIS would be able to obtain a certificate chaining to a VESA trust anchor, to enable signing of location. 

However,  I am not aware of a document that provides details of the certificates, hierarchy, issuance policies, revocation, etc. so as to allow this to become operational (e.g. by sub-contracting to a vendor with experience in this area). 

> From: [email-masked]
> Date: Sun, 7 Nov 2010 15:52:16 -0700
> To: [email-masked]
> Subject: [Ecrit] draft-ietf-ecrit-trustworthy-location and who can sign	location
> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 9 Nov 2010 02:23:02 -0700

The reason I asked is because it seem like if the CA will give certs to pretty much anyone, then this security approach does not work, and if the certs are not easy for an enterprise to get then the approach also won't work because it won't be used. I understand this is a bit outside of ECRIT work but seems like a tricky line to thread.

---

From: Brian Rosen <[email-masked]>
Date: Tue, 9 Nov 2010 09:51:24 -0500

It's conceivable that this could be made to work, only because it's possible that the local PSAP would have knowledge of local enterprises and could vouch for the authenticity of the enterprise.  Mechanizing this might be difficult however.

I've long thought that we should have more extensive testing mechanisms.  At least in the U.S., every substantial enterprise is visited regularly by a fire marshal.  If the fire marshal could easily place a test call that verified all the bits were working, that would help a lot.  We do have a big part of that in the -phonebcp spec.  The test call could validate the credential of the enterprise if we could reasonably validate that it was the fire marshal placing the test call.

Brian

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 9 Nov 2010 12:29:57 -0800

The issuance policy for the LIS certificate would need to be ironed out to understand how this could work. this would be part of a suite of documents describing the operation of the Certificate Authority.  As Brian notes, leveraging the fire marshall visit or related building documents could decrease or perhaps eliminate the need for an in-person visit.  However, typical verification operations of a public CA would be likely to apply here, in addition to any special requirements for LIS certificate issuance, so that the operation is likely to be non-trivial in terms of cost. 

  In practice, this policy is part of a document set that defines the operation of the Certificate Authority.  

> Subject: Re: [Ecrit] draft-ietf-ecrit-trustworthy-location and who can sign location
> From: [email-masked]
> Date: Tue, 9 Nov 2010 09:51:24 -0500
> CC: [email-masked]; [email-masked]
> To: [email-masked]
>

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 19 Nov 2010 09:32:00 -0700

Brian & Bernard - thanks. Makes sense.