Subject: [Ecrit] Spencer Dawkins' No Objection on draft-ietf-ecrit-additional-data-34: (with COMMENT)

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 02 Sep 2015 20:22:50 -0700

Spencer Dawkins has entered the following ballot position for
draft-ietf-ecrit-additional-data-34: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ecrit-additional-data/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I note that Stephen hasn't cleared his Discuss yet, so I'll let that play
out (and thanks to all who are busily Discussing it), but just for the
record, I'm also confused between 

   The intent
   is that every emergency call carry the information described here
   using the mechanisms described here.

and (paraphrasing)

"we aren't the experts on extending this mechanism, and we can't say who
is, but there's more than one set of experts"

This tussle sounds like a fork waiting to happen.

Is that going to be a problem? One answer could be "if it is, we aren't
the ones who are going to have to solve it", but I thought I'd ask.

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 Sep 2015 13:18:58 +0000

Not every call has every block.  There is only one block that is required, which is “who sent the data”.  That block includes contact info.  We want every entity to handles the call to supply at least that block.  If you have more info, please send it, but at least tell me how to contact you.  This corresponds to the current mechanisms in North America and elsewhere: mobile networks only supply the identity of the network operator handling the call, wireline networks supply that and also a subscriber name/address. 

The extension is additional blocks of data, and we have to allow others to define blocks.  Many of those blocks wouldn’t make sense for, as an example, a carrier to provide.  Others might not make sense for anyone except, say, an enterprise to supply.

Brian

> On Sep 2, 2015, at 11:22 PM, Spencer Dawkins <[email-masked]> wrote:
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 3 Sep 2015 08:37:35 -0500

Hi, Brian,

On Thu, Sep 3, 2015 at 8:18 AM, Rosen, Brian <[email-masked]>
wrote:

> Not every call has every block.  There is only one block that is required,
> which is “who sent the data”.  That block includes contact info.  We want
> every entity to handles the call to supply at least that block.  If you
> have more info, please send it, but at least tell me how to contact you.
> This corresponds to the current mechanisms in North America and elsewhere:
> mobile networks only supply the identity of the network operator handling
> the call, wireline networks supply that and also a subscriber name/address.
>
> The extension is additional blocks of data, and we have to allow others to
> define blocks.  Many of those blocks wouldn’t make sense for, as an
> example, a carrier to provide.  Others might not make sense for anyone
> except, say, an enterprise to supply.

Thanks for the quick feedback.

I see the problem - I should be reading

   The intent

as

   The intent
   is that every emergency call *that carries* the information described
here
   *uses* the mechanisms described here.

and doesn't go off the reservation and send it some other way.

Am I getting that right?

Thanks,

Spencer

> > Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 Sep 2015 14:30:13 +0000

Well, sort of.  We really do want every emergency call to at least have that identity block.

We’ll need to edit the text to say more clearly what we mean.  I see two ways to edit:
…every emergency call carry at least some of the information….

or
..every provider in the path of the call provide at least some of the information …

Brian

On Sep 3, 2015, at 9:37 AM, Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>> wrote:

Hi, Brian,

On Thu, Sep 3, 2015 at 8:18 AM, Rosen, Brian <[email-masked]<mailto:[email-masked]>> wrote:
Not every call has every block.  There is only one block that is required, which is “who sent the data”.  That block includes contact info.  We want every entity to handles the call to supply at least that block.  If you have more info, please send it, but at least tell me how to contact you.  This corresponds to the current mechanisms in North America and elsewhere: mobile networks only supply the identity of the network operator handling the call, wireline networks supply that and also a subscriber name/address.

   The intent

as

   The intent
   is that every emergency call *that carries* the information described here
   *uses* the mechanisms described here.

Am I getting that right?

Thanks,

Spencer

Brian

> On Sep 2, 2015, at 11:22 PM, Spencer Dawkins <[email-masked]<mailto:[email-masked]>> wrote:
>
> [email-masked]<mailto:[email-masked]>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 3 Sep 2015 10:38:31 -0500

Hi, Brian,

> ..every provider in the path of the call provide at least some of the

At this point, it sounds like you're poised to Do The Right Thing. Thanks!

>
> Brian
>
>
>
> On Sep 3, 2015, at 9:37 AM, Spencer Dawkins at IETF <
> [email-masked]> wrote:
>
> Hi, Brian,
>
>> Not every call has every block.  There is only one block that is
>> required, which is “who sent the data”.  That block includes contact info.
>> We want every entity to handles the call to supply at least that block.  If
>> you have more info, please send it, but at least tell me how to contact
>> you.  This corresponds to the current mechanisms in North America and
>> elsewhere: mobile networks only supply the identity of the network operator
>> handling the call, wireline networks supply that and also a subscriber
>> name/address.
>>
>> The extension is additional blocks of data, and we have to allow others
>> to define blocks.  Many of those blocks wouldn’t make sense for, as an

---

From: Randall Gellens <[email-masked]>
Date: Wed, 16 Sep 2015 12:54:41 -0700

Either "at least some" or "as much ... as
possible"?

So,

OLD:

The intent is that every emergency call carry
the

information described here using the mechanisms
described here.

NEW:

The intent is that every emergency call carry at
least some of

the information described here using the mechanisms
described

here.

OR:

The intent is that every emergency call carry as
much as possible

of the information described here using the mechanisms
described

here.

At 2:30 PM +0000 9/3/15, Brian Rosen wrote:

Well, sort of.  We really do want
every emergency call to at least have that identity
block.

We'll need to edit the text to say more
clearly what we mean.  I see two ways to edit:

Ševery emergency call carry at least
some of the informationŠ.

or

..every provider in the path of the call
provide at least some of the information Š

Brian

On Sep 3, 2015, at 9:37 AM, Spencer
Dawkins at IETF <[email-masked]> wrote:

Hi, Brian,

On Thu, Sep 3, 2015 at 8:18 AM, Rosen,
Brian <[email-masked]>
wrote:

Not every call has every block.  There is only one
block that is required, which is "who sent the data".  That
block includes contact info.  We want every entity to handles the
call to supply at least that block.  If you have more info,
please send it, but at least tell me how to contact you.  This
corresponds to the current mechanisms in North America and elsewhere:
mobile networks only supply the identity of the network operator
handling the call, wireline networks supply that and also a subscriber
name/address.

The extension is additional blocks of data, and we have to allow
others to define blocks.  Many of those blocks wouldn't make
sense for, as an example, a carrier to provide.  Others might not
make sense for anyone except, say, an enterprise to supply.

Thanks for the quick
feedback.

I see the problem - I should be
reading

The intent

is that every emergency call carry the information
described here

as

The intent

is that every emergency call *that carries* the
information described here

and doesn't go off the reservation and
send it some other way.

Am I getting that right?

Thanks,

Spencer

Brian

--

Randall Gellens

Opinions are personal;    facts are
suspect;    I speak for myself only

-------------- Randomly selected tag: ---------------

"When I use a word," Humpty Dumpty said, in a rather scornful

tone, "it means just what I choose it to mean -- neither more nor less.

"The question is," said Alice, "whether you can make words mean

so many different things."

"The question is," said Humpty Dumpty, "which is to be master  --

that's all."