Subject: Re: [Ecrit] AD evaluation: draft-ietf-ecrit-held-routing-03

From: Alissa Cooper <[email-masked]>
Date: Fri, 4 Dec 2015 09:20:39 -0800

What is the status of this? Does anyone else have an opinion?

Thanks,
Alissa

> On Nov 21, 2015, at 12:36 AM, James Winterbottom <[email-masked]> wrote:
> 
> Hi Alissa,
> 
> I think the only comment of yours that I didn’t comment on was the one surrounding the LIS understanding the new option but not being able to provide routing information.
> 
> When we were originally writing the document we came to this scenario and found three options:
> 	1) Just return location and ignore the routing request (this is what the document currently says)
> 	2) Pass something back, anything
> 	3) Pass something back and say, but indicate it may not be the droid they are looking for (LoST allows for this approach with the defaultMappingReturned warning).
> 
> The original reason for going with 1 was simplicity. If you requested routing, got nothing you would try LoST. Similarly if you requested routing and got a response saying, “eh, not sure, try this one”, then the requestor would probably try LoST anyway. I guess that with 3, at least the requestor has something.
> 
> If there is general agreement, then I will add an attribute to the routingInformation element that can indicate if it is default or not, and require the LIS to always respond with something if it understands the extension.
> 
> 
> Cheers
> James
> 
> 
> 
>>>> 
>> 
>

---

From: James Winterbottom <[email-masked]>
Date: Sat, 5 Dec 2015 05:18:24 +1100

Hi Alissa,

I have most of the changes ready to go.
I just wanted a bit more feed back on this one because it changes the XML (obviously), needs an example, and will change a subsequent requirement variation in RFC 6881.

If I don’t here back very soon I will make the changes anyway and press on.

Cheers
James

> On 5 Dec 2015, at 4:20 am, Alissa Cooper <[email-masked]> wrote:
>