Subject: [Ecrit] I-D Action: draft-ietf-ecrit-lost-planned-changes-02.txt

From: [email-masked]
Date: Tue, 23 Oct 2018 12:08:09 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Emergency Context Resolution with Internet Technologies WG of the IETF.

        Title           : Validation of Locations Around a Planned Change
        Author          : Brian Rosen
	Filename        : draft-ietf-ecrit-lost-planned-changes-02.txt
	Pages           : 17
	Date            : 2018-10-23

Abstract:
   This document defines an extension to LoST (RFC5222) that allows a
   planned change to the data in the LoST server to occur.  Records that
   previously were valid will become invalid at a date in the future,
   and new locations will become valid after the date.  The extension
   adds two elements to the <findservice> request: A URI to be used to
   inform the LIS that previously valid locations will be invalid after
   the planned change date, and add a date which requests the server to
   perform validation as of the date specified.  It also adds an
   optional Time-To-Live element to the response, which informs clients
   about the current expected lifetime of the validation.  This document
   also provides a conventional XML schema for LoST, as backwards
   compatible alternative to the RelaxNG schema in RFC5222

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ecrit-lost-planned-changes/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ecrit-lost-planned-changes-02
https://datatracker.ietf.org/doc/html/draft-ietf-ecrit-lost-planned-changes-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ecrit-lost-planned-changes-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian Rosen <[email-masked]>
Date: Tue, 23 Oct 2018 15:10:50 -0400

I have refreshed this draft and think it is ready for publication.  Note that the biggest remaining item was finished in -01 which was the replacement XML schema for LoST, as well as an XML extension schema for this document.

Oh rats, I forgot to credit Peter St Andre for helping with the review of the schemas.  I will get that done before publication.

Brian

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: I-D Action: draft-ietf-ecrit-lost-planned-changes-02.txt
> Date: October 23, 2018 at 3:08:09 PM EDT
> To: <[email-masked]>
> Cc: [email-masked]
> Reply-To: [email-masked], [email-masked]
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Brian Rosen <[email-masked]>
Date: Tue, 23 Oct 2018 15:29:19 -0400

It occurs to me that since this draft includes a new schema for LoST it probably ought to update 5222.  It doesn’t claim to do that.  Should it?

Brian

> On Oct 23, 2018, at 3:10 PM, Brian Rosen <[email-masked]> wrote:
> 
>> From: [email-masked] <mailto:[email-masked]>
>> To: <[email-masked] <mailto:[email-masked]>>
>> Cc: [email-masked] <mailto:[email-masked]>
>> Reply-To: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
>> 
>> 
>> https://datatracker.ietf.org/doc/draft-ietf-ecrit-lost-planned-changes/ <https://datatracker.ietf.org/doc/draft-ietf-ecrit-lost-planned-changes/>
>>