Subject: AS2 Port Issues

From: "Redick, Jeffrey A" <[email-masked]>
Date: Wed, 29 Jun 2005 18:02:53 -0400

AS2 Standards Community,

There is a long standing port usage issue that AS2 implementers have
been dealing with for some time now.  Many companies  restrict outbound
ports on their Internet facing firewalls for security reasons.  The fact
that there is no well known or recommended port for AS2 implementations
continues to be a problem.  Every AS2 implementer is making up their own
port assignments and requiring their trading partners to use them.  AS2
implementations are making firewalls look like pieces of Swiss cheese.
Firewall security personnel are hopping mad about this issue and can't
understand why this is happening.  We try to explain why we need to keep
opening more ports to them but, quite frankly, we don't understand why
there isn't at least a recommended port or port range for this
technology either.  The attached email dialog between two AS2
administrators is a typical exchange when trying to set up a new
connection (I removed the last names and company names for the sake of
privacy).  Can someone explain why having a range of recommended ports
for AS2 implementations is such an issue?

Regards,
Jeff Redick
Engineering Manager
MS 3O
1075 W. Entrance Dr.
Auburn Hills, MI   48326
 
Phone: 248-364-5826 (8-351)
Email:  mailto:[email-masked]

>John,
 
> Unfortunately, that is the only port opened to our AS2 server. We have
the same issues with opening ports on our
> firewall. FYI, our engineers have been pushing the AS2 governing
bodies to come up with a standard AS2 port, to no
> avail. I don't have the authorization or ability to open additional
ports.

>Rick 

>>-----Original Message-----
>>From: John 
>>Sent: Tuesday, June 28, 2005 5:55 PM
>>To: Richard
>>
>>Subject: Fwd: RE: AS2 Setup Contact and Form

>>Richard,
 
>>I am the firewall admin for xxxxx.  It is my job to setup the AS2
communications.   We are under strict compliance with
>>Sarbanes-Oxley, HIPPA and VISA Security guidelines to limit the number
of ports off our firewall.   Therefore,  we would
>> like you to open port 4080 or 4079 for xxxxx communication to xxxxx
on your inbound side.
 
>>Thanks,
>>John

---

From: "Kyle Meadors" <[email-masked]>
Date: Thu, 30 Jun 2005 15:01:57 -0500

I have heard of similar concerns. Based on feedback I have received, it
appears the typical ports used are either 80, 4080, 5080 or 8080, with 4080
being the most common. But various port values get used.

Should we attempt to get port 4080 or another port assigned as a IANA
registered port? 

Kyle Meadors
DGI

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Redick, Jeffrey A
Sent: Wednesday, June 29, 2005 5:03 PM
To: [email-masked]
Subject: AS2 Port Issues

AS2 Standards Community,

Regards,
Jeff Redick
Engineering Manager
MS 3O
1075 W. Entrance Dr.
Auburn Hills, MI   48326

 
ports.

 
on your inbound side.

-- 
No virus found in this incoming message.
Checked by AVG Anti-Virus.
Version: 7.0.323 / Virus Database: 267.8.6/33 - Release Date: 6/28/2005

-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.323 / Virus Database: 267.8.6/33 - Release Date: 6/28/2005