Subject: Re: [Edm] Implementation status tag name: please bikeshed!

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 2 Mar 2022 21:23:28 +0000

On Feb 18, 2022, at 12:41 PM, Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>> wrote:

Thanks to everyone who provided feedback via email and GitHub.

David and I discussed, and I think we’d like to go with:
- Tag name: “related_implementations”
- Display name: "Related Implementations”

Works for me.

Robert, could you get that added?

Is there a need for an enhancement request to be entered for this, and if so, what is the mechanism for does so?
I am curious as to the time frame this functionality might be added and if there will be an opportunity to try it out during the IETF 113 Hackathon.

Cheers,
Charles

Best,
Tommy

On Feb 4, 2022, at 9:58 AM, Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>> wrote:

At out last call, we discussed adding a single tag that WG chairs and document authors could use to point to a resource for implementation status/info/guidance/code or interop testing.

The question is what the tag name should be! This is a bikeshed, but we should decide on something before IETF 113 so we can add it for people working on the hackathon and in working groups.

For reference, the existing tags are: faq, github_org, github_repo, github_username, gitlab_username, jabber_log, jabber_room, mailing_list, mailing_list_archive, repo, slack, tracker, webpage, wiki, yc_entry, yc_impact

Some options to start us off:
• implementations (display as “Implementations”)
• impl_status (display as “Implementation Status”)
• related_code (display as “Related Code”)

Please reply with other options, or which option you prefer.

You can also chime in on the GitHub issue: https://github.com/intarchboard/program-edm/issues/15

Best,
Tommy
--
Edm mailing list
[email-masked]<mailto:[email-masked]>
https://www.iab.org/mailman/listinfo/edm

--
Edm mailing list
[email-masked]<mailto:[email-masked]>
https://www.iab.org/mailman/listinfo/edm

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 02 Mar 2022 13:30:50 -0800

> On Mar 2, 2022, at 1:23 PM, Charles Eckel (eckelcu) <eckelcu=[email-masked]> wrote:
> 
> 
>> On Feb 18, 2022, at 12:41 PM, Tommy Pauly <tpauly=[email-masked] <mailto:tpauly=[email-masked]>> wrote:
>> 

Robert filed this: https://trac.ietf.org/trac/ietfdb/ticket/3560 <https://trac.ietf.org/trac/ietfdb/ticket/3560>

> I am curious as to the time frame this functionality might be added and if there will be an opportunity to try it out during the IETF 113 Hackathon.

Agreed, if we can get this ahead of IETF 113, we could advertise it in the hackathon and let WG chairs know as well. Robert, what do you expect for timeline?

Tommy
> 
> Cheers,
> Charles
> 
>> 
>> Best,
>> Tommy
>> 
>>> On Feb 4, 2022, at 9:58 AM, Tommy Pauly <tpauly=[email-masked] <mailto:tpauly=[email-masked]>> wrote:
>>> 
>>> You can also chime in on the GitHub issue: https://github.com/intarchboard/program-edm/issues/15 <https://github.com/intarchboard/program-edm/issues/15>
>>> 
>>> Best,
>>> Tommy
>>> -- 
>>> Edm mailing list
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.iab.org/mailman/listinfo/edm <https://www.iab.org/mailman/listinfo/edm>
>> 
>> -- 
>> Edm mailing list
>> [email-masked] <mailto:[email-masked]>

---

From: Robert Sparks <[email-masked]>
Date: Wed, 2 Mar 2022 16:04:23 -0600

It should be available already. The ticket hasn't changed as we have a 
soft-freeze on trac (we're letting people enter new tickets, but making 
as few other changes as possible) as we wrap up the migration to github.

RjS

On 3/2/22 3:30 PM, Tommy Pauly wrote:
>
>
>> On Mar 2, 2022, at 1:23 PM, Charles Eckel (eckelcu) 
>> <eckelcu=[email-masked]> wrote:
>>
>>
>>> On Feb 18, 2022, at 12:41 PM, Tommy Pauly 
>>> <tpauly=[email-masked]> wrote:
>>>
>> Is there a need for an enhancement request to be entered for this, 
>> and if so, what is the mechanism for does so?
>
> Robert filed this: https://trac.ietf.org/trac/ietfdb/ticket/3560
>
>> I am curious as to the time frame this functionality might be added 
>> and if there will be an opportunity to try it out during the IETF 113 
>> Hackathon.
>
> Agreed, if we can get this ahead of IETF 113, we could advertise it in 
> the hackathon and let WG chairs know as well. Robert, what do you 
> expect for timeline?
>
> Tommy
>>
>> Cheers,
>> Charles
>>
>>>
>>> Best,
>>> Tommy
>>>
>>>> On Feb 4, 2022, at 9:58 AM, Tommy Pauly 
>>>> <tpauly=[email-masked]> wrote:
>>>>
>>>> At out last call, we discussed adding a single tag that WG chairs 
>>>> and document authors could use to point to a resource for 
>>>> implementation status/info/guidance/code or interop testing.
>>>>
>>>> The question is what the tag name should be! This is a bikeshed, 
>>>> but we should decide on something before IETF 113 so we can add it 
>>>> for people working on the hackathon and in working groups.
>>>>
>>>> For reference, the existing tags are: faq, github_org, github_repo, 
>>>> github_username, gitlab_username, jabber_log, jabber_room, 
>>>> mailing_list, mailing_list_archive, repo, slack, tracker, 
>>>> webpage, wiki, yc_entry, yc_impact
>>>>
>>>> You can also chime in on the GitHub issue: 
>>>> https://github.com/intarchboard/program-edm/issues/15
>>>>
>>>> Best,
>>>> Tommy
>>>> -- 
>>>> Edm mailing list
>>>> [email-masked]
>>> [email-masked]

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 02 Mar 2022 14:42:33 -0800

Perfect! I do see it now. I didn’t realize that trac wouldn’t reflect that.

Charles, we should be good to go then for the hackathon.

Best,
Tommy

> On Mar 2, 2022, at 2:04 PM, Robert Sparks <[email-masked]> wrote:
> 
> It should be available already. The ticket hasn't changed as we have a soft-freeze on trac (we're letting people enter new tickets, but making as few other changes as possible) as we wrap up the migration to github.
> 
> RjS
> 
>>> On Mar 2, 2022, at 1:23 PM, Charles Eckel (eckelcu) <eckelcu=[email-masked] <mailto:eckelcu=[email-masked]>> wrote:
>>> 
>>>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 3 Mar 2022 22:31:16 +0000

On Mar 2, 2022, at 2:42 PM, Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>> wrote:

Great. Is there documentation on the new tag or how to use it?
I have added tags to drafts while submitting them, but I am not aware of how to add/edit tags for drafts that have already been submitted.

Thanks,
Charles

Best,
Tommy

On Mar 2, 2022, at 2:04 PM, Robert Sparks <[email-masked]<mailto:[email-masked]>> wrote:

RjS

On Mar 2, 2022, at 1:23 PM, Charles Eckel (eckelcu) <eckelcu=[email-masked]<mailto:eckelcu=[email-masked]>> wrote:

Works for me.

Tommy

Cheers,
Charles

Best,
Tommy

Best,
Tommy

---

From: Robert Sparks <[email-masked]>
Date: Thu, 3 Mar 2022 17:35:34 -0600

On 3/3/22 4:31 PM, Charles Eckel (eckelcu) wrote:
>
>> On Mar 2, 2022, at 2:42 PM, Tommy Pauly 
> I have added tags to drafts while submitting them, but I am not aware 
> of how to add/edit tags for drafts that have already been submitted.

For individual drafts, the authors can edit the set of additional 
resources - look for the [Edit] button at "Additional Resources" at 
draft-eckel-edm-find-code, for example.

For wg drafts, the wg chairs (or delegates) are who can edit the 
additional resources (such as at draft-ietf-schmoo-hackathon).

The editing itself is downright clunky at the moment - you get a text 
field to edit that gets parsed.

For draft-eckel-edm-find-code, right now, the set of resources looks like:

github_repo https://github.com/eckelcu/draft-eckel-edm-find-code

You could add an additional implementation by adding a line that looked 
like:

related_implementations https://super.implementation.neverusethis.com

The edit for itself has a small bit of help text.

RjS

>>> It should be available already. The ticket hasn't changed as we have 
>>> a soft-freeze on trac (we're letting people enter new tickets, but 
>>> making as few other changes as possible) as we wrap up the migration 
>>> to github.
>>>
>>> RjS
>>>
>>>>> I am curious as to the time frame this functionality might be 
>>>>> added and if there will be an opportunity to try it out during the 
>>>>> IETF 113 Hackathon.
>>>>
>>>> Agreed, if we can get this ahead of IETF 113, we could advertise it 
>>>> in the hackathon and let WG chairs know as well. Robert, what do 
>>>> you expect for timeline?
>>>>
>>>> Tommy
>>>>>
>>>>> Cheers,
>>>>> Charles
>>>>>
>>>>>>
>>>>>> Best,
>>>>>> Tommy
>>>>>>
>>>>>>> At out last call, we discussed adding a single tag that WG 
>>>>>>> chairs and document authors could use to point to a resource for 
>>>>>>> but we should decide on something before IETF 113 so we can add 
>>>>>>> it for people working on the hackathon and in working groups.
>>>>>>>
>>>>>>> For reference, the existing tags are: faq, github_org, 
>>>>>>> github_repo, github_username, gitlab_username, jabber_log, 
>>>>>>> jabber_room, mailing_list, mailing_list_archive, repo, slack, 
>>>>>>> tracker, webpage, wiki, yc_entry, yc_impact
>>>>>>>

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 08 Mar 2022 12:50:46 -0800

I’ve added an example for Binary HTTP Messages, with two implementations, here:

https://datatracker.ietf.org/doc/draft-ietf-httpbis-binary-message/ <https://datatracker.ietf.org/doc/draft-ietf-httpbis-binary-message/>

The tags for that were:

related_implementations https://github.com/chris-wood/ohttp-go (Go Implementation)
related_implementations https://github.com/martinthomson/ohttp (Rust Implementation)

I’ll send info about how to use the tag to the WG chairs list.

Thanks,
Tommy

> On Mar 3, 2022, at 3:35 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
> 
>>> On Mar 2, 2022, at 2:42 PM, Tommy Pauly <tpauly=[email-masked] <mailto:tpauly=[email-masked]>> wrote:
>>> 
> For individual drafts, the authors can edit the set of additional resources - look for the [Edit] button at "Additional Resources" at draft-eckel-edm-find-code, for example.
> 
> For wg drafts, the wg chairs (or delegates) are who can edit the additional resources (such as at draft-ietf-schmoo-hackathon).
> 
> The editing itself is downright clunky at the moment - you get a text field to edit that gets parsed.
> 
> github_repo https://github.com/eckelcu/draft-eckel-edm-find-code <https://github.com/eckelcu/draft-eckel-edm-find-code>
> You could add an additional implementation by adding a line that looked like:
> 
> related_implementations https://super.implementation.neverusethis.com <https://super.implementation.neverusethis.com/>
>>>> On Mar 2, 2022, at 2:04 PM, Robert Sparks <[email-masked] <mailto:[email-masked]>> wrote:
>>>>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 9 Mar 2022 17:36:37 +0000

I tried this out with my draft, https://datatracker.ietf.org/doc/draft-eckel-edm-find-code/. It worked well. I also sent a note to the hackathon list encouraging its use.

Is there a way to use this for existing RFCs?

Thanks,
Charles

On Mar 8, 2022, at 12:50 PM, Tommy Pauly <[email-masked]<mailto:[email-masked]>> wrote:

https://datatracker.ietf.org/doc/draft-ietf-httpbis-binary-message/

The tags for that were:

Thanks,
Tommy

On Mar 3, 2022, at 3:35 PM, Robert Sparks <[email-masked]<mailto:[email-masked]>> wrote:

related_implementations https://super.implementation.neverusethis.com<https://super.implementation.neverusethis.com/>

RjS

Thanks,
Charles

Best,
Tommy

RjS

Works for me.

Tommy

Cheers,
Charles

Best,
Tommy

Best,
Tommy

---

From: Robert Sparks <[email-masked]>
Date: Wed, 9 Mar 2022 11:59:43 -0600

On 3/9/22 11:36 AM, Charles Eckel (eckelcu) wrote:
> I tried this out with my draft, 
> https://datatracker.ietf.org/doc/draft-eckel-edm-find-code/. It worked 
> well. I also sent a note to the hackathon list encouraging its use.
>
Yes, chairs can edit the resources for RFCs that are attached to their 
groups. Otherwise you would have to ask the secretariat to add the links 
(via a request to [email-masked]).
>
> Thanks,
> Charles
>
>> On Mar 8, 2022, at 12:50 PM, Tommy Pauly <[email-masked]> wrote:
>>
>>>> I have added tags to drafts while submitting them, but I am not 
>>>> aware of how to add/edit tags for drafts that have already been 
>>>> submitted.
>>>
>>>>>> It should be available already. The ticket hasn't changed as we 
>>>>>> have a soft-freeze on trac (we're letting people enter new 
>>>>>> tickets, but making as few other changes as possible) as we wrap 
>>>>>> up the migration to github.
>>>>>>
>>>>>> RjS
>>>>>>
>>>>>>>> Is there a need for an enhancement request to be entered for 
>>>>>>>> this, and if so, what is the mechanism for does so?
>>>>>>>
>>>>>>>> added and if there will be an opportunity to try it out during 
>>>>>>>> the IETF 113 Hackathon.
>>>>>>>
>>>>>>> Agreed, if we can get this ahead of IETF 113, we could advertise 
>>>>>>> it in the hackathon and let WG chairs know as well. Robert, what 
>>>>>>> do you expect for timeline?
>>>>>>>
>>>>>>> Tommy
>>>>>>>>
>>>>>>>> Cheers,
>>>>>>>> Charles
>>>>>>>>
>>>>>>>>>
>>>>>>>>> Best,
>>>>>>>>> Tommy
>>>>>>>>>
>>>>>>>>>> chairs and document authors could use to point to a resource 
>>>>>>>>>> for implementation status/info/guidance/code or interop testing.
>>>>>>>>>>
>>>>>>>>>> The question is what the tag name should be! This is a 
>>>>>>>>>> bikeshed, but we should decide on something before IETF 113 
>>>>>>>>>> so we can add it for people working on the hackathon and in 
>>>>>>>>>> working groups.
>>>>>>>>>>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 9 Mar 2022 22:39:37 +0000

On Mar 9, 2022, at 9:59 AM, Robert Sparks <[email-masked]<mailto:[email-masked]>> wrote:

Is there a way to use this for existing RFCs?
Yes, chairs can edit the resources for RFCs that are attached to their groups. Otherwise you would have to ask the secretariat to add the links (via a request to [email-masked]<mailto:[email-masked]>).

Great. Thanks Robert.

Cheers,
Charles

Thanks,
Charles

The tags for that were:

Thanks,
Tommy

RjS

Thanks,
Charles

Best,
Tommy

RjS

Works for me.

Tommy

Cheers,
Charles

Best,
Tommy

Best,
Tommy