Subject: Fwd: [edu-team] Document Lifecycle class proposal for IETF 70

From: Alice Hagens <[email-masked]>
Date: Wed, 25 Jul 2007 09:22:41 -0500

Begin forwarded message:

> From: "Spencer Dawkins" <[email-masked]>
> Date: June 25, 2007 11:48:29 AM CDT
> To: "EDU Team" <[email-masked]>
> Subject: [edu-team] Document Lifecycle class proposal for IETF 70
>
> As discussed on previous calls - Alice and I talked last week, and
> this is more or less where we ended up. We aren't thinking of large
> amounts of new material, so it's mostly combining slide sets and then
> deleting the parts we don't want to include immediately.
>
> Our IETF 70 plan is to do a document lifecycle class, based on slides
> from WG leadership and from RFC Editor training tutorials. We might
> remove these slides from the other tutorials someday, but not before
> IETF 70, and we don't expect Document Lifecycle to be offered at the
> same IETF as the other tutorials.
>
> SHORT overview of "where RFCs come from" - there are actually *5*  
> streams
>
> SHORT WG process overview, mostly pictures and pointers.
>
> The document lifecycle roadmap, mostly pictures and pointers
>
> Content of a 00 Internet Draft - required and suggested
>
> One slide on XML2RFC and pointer to tutorial
>
> Steps during individual-author draft stage (all the following sections
> are explained from
> the author's perspective)
>
> Steps during WG draft stage
>
> Steps during IETF Last Call/IESG evaluation stage
>
> Steps during post-approval stage
>
> Please let us know if you think we were supposed to produce a
> different concept - if we're good on the concept, please let us know
> and we'll start slicing slides.
>
> Spencer
>
>
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/edu-team

_______________________________________________
edu-team mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/edu-team

---

From: Alice Hagens <[email-masked]>
Date: Wed, 25 Jul 2007 10:45:43 -0500

Hi, Spencer,
Here are a few notes on the doc. lifecycle class from the edu team  
meeting today. Hopefully the team will chime with corrections/ 
comments. Also, I think Margaret will send the minutes.

1) Make sure to clarify:

- the difference between types of documents in the IETF stream:
   WG / individual (can't be STD) / AD-sponsored (can be STD)

- the definition & politics of deciding the category of a document
   for example, informational vs. experimental

- the difference between
   Individual (IETF)
   Independent (RFC Editor: www.rfc-editor.org/indsubs.html)

- can a company's highly patented tech be published as informational?
   (led to "covering IPR" below)

2) Point to 4 docs below and provide some *why*
for choosing among/within streams. for example,
why choose AD-sponsored vs. Independent

- 4845 on the IAB stream
- 4846 on the Independent stream
- http://www.ietf.org/IESG/content/ions/ion-ad-sponsoring.html
   on AD-sponsored documents
- 4844 on the RFC Series and RFC Editor
   (this one is not as relevant to this tutorial, IMHO)

3) covering IPR
point to newcomer slides and RFC 3669

4) covering XML2RFC

- point to the docs on xml.resource.org instead of the xml2rfc tutorial
because the tutorial needs to be updated to be useful

- can Henrik's tools tutorial be combined with xml2rfc?
for example, 15 min. on xml2rfc in the tools tutorial.
another option: a tutorial that covers microsoft word, xml2rfc, nroff
meta-issue: Is the edu team actively encouraging xml2rfc?

5) Where do the WG leadership & RFC tutorials go now?
As Spencer wrote: not at the same IETF.
[option: email the WG chairs a link to the WG leadership slides]

6) deadline for a draft of the slides: Nov. 2