Subject: [edu-team] Do you have any suggestions for what should be included in an OAM tutorial?

From: Radia Perlman <[email-masked]>
Date: Wed, 28 Dec 2011 10:18:14 -0800

After poking around, Tissa Senevirathne  from Cisco (Idwas recommended as
someone who could prepare and teach an OAM tutorial. He's enthusiastic, and
has volunteered to have a first draft of the slides done at least a month
before the IETF meeting.  I talked to him for awhile, and he was explaining
about the subtleties like needing to make sure that "ping" messages follow
exactly the same route, and code path, as regular data packets, so cannot
look different to intermediate nodes, and implications of things like
multipathing or asymmetric routes.  And also, give an overview of various
protocols, (ping, traceroute, reverse traceroute, MPLS-TP, BFD), how they
interrelate/overlap...Also, the typical types of things that go wrong in
networks, and how they get diagnosed using the available tools.

Do you have any other suggestions as to what should be included in an OAM
tutorial?

Thanks,

Radia

---

From: Scott O Bradner <[email-masked]>
Date: Wed, 28 Dec 2011 13:21:54 -0500

a comparison between OAM in the teleco carrier world and the IP network world would be good
as would the inclusion of the MPLS OAM technology (not just MPLS-TP)

Scott

On Dec 28, 2011, at 1:18 PM, Radia Perlman wrote:

> After poking around, Tissa Senevirathne  from Cisco (Idwas recommended as someone who could prepare and teach an OAM tutorial. He's enthusiastic, and has volunteered to have a first draft of the slides done at least a month before the IETF meeting.  I talked to him for awhile, and he was explaining about the subtleties like needing to make sure that "ping" messages follow exactly the same route, and code path, as regular data packets, so cannot look different to intermediate nodes, and implications of things like multipathing or asymmetric routes.  And also, give an overview of various protocols, (ping, traceroute, reverse traceroute, MPLS-TP, BFD), how they interrelate/overlap...Also, the typical types of things that go wrong in networks, and how they get diagnosed using the available tools.
>  
> Do you have any other suggestions as to what should be included in an OAM tutorial?
>  
> Thanks,
>  
> Radia
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Thomas Narten <[email-masked]>
Date: Wed, 28 Dec 2011 13:29:45 -0500

What would be a good OAM tutorial?

Let me suggest something a little different.

What I would (personally) find useful is a tutorial from multiple
perspectives.

If you look at Trill, it has a real OAM gap right now that needs
filling. But I don't get the sense there are a lot of experts working
in that area within Trill.  Not Good. (Tissa is doing work in Trill,
but I think more and broader perspective is needed.)

IEEE 802.1 has OAM for Ethernets. I'd find it useful to get an
overview of what they have, what they do, what works, and a
perspective from operators as to whether what they have is adequate.

MPLS has OAM. Would be useful to get a similar overview, and in
particular how it differs from other OAM and why.

And as Scott suggests, a telco perspective would be useful as well.

My fear is that getting a perspective from just one group is a start,
but may not be all that helpful.

And in today's world, its getting harder to segment OAM into differnet
spaces. I.e., you have Ethernet and Trill like approaches running
across telco links...

Thomas

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 29 Dec 2011 08:09:48 +1300

Right. There is an enormous gap in perception between the telco
view of OAM and the 'traditional' ISP view of OAM, and many
tensions in the I* world (* = ETF | TU | SP) come from this.
Somehow it would be good to get IETF people aware of both
perspectives and what they should do in protocol design as a
result.

Regards
   Brian

---

From: Ronald Bonica <[email-masked]>
Date: Wed, 28 Dec 2011 14:10:32 -0500

He might want to talk about how traceroute works through MPLS or GRE tunnels. Also MPLS has its own PING/TRACEROUTE facility.

He might also talk about common ISP practice regarding ICMP filtering.

                                                                                               Ron

From: Radia Perlman [mailto:[email-masked]]
Sent: Wednesday, December 28, 2011 1:18 PM
To: Romascanu, Dan (Dan); Ronald Bonica
Cc: EDU Team
Subject: Do you have any suggestions for what should be included in an OAM tutorial?

Thanks,

Radia

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 29 Dec 2011 10:00:03 +1300

> ... about common ISP practice regarding ICMP filtering

In particular, how it can break PMTUD if done wrongly, leading
to help desk calls.

Actually some discussion of high-level goals like avoiding help
desk calls and meeting SLAs would be useful too. I was amused
recently to hear my university's IT boss remark cheerfully that
she'd met her formal 99% up time requirement despite a day's
complete outage of the web site. Discussing where reality lies
between 99% and 99.999% seems quite important.

Regards
   Brian

On 2011-12-29 08:10, Ronald Bonica wrote:
> ------------------------------------------------------------------------
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 29 Dec 2011 11:28:06 +0100

I agree that a layered view (from Ethernet to tunnels) would be a useful
perspective to be presented in the tutorial. 

I would however correct the statement made by Thomas (' IEEE 802.1 has
OAM for Ethernets') which is not fully accurate. 

IEEE 802.3ah defined first an OAM protocol for Ethernet on the First
Mile (EFM)  
IEEE 802.1ag was the first project that defined an OAM layer
(Connectivity Fault Management) for IEEE 802.1 bridged networks, several
other completed or work-in-progress projects extended this

Regards,

Dan

> -----Original Message-----
> From: Thomas Narten [mailto:[email-masked]]
> Sent: Wednesday, December 28, 2011 8:30 PM
> To: Radia Perlman
> Cc: Romascanu, Dan (Dan); Ronald Bonica; EDU Team
> Subject: Re: [edu-team] Do you have any suggestions for what should be
> included in an OAM tutorial?
>

---

From: Thomas Narten <[email-masked]>
Date: Thu, 29 Dec 2011 07:11:51 -0500

> OAM for Ethernets') which is not fully accurate.

See, this proves my point. :)

> Mile (EFM) IEEE 802.1ag was the first project that defined an OAM
> layer (Connectivity Fault Management) for IEEE 802.1 bridged
> networks, several other completed or work-in-progress projects
> extended this

One of the things I'm hearing but don't fully understand is that the
standard OAM suite works just fine over SPB.

But it does not for Trill (because Trill has different properties
about paths - they are not symetric). That means Trill has to invent
something different for OAM. That is probably not a feature.

Thomas