Subject: [edu-team] Tutorials for IETF 83 in Paris

From: Mirjam Kuehne <[email-masked]>
Date: Tue, 20 Dec 2011 14:12:04 +0100

Dear Edu Team,

Registration for IETF 83 will open soon and the secretariat would like 
to include the list of tutorials. So, what shall we do?

1. Newcomers (Scott, are you planning to be in Paris?)

2. Newcomers in French (Does anyone remember who gave the french 
Newcomer's in Paris last time?)

3. Alice, do you want to do Document Lifecycle again?

4. We spoke about an operations and management tutorial. Radia, I 
believe you were in touch with potential presenters (Tissa Senevirathne, 
Dave Ward, Adrian?)

5. Do we want to offer the DNS for Programmers tutorial again?

Other ideas? Comments? Feedback?

Regards,
Mirjam

---

From: Radia Perlman <[email-masked]>
Date: Tue, 20 Dec 2011 09:58:01 -0800

For OAM...I did talk to Tissa, and I think he would do an excellent job.
He is articulate and knows his stuff, and can discuss things
conceptually...like the challenge of having intermediate devices forward an
OAM message *exactly* like they would a data message, and yet have the end
device that is supposed to report back, know that it's OAM.  And the
challenge of discovering the "route" when there is multipathing.

I didn't want to tell him to do too much work unless the edu team gave him
a slot.  I can help review the materials, and other people have volunteered
as well.

It might be nice for the DNS one to include DNSSEC.

I could do security or routing, but I think it would be nice to introduce
an OAM tutorial.

Radia

On Tue, Dec 20, 2011 at 5:12 AM, Mirjam Kuehne <[email-masked]> wrote:

> Dear Edu Team,
>
> Registration for IETF 83 will open soon and the secretariat would like to
> include the list of tutorials. So, what shall we do?
>
> 4. We spoke about an operations and management tutorial. Radia, I believe
> you were in touch with potential presenters (Tissa Senevirathne, Dave Ward,
> Adrian?)
>
> ______________________________**_________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/edu-team<https://www.ietf.org/mailman/listinfo/edu-team>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 21 Dec 2011 10:20:29 +1300

I agree about OAM; it's a classical case of a topic that may affect
every WG in the IETF. Please check with the O&M ADs on aspects
that especially need to be better understood by the IETF.

BTW, I have no record of who gave the French language newbies talk
in 2005. SOP is to ask Ray Pelletier for a local contact.

Regards
   Brian

On 2011-12-21 06:58, Radia Perlman wrote:
> ------------------------------------------------------------------------
> 
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team

---

From: Alice Hagens <[email-masked]>
Date: Tue, 20 Dec 2011 16:35:33 -0500

How about a new 'Introduction to IETF Tools' (last given at IETF 69 by Henrik - http://www.ietf.org/proceedings/07jul/slides/ToolsTut-0.pdf) to help a newer IETFer make use of the tools out there?  It could be an overview of what's available and a demo of the essentials. It could be organized into topics similar to tools.ietf.org main page, and hopefully created/presented with the help of the tools team. For rough example:

1) Prepare documents
- [briefly] xml2rfc / NroffEdit / Word template 
- I-D nits
- I-D Submission Tool

2) Search and view documents
- Datatracker basics
- tools.ietf.org HTML versions
- Retrieve from search bar (IETF Doc Fetch)
- Diff tool options

3) Be aware and communicate
- Daily Dose
- using WG wikis
- using email aliases
- RSS feeds available

4) Follow an IETF meeting
- agendas available
- apps available
- remote participation

5) Formal languages / compliance
- where to find ABNF parsers, MIB review tools
- validate the signature of an I-D

On Dec 20, 2011, at 8:12 AM, Mirjam Kuehne wrote:

> Dear Edu Team,
> 
> Registration for IETF 83 will open soon and the secretariat would like to include the list of tutorials. So, what shall we do?
> 
> 2. Newcomers in French (Does anyone remember who gave the french Newcomer's in Paris last time?)
> 
> 4. We spoke about an operations and management tutorial. Radia, I believe you were in touch with potential presenters (Tissa Senevirathne, Dave Ward, Adrian?)
>

---

From: Radia Perlman <[email-masked]>
Date: Tue, 20 Dec 2011 13:52:28 -0800

Definitely.  And it would be good if we could additionally capture this
permanently somehow, because I assume the ppt of the presentation will not
be completely self-describing.  Can we video it and post the video along
with the slides?

Perhaps ppt with extensive "speaker notes"?

Or some sort of on-line tutorial with links to things?

Radia

On Tue, Dec 20, 2011 at 1:35 PM, Alice Hagens <[email-masked]> wrote:

> How about a new 'Introduction to IETF Tools' (last given at IETF 69 by
> Henrik - http://www.ietf.org/proceedings/07jul/slides/ToolsTut-0.pdf) to
> help a newer IETFer make use of the tools out there?  It could be an
> overview of what's available and a demo of the essentials. It could be
> organized into topics similar to tools.ietf.org main page, and hopefully
> created/presented with the help of the tools team. For rough example:
>
> 1) Prepare documents

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 22 Dec 2011 11:58:49 +0100

Hi Henrik,

Would you be willing to organise (possibly together with others from the 
tools team) another tools training on Sunday at IETF 83 in Paris? Please 
see below some suggestions. It would be great if you could let us know 
asap if you are available in principle, so that the IETF secretariat can 
include it on the registration page. We can then discuss the details 
closer to the meeting.

Kind regards,
Mirjam
IETF Edu-Team

-------- Original Message --------
Subject: Re: [edu-team] Tutorials for IETF 83 in Paris
Date: Tue, 20 Dec 2011 16:35:33 -0500
From: Alice Hagens <[email-masked]>
To: Mirjam Kuehne <[email-masked]>
CC: EDU Team <[email-masked]>

1) Prepare documents

---

From: Mirjam Kuehne <[email-masked]>
Date: Thu, 22 Dec 2011 12:33:38 +0100

Hi,

Thanks for all the feedback! I am going to send this list to the 
secretariat for now:

1. Newcomers Tutorial (speaker:TBD)
2. Newcomers Tutorial in local language (speaker: TBD)
3. Tools Tutorial (TBD) - waiting for Henrik to confirm
4. Operations & Management Tutorial (speaker: TBD)

I hope we will have identified speakers early next year so we can send 
more details.

Happy Holidays to all of you and a successful 2012!
Mirjam

On 20/12/11 10:52 PM, Radia Perlman wrote:
> permanently somehow, because I assume the ppt of the presentation will
> not be completely self-describing.  Can we video it and post the video
> along with the slides?
> On Tue, Dec 20, 2011 at 1:35 PM, Alice Hagens <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     How about a new 'Introduction to IETF Tools' (last given at IETF 69
>     by Henrik -
>     http://www.ietf.org/proceedings/07jul/slides/ToolsTut-0.pdf) to help
>     a newer IETFer make use of the tools out there?  It could be an
>     overview of what's available and a demo of the essentials. It could
>     be organized into topics similar to tools.ietf.org
>     <http://tools.ietf.org/> main page, and hopefully created/presented
>     with the help of the tools team. For rough example:
>
>     1) Prepare documents
>     - tools.ietf.org <http://tools.ietf.org/> HTML versions
>      > Registration for IETF 83 will open soon and the secretariat would
>     like to include the list of tutorials. So, what shall we do?
>      >
>     believe you were in touch with potential presenters (Tissa
>     Senevirathne, Dave Ward, Adrian?)
>      >
>      > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Thu, 22 Dec 2011 17:06:34 -0500

On Dec 22, 2011, at 6:33 AM, Mirjam Kuehne wrote:

> Hi,
> 
> Thanks for all the feedback! I am going to send this list to the secretariat for now:
> 

I expect to be there & ready to give the tutorial

Scott

> I hope we will have identified speakers early next year so we can send more details.
>

---

From: Mirjam Kuehne <[email-masked]>
Date: Fri, 23 Dec 2011 09:40:30 +0100

Thanks, Scott.

So, now we have:

13:00 Newcomers Tutorial in English (Scott Bradner)
15:00 Newcomers Tutorial in French (Alain Durand, Mark Townsley)
13:00 Tools Tutorial (TBD) - waiting for Henrik to confirm
15:00 Operations &  Management Tutorial (Tissa Senevirathne)

I have not yet heard from Henrik. Let's hope he is available.

I know we discussed earlier not to have the two newcomers tutorials in 
parallel. But in this case I thought it would be better not have the 
Tools and O&M tutorial in parallel to allow people to attend both.

Regards,
Mirjam

On 22/12/11 11:06 PM, Scott O. Bradner wrote:
> I expect to be there&  ready to give the tutorial
>
> Scott
>
>> 4. Operations&  Management Tutorial (speaker: TBD)
>>
>>> On Tue, Dec 20, 2011 at 1:35 PM, Alice Hagens<[email-masked]
>>>     - tools.ietf.org<http://tools.ietf.org/>  HTML versions
>>>      >  [email-masked]<mailto:[email-masked]>
>>>     [email-masked]<mailto:[email-masked]>