Subject: [edu-team] list of suggested tutorial topics from meeting surveys

From: Alice Russo <[email-masked]>
Date: Mon, 4 Nov 2013 15:23:51 -0800

EDU team,

Below is a compilation of potentially useful suggestions from recent post-meeting survey results from http://iaoc.ietf.org/surveys.html. They are separated into technical (specific), technical (general), and process. Please speak up if you think any of these should be developed for the future.

Recurring requests among technical: 
- IPv6 (specifically: suggestion to update the WG lunch from IETF 77)
- DNSSEC
- mobility
- Area overviews 

Thanks,
Alice

---------------------------
1. TECHNICAL (specific)
---------------------------

"An tutorial to MPLS and its benefits and use cases compared to other
technologies could be more interesting" [74]

"I think it is time for an RTP/RTSP/RTCP tutorial" [76]

"more very detailed and narrow scoped presentations.. for example how IPv6 ND really works in very picky detail.. or more programming related presentations..etc" [76]

"Would love to hear from operators about how PoPs and NAPs are run and
managed." [76]

"IPv6 for programmers, DNSSEC for sysadmin of zones" [76]

"real-time text as a new real-time communication protocol." [77]

"Use of the DNS for protocols and applications." [77]

"overview of basics, e.g. DHCP, IPv6, DNS, ICMP, MPLS. Overview of what
other SDOs are doing (ITU SG13, SG15, MEF, BBF, ...)" [77]

"YANG data modelling language" [77]

"An ipv6 tutorial would be helpful." [77]

"(The IPv6 tutorial at the WG chair training was useful and should probably be made available to a wider audience.)" [77]

"DNSSEC tutorial?" [77]

"Real-Time Text, Total Conversation. Accessible Internet for people with
Disabilities" [78]

"IPv6 why act now. Issues to note." [78]

"Network Scalability tutorial" [78]

"Internet abuse" [78]

"cloud computing" [78]

"Ipv6. Dnssec." [78]

"End-to-end architecture (since so few know about it any more) and benefits." [78]

"Privacy." [82]

"- Security, IPSec, SSL etc 
- DNS, DNSSec" [82]

"Network Economics" [83]

"new HTTP space (websockets, HTML5...)" [84]

"Internet Routing (BGP) Security" [84]

"SDN technology in general" [85]

"More IEEE-802 stuff" [86]

"SCTP congestion handling" [86]

---------------------------
2. TECHNICAL (general)
---------------------------

"but even more worthwhile would be to have tutorials put on by the various Areas, where maybe at least one tech tutorial is always available as a session choice." [65]

"security, mobility, ..." [76]

"It would be useful to have high-level tutorials on general technology areas or
current issues/states-of-affairs from a networking technology point of view in specific sectors such as enterprise, service provider, academic, financial,
defence, connecting up to the relevant current work in the IETF. Another good
tutorial topic would be relationship between IETF and other SDOs such as IEEE
and ITU-T, joint work and processes, areas of differentiation and overlap, and so on." [77]
 
"1. Technology tutorials - get some WG chairs to give a short presentations (30
mins?) on their area of expertise, so we can get a flavour of other things that are going on. 2. Soft skills: negotiating, influencing, etc." [78]

"I read the NAT slides, I would have like material on IPsec and NAT. I think a
presentation that put all the various mobility strands in the IETF together in
context would be good, but there's a danger of a limited viewpoint rendering it
less than useful." [77]

"Most of the topics should be known by most of the attendees. I propose to
consider completely new tutorials related to working group achievements of WGs
that were recently closed." [78]

"varying informational topics related to different areas (such as intro to
general/routing/applications area etc." [80]

"Perhaps a tutorial on successful research of the IRTF that have had a signficant impact on the global marketplace." [82]

"The technical tutorials need to focus on emerging technology that affects multiple WGs and Areas - a more grunty version of the technical plenary, with deep technical content." [82]

"overview of one or two AREAS (e.g. Ops and Management) at each IETF" [83]

"More on networking technologies (perhaps including recent developments inside and outside the IETF)" [83]

"latest tech issues of the Internet" [85]

"Would be good to have tutorials on all the WGs in the IETF. For each WG, have
the chair put together a team of a few people that go over the problem statement and applicability. This should be done for new working groups (e.g. I2RS comes to mind)" [86]

------------------------
3. PROCESS / ADMIN
------------------------

"Soem of the EDU team tutorials are about how to better utilize the services available to you, or how to better work with the admin teams. It might be nice to have the rfc-editor team discuss new tools that make their jobs easier, such as how xml2rfc can make it easier to get drafts processed quickly, and how the shepherding process can make things progress more smoothly, and so on" [65]

"how to bring accross cross-wg or cross-domain topics (currently, there is lack of coordination, so it seems, between different wg that depend on one another -- or, maybe, I just do not know which route to walk for this with IETF). An example would be 6lowapp, 6lowpan, roll, and smart grid, where viable protocols should exploit some commonalities to keep implementation cost down. Question is how to get various wgs in one room and coordinate things." [76]

"First-time presenter tutorial, Chair tutorial - how to support remote participation" [76]

"IETF IPR Policy: What the "Note Well" statements mean to you." [76]

"1. How to present at the IETF 
 2. The IETF for non-native speakers" [76]

"IANA sectiions in I-Ds / RFCs" [77]

"How to effectively use the xml2rfc tool." [78]

"How about a review of other standards orgs we interact with - people who do
could speak briefly about the content and style of their interaction." [80]

"Document editing; how to be a document shepherd" [82]

"Tools and techniques for preparing drafts (for new authors); like how to use MS-WORD to prepare submissions." [84]

"How to follow RFCs using the RFC tool." [84]

"Draft editing and formating" [84]

"A course on the existing IETF tools as well as internet draft writing would be useful as well." [86]

"Maybe have a quick one on the local area near the venue. IE, show a map of
"where you are" and "other things in the area, like food, that you might want to go visit". We could call it the "general area tutorial". ha ha" [86]

---

From: Alice Russo <[email-masked]>
Date: Mon, 4 Nov 2013 15:31:47 -0800

Additions below are from the IETF 81 survey. (Thanks for the corrected link, Ray.)

Thanks,
Alice

> - IPv6 (specifically: suggestion to update the WG lunch from IETF 77)
"IPv6 deployment, security, optimization" [81]

"Peer to Peer technologies and overview of IETF WGs in this area." [81]

"VOIP/ Video fundementals" [81]

"DNS" [81]

"DNSSEC for zone maintainers" [81]

"DNS (including DNSsec)." [81]

> "SCTP congestion handling" [86]

"I would like to see some more advanced tutorials. Going more in to technical details." [81]

> the chair put together a team of a few people that go over the problem statement and applicability. This should be done for new working groups (e.g. I2RS comes to mind)" [86]

"Many people were discussing a "running a working group" tutorial that would benefit WG chairs (new and old!), WG secretaries, BoF planners, people being educated up to these roles, interested parties." [81]

---

From: Alice Russo <[email-masked]>
Date: Mon, 4 Nov 2013 15:34:19 -0800

correction: from the IETF 79 (Beijing) survey.

On Nov 4, 2013, at 3:31 PM, Alice Russo wrote:

> "IPv6 deployment, security, optimization" [79]
> 
> "Peer to Peer technologies and overview of IETF WGs in this area." [79]
> 
> "VOIP/ Video fundementals" [79]
> 
> "DNS" [79]
> 
> "DNSSEC for zone maintainers" [79]
> 
> "DNS (including DNSsec)." [79]
> 
>> "Privacy." [82]
>> 
> "I would like to see some more advanced tutorials. Going more in to technical details." [79]
> 
>> 
> "Many people were discussing a "running a working group" tutorial that would benefit WG chairs (new and old!), WG secretaries, BoF planners, people being educated up to these roles, interested parties." [79]
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 05 Nov 2013 13:12:04 +1300

Wow. Thanks, Alice.

Regards
   Brian

On 05/11/2013 12:34, Alice Russo wrote:
> _______________________________________________
> edu-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/edu-team
>