Subject: [eman] Charter proposal - identity

From: Bruce Nordman <[email-masked]>
Date: Mon, 20 Sep 2010 09:41:31 -0700

Regarding the proposed charter for the Energy Management Working Group,
I have a comment and a suggestion.

My comment is that as an 'energy' person I am quite pleased that the IETF
is moving in this direction.  I firmly believe that in future most energy in
buildings will be used by devices that have IP connectivity so that having
basic features that support energy concerns is essential.

My suggestion is to add one component to the charter, namely 'identify'.
This is not identify of a specific machine as many protocols do already,
but more on a 'species' basis.  That is, am I a computer, a television,
a refrigerator, a light bulb, etc.  This would not be identifying which
particular one it is (e.g. if multiple identical devices on the same
network).
I envision the device reporting its manufacturer and model number, or
perhaps the Universal Product Code for it, or a URL to the manufacturer's
site with product info, or some combination of these.

I think "identity" could be woven into the existing numbered items
in the charter, perhaps called something like "basic identity" to indicate
that this is not intended to be complex.

Thank you,

--Bruce

-- 
*Bruce Nordman*
Lawrence Berkeley National Laboratory
eetd.lbl.gov/ea/nordman
[email-masked]
510-486-7089
m: 510-501-7943

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 20 Sep 2010 20:02:21 +0200

On Mon, Sep 20, 2010 at 06:41:31PM +0200, Bruce Nordman wrote:
> particular one it is (e.g. if multiple identical devices on the same network).

We do have the ENTITY-MIB. What is missing to apply it to a TV, a
fridge, or a light bulb? If the ENTITY-MIB is too heavy, we have
sysDescr and sysObjectID - which might be all you would excpect from a
light bulb.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Juergen Quittek <[email-masked]>
Date: Mon, 20 Sep 2010 18:37:46 +0000

Hi Bruce,

I fully agree to your statement.

In the current charter proposal there is a sentence stating

   "the framework will address the issues of discovery
    and identification of remote devices"

Do you think this is sufficient or would have a suggestion
for modifying the charter?

Thanks,

    Juergen

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 20 Sep 2010 21:44:00 +0200

This sounds sufficient to me, and it does not preclude using objects
from the existing MIB standard MIB modules as suggested by Juergen S. 

Dan
(speaking as a contributor) 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Juergen Quittek
> Sent: Monday, September 20, 2010 8:38 PM
> To: Bruce Nordman; [email-masked]
> Subject: Re: [eman] Charter proposal - identity
> 
> Hi Bruce,
> 
> > Regarding the proposed charter for the Energy Management Working 
> > Group, I have a comment and a suggestion.
> > 
> > My comment is that as an 'energy' person I am quite pleased 
> that the 
> > IETF is moving in this direction.  I firmly believe that in future 
> > most energy in buildings will be used by devices that have IP 
> > connectivity so that having basic features that support 
> energy concerns is essential.
> > 
> > This is not identify of a specific machine as many protocols do 
> > already, but more on a 'species' basis.  That is, am I a 
> computer, a 
> > television, a refrigerator, a light bulb, etc.  This would not be 
> > identifying which particular one it is (e.g. if multiple identical 
> > devices on the same network).
> > perhaps the Universal Product Code for it, or a URL to the 
> > manufacturer's site with product info, or some combination of these.
> > 
> > I think "identity" could be woven into the existing 
> numbered items in 
> > the charter, perhaps called something like "basic identity" to 
> > indicate that this is not intended to be complex.
> > 
> > Thank you,
> > 
> > --Bruce
>