Subject: [Emu] EAP-GPSK: Feedback Solicited

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 06 Apr 2007 09:07:11 +0200

Hi all,

we have submitted a new EAP-GPSK draft version:
http://www.tschofenig.com/svn/draft-clancy-emu-eap-gpsk/draft-ietf-emu-eap-gpsk-05.txt

ChangeLog:
 - references fixes identified by idnits
 - spell check found a couple misspelled words
 - replaced Hash with MAC
 - fixed key length KDF output for HMAC ciphersuite
 - removed MID references, replaced with Method-ID

Please take a look at it to ensure that we made the changes requested at 
the IETF#68 EMU meeting.

Provide your comments by April, 23rd to allow our chair to continue with 
the publication process.

Ciao
Hannes & Charles

_______________________________________________
Emu mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/emu

---

From: Jouni Malinen <[email-masked]>
Date: Fri, 6 Apr 2007 11:25:14 -0700

> http://www.tschofenig.com/svn/draft-clancy-emu-eap-gpsk/draft-ietf-emu-eap-gpsk-05.txt

If I understood the change correctly, GKDF-X(Y, Z) is now using
AES-128-CMAC if ciphersuite #1 is used. This would require 16-octet key
(Y), but the values passed into GKDF in 6.1.3 are of 1 octet (0x00) and
32 octets (MK). How is this supposed to work?

-- 
Jouni Malinen                                            PGP id EFC895FA

---

From: "Charles Clancy" <[email-masked]>
Date: Fri, 6 Apr 2007 14:46:31 -0400 (EDT)

Jouni,

Good catch -- 0x00 should be 16 octets long and MK should be generated
from GKDF-16 instead.

-- 
t. charles clancy, ph.d.  <>  [email-masked]  <>  www.cs.umd.edu/~clancy