Subject: Re: [Emu] TLS 1.3 and other EAP methods

From: John Mattsson <[email-masked]>
Date: Thu, 31 Jan 2019 16:55:53 +0000

> Alan DeKok <[email-masked]>; wrote:
>
> Hmm... if the changes are too complex, it may be better to have a new document. I have a first draft written, and will be publishing it soon.  It's only about 12 pages, but it goes through a lot of detail that is likely not relevant for the EAP-TLS document.
>

Make sense, let's continue the discussion when you have published the new document. 12 pages of details unrelated to EAP-TLS sounds like a new document.

> It still may be useful to give guidance in the EAP-TLS document.  e.g.:

Agree. I have added the updates you suggested (Type-Code in context_value, paragraph about other TLS-based EAP methods) to the GitHub version. 

Cheers,
John

---

From: Alan DeKok <[email-masked]>
Date: Thu, 31 Jan 2019 14:45:07 -0500

> Make sense, let's continue the discussion when you have published the new document. 12 pages of details unrelated to EAP-TLS sounds like a new document.

  That's a conservative estimate.  And a good chunk of that is TEAP and FAST.  PEAP / TTLS are relatively simple in comparison.  Maybe 2 pages, even with implementation notes on how TLS 1.3 is different from TLS 1.2.

> Agree. I have added the updates you suggested (Type-Code in context_value, paragraph about other TLS-based EAP methods) to the GitHub version. 

  Thanks.  That makes a huge difference.

  Alan DeKok.