Subject: Re: [Emu] EAP Erratum 6154 on RFC 3579:

From: Alan DeKok <[email-masked]>
Date: Fri, 1 Apr 2022 08:16:43 -0400

+1

  Other than that, they look OK, thanks.

> On Apr 1, 2022, at 1:16 AM, Bernard Aboba <[email-masked]> wrote:
> 
> I think the note in eid6259 is now superfluous.  Can we remove it? 
> 
> On Thu, Mar 31, 2022 at 10:09 PM Independent Submissions Editor (Eliot Lear) <[email-masked]> wrote:
> Corrected URLs below:
> 
> On 01.04.22 06:48, Independent Submissions Editor (Eliot Lear) wrote:
> > Ok.
> >
> > I have edited – but not yet verified – the two errata accordingly.  
> > Please see:
> >
> > https://www.rfc-editor.org/errata/eid6154
> > https://www.rfc-editor.org/errata/eid6259

---

From: "Independent Submissions Editor (Eliot Lear)" <[email-masked]>
Date: Fri, 1 Apr 2022 14:25:38 +0200

Ok.  Then I will reject eid6259.

Eliot

---

From: Eliot Lear <[email-masked]>
Date: Fri, 1 Apr 2022 16:56:55 +0200

Ok.  I've updated the errata text.

On 01.04.22 14:16, Alan DeKok wrote:
> _______________________________________________
> Emu mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emu
>

---

From: Oleg Pekar <[email-masked]>
Date: Mon, 4 Apr 2022 11:05:13 +0300

I submitted errata on this https://www.rfc-editor.org/errata/eid6915

On Thu, Mar 31, 2022 at 5:21 PM Alan DeKok <[email-masked]>
wrote:

> On Mar 31, 2022, at 10:05 AM, Oleg Pekar <[email-masked]>
> wrote:
> >
> > It looks like RADIUS RFC 2865, Section "5. Attributes" is ambiguous when
> it talks about the attribute value size:
> >
> > First it says: "The Value field is zero or more octets", then it
> provides 5 possible value data types none of which allows a zero length
> value.
>
>   Yeah.  :(  It's horrible.
>
> > Section "5.26. Vendor-Specific" also says about the value of a
> vendor-specific attribute "The String field is one or more octets".
> >
> > Thus the RFC allows empty values for attributes in general but prohibits
> for any declared types of the attributes.
>
>   Yes.
>
>   RADIUS is weird and terrible.
>
>   Alan DeKok.
>
>